Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 3.1.2 stable (26821)

Recommended Posts

Since I updated to version 3.*, the "~uTorrentPartFile_*.dat" doesn't get deleted automatically when I remove the torrents from the list. Is it a bug or is it the outcome of some setting I may have changed?

Share this post


Link to post
Share on other sites

In first - sorry for my english, i am a russian user.

in many builds of 3-rd edition i see the bug - start or autostart the program not hiding in tray. Check or uncheck this feature in options - program open on full screen and don't want to automatically hide in tray. Please fix it - and thank to you from russian users for very good product:)

Share this post


Link to post
Share on other sites

Upgraded from build 26671 to 26710 and:

1) lost all my torrents (got empty list);

2) now everytime have 100% disk overload;

3) lot of crashes with Force Re-Check.

Problem signature:

Problem Event Name: AppHangB1

Application Name: uTorrent.exe

Application Version: 3.1.2.26710

Application Timestamp: 4f2b0622

Hang Signature: 2f76

Hang Type: 0

OS Version: 6.0.6001.2.1.0.256.6

Locale ID: 1049

Additional Hang Signature 1: a612975e9c14f21cd88c5424010afd90

Additional Hang Signature 2: a722

Additional Hang Signature 3: 3b10bef1d6ef55645cf8b0bd61852c88

Additional Hang Signature 4: 2f76

Additional Hang Signature 5: a612975e9c14f21cd88c5424010afd90

Additional Hang Signature 6: a722

Additional Hang Signature 7: 3b10bef1d6ef55645cf8b0bd61852c88

Share this post


Link to post
Share on other sites

Hmm, I guess my memory usage problem was cache related. I disabled the uTorrent caches (and enabled Windows caching) and my memory usage dropped below 80 MB.

CPU usage also went from 20% to less than 5% by doing this.

Share this post


Link to post
Share on other sites

I have two files which have no label, downgrading to 3.0 shows them, updating to 3.1.2 makes them disappear even though the label states two files are there. Also I had a torrent in my list which was not showing, I downloaded the .torrent file again and added it over and over but it never reappeared in my list. Downgraded to 3.0 and added the torrent and it popped into the list just fine. Guess I'm back to 3.01, crazy stuff.

Share this post


Link to post
Share on other sites

I installed this utorrent 3.1.2 version clean on a XP Pro computer for the first time. Everything seemed to be working fine. So I set it up to download some torrents and it hummed along nicely for an hour or so, then froze deader 'n a doornail. I tried everything to get it going again, but the computer's firewall (ZA) was also hung, and the computer refused to shut down normally. I had no choice but to press the power button to restart the computer. After restarting utorrent, no data was lost, and it is resuming download of the torrents again. Will it freeze again...?

Share this post


Link to post
Share on other sites

-- 2011-11-22: Version 3.1 Release Candidate 1 (build 26495)

- Change: enable windows disk cache for writes by default. Improves write performance, especially with sparse files

So how come windows disk cache for writes is still disabled on this version?

Share this post


Link to post
Share on other sites

Can not remember to add a task window for the screen of the X-axis and Y axis, each return to a specific location, but after 3.1, the window size can remember. This is also an old problem.

S6XWH.jpg

Share this post


Link to post
Share on other sites
Probably for as long as you rely on zonealarm to protect you (it won't really protect you that much)

Then forever, I guess, because I have no plans to get rid of ZA. I like it. I doubt it was the cause, although it was obviously involved. utorrent has been granted full permissions by ZA, and the utorrent port is opened in the router.

That Win XP Pro SP3 computer has no history of freezes nor problems with ZA. Only with utorrent 3.1.2 running, the very first time it has ever happened.

utorrent has continued to run OK for several hours since then, downloading torrents, no more freezes (yet). So possibly the new utorrent installation wasn't fully initialized and needed a computer reboot anyway (which it didn't have previously). That might indicate a utorrent installer problem.

Share this post


Link to post
Share on other sites

This post is for those that have disk overload

Tested today at high speeds (down/upload simultaneously) with this settings no disk overload after you make these changes restart utorrent :

6e2dd9173665075.jpg

31642d173665076.jpg

b7bdac173665077.jpg

if you still have disk overload problems perform a clean install,when you update utorrent exit the program down from official site last build an then install .....If I encounter any disk overload I will let you now

Share this post


Link to post
Share on other sites

Hi MirceaForce!

I will try your settings, though I like to keep my manual cache at the max of 1800 (would have it higher if the program allows). Will let you know how it goes when I get around to re-starting it :

(Oh, I also have Rafi's diskio.coalesce_write_size setting in the Advanced - Rafi, can that setting go any higher?)

Thanks!

Share this post


Link to post
Share on other sites

uTorrent 3.1.2 (Build 26729) is still generating .torrent files that are poorly indexed and have non-standard hashes. Below all of this text are 2 links - 1 is for a .torrent file created using 3.1.2 of an entire directory, the other is for a .torrent file created using 3.0 of the SAME directory. I've recreated the .torrent file using 3.1.2 upon the release of each new build hoping that the issues would be corrected, however they have yet to be. You'll notice that the first link (the one that was improperly indexed) does still work, however most sites will reject posting it because of its "corruption". The other .torrent file would technically work, however it's never been used (seeded) so it won't actually work. I've just posted these for troubleshooting purposes.

http://www.mediafire.com/?k250d09odwwqk5p - .torrent created in 3.1.2 (improperly indexed)

http://www.mediafire.com/?qrbvn96cx6aw1xn - .torrent created in 3.0 (properly indexed)

Share this post


Link to post
Share on other sites

Build 26729

I am now having disk overload problems as experienced and posted by many others. Windows 7 64-bit, i7 2760QM, running wireless (300Mbps 5Ghz), writing out to local disk or to NAS does not seem to make any difference.

Preallocate is enabled, and my disk cache settings are identical to those in rafi's "tips" thread.

I have increased the cache manually which sent the torrents to 100% but now they are stuck "Flushing to disk" but there are no disk writes being performed at all despite all torrents having finished downloading to the cache.

uTorrent is now sitting here doing nothing whatsoever with a bunch of torrents stuck "Flushing".

If it werent for the RSS implementation (have tried other clients and they dont seem to have the RSS flexibility), I would be "flushing" uTorrent right about now.too.

How can something seemingly so simple as saving a file be so difficult?

edit: Cancelled 3 remaining with "flushing" status, relaunched uTorrent - cache is filling again with no disk writes at all:

7518356.jpg

Share this post


Link to post
Share on other sites

Utorrent is still freezing on me.

I have posted for help in the troubleshooting area, but no one has replyed.

I am not that good with computers, but i have tryed everything i can possibly think of.

If i understand correcly it's because of a process i need to stop, i just don't know wich one!

Can someone please help me!!

Share this post


Link to post
Share on other sites
3) lot of crashes with Force Re-Check.

Problem signature:

I had a similar issue, with re-checking a large torrent with many internal files, some "skipped".

I think that uTorrent does not crash, the GUI just hangs/stalls. If you wait long enough time - it will free itself... Of cuase, it should be fixed :P

Share this post


Link to post
Share on other sites

One thing about the "Completed" category in the utorrent's interface main window:

apart from the finished/seeding torrents

it also displays the items that have been loaded as magnet links and are not started (their status: Stopped 0.0%).

I've noticed this in all latest utorrent releases.

Share this post


Link to post
Share on other sites
it also displays the items that have been loaded as magnet links and are not started (their status: Stopped 0.0%).

0% = 100% if the size is 0 (or blank... ) so it is "complete" ... :P

I would say that adding a magnet link should be automatically followed by loading the torrent file itself. Thus, problem solved...

Share this post


Link to post
Share on other sites

I would say that adding a magnet link should be automatically followed by loading the torrent file itself. Thus, problem solved...

+1

Share this post


Link to post
Share on other sites
(Oh, I also have Rafi's diskio.coalesce_write_size setting in the Advanced - Rafi, can that setting go any higher?)

I have it set to ~4000000 . Sure, you can experiment higher ...

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.