Jump to content

Resume.dat wiped after upgrade to 3.1.2


Recommended Posts

I'm having a problem regarding torrent resumes that's... Eh, driving me crazy.

I used uTorrent 3.0 (build 26473), and it worked correctly, no problems at all. There are ~55 active torrents in my seedlist, and resume.dat grew to ~400kb. I'm running uT from a portable drive which is always mounted to the same drive letter.

But then I upgraded to 3.1.2. (build 26773), and the resume.dat got corrupted. It doesn't happen all the time, which is most surprising. The new version wrecks the resume.dat after first run, but sometimes it works for 3 runs then whacks the resume (filesize = 99).

I can save a copy of the resume.dat, then overwrite it over the whacked file, and everything works alright until I restart uT. When the loading time is <1sec, everything is alright. When uT loads 3+ seconds, it shows a message "Running in portable mode, exit before unmounting drive...etc." and the resume.dat is wiped out.

I tried BEncode 0.7.1 and it validated resume.dat without problems. Chkdsk showed no disk corruption. Build 26773 just trashes the resume of no particular reason. So far, I'm using the old version (26473).

Also, one thing I noticed, uT 3.0 stores path to torrent files as absolute (e.g. F:\Movies\), while 3.1.2. auto-renames paths to relative (..\..\..\movies).

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...