Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 3.1.3 stable (27327)

Recommended Posts

This release changes several default options to match older releases more and be less confusing to returning users.

It also adds a few more fixes.

Download the new version now!

Release highlights:

  • Change: default UI is now the columns/advanced view (like 2.x)
  • Change: re-add several columns by default
  • Fix: anti-virus issue

For a list of feature changes and how to customize things they way you like, http://download.utorrent.com/help/Whats_New.pdf

Changelog:

-- 2012-06-01: Version 3.1.3 stable (build 27327)

- Fix: startup crash when settings.dat was corrupt

- Fix: Improperly formatted torrent vote messages

- Fix: Bad outgoing request_peer DHT message when filename length over 100

- Fix: possible deadlock when reporting a hang

-- 2012-05-14: Version 3.1.3 stable (build 27220)

- Fix: free content offer in installer didn't actually add

-- 2012-05-11: Version 3.1.3 stable (build 27213)

- Fix: UAC prompt would show up for limited users on every run

-- 2012-05-10: Version 3.1.3 stable (build 27207)

- Fix: starting up with Windows had been forcibly disabled for users of 3 previous builds

-- 2012-05-04: Version 3.1.3 stable (build 27167)

- Change: minor installer tweak

-- 2012-04-26: Version 3.1.3 stable (build 27120)

- Fix: minor crash fix

-- 2012-04-23: Version 3.1.3 stable (build 27099)

- Fix: Some missing changes for fixing the window subclassing crash

-- 2012-04-21: Version 3.1.3 stable (build 27096)

- Fix: Fix crash in window subclassing in add torrent dialog

-- 2012-04-20: Version 3.1.3 stable (build 27095)

- Fix: Fix for crash when switching away from the built-in media player

-- 2012-04-19: Version 3.1.3 stable (build 27092)

- Fix: Fix for crash during install

-- 2012-04-18: Version 3.1.3 stable (build 27081)

- Change: turn off btapp autoupdates to work around a crash

-- 2012-04-12: Version 3.1.3 stable (build 27060)

- Fix: settings.dat could grow very large

-- 2012-04-02: Version 3.1.3 stable (build 26994)

- Fix: Hold the lock when doing media state callbacks.

- Fix: Disable "Can't connect to Remote" messages.

- Fix: improve error messages around transcoding

- Fix: Tab order in dialogs

-- 2012-03-09: Version 3.1.3 stable (build 26837)

- Fix: Stop anti-virus updating when there is a error

- Change: show info tab by default (instead of files tab)

- Change: show seeds/peers, completed on and added on columns by default

- Fix: fixed bug where locally created torrents would fail to transcode

Share this post


Link to post
Share on other sites
Fix: fixed bug where locally created torrents would fail to transcode

What was the bug/fix?

Share this post


Link to post
Share on other sites

For those with disk overload issues' date=' open the advanced preferences, and set diskio.use_partfile to false.

[/quote']

On Win2k3 it doesn't really help.

Keep in mind, it only helps for -new- torrents. You'd have to remove and re-add existing torrents.

I do keep it in mind. It doesn't help!

Share this post


Link to post
Share on other sites

hey guys,

what is this "V8 bundle" you're trying to install in my computer that fails all the time?

thanks.

Share this post


Link to post
Share on other sites
Version 3.1.2 stable (build 26821)

- Fix: Check existing files before start downloading the torrent added via magnet link

It is now the next version and still do not see the contents of magnet links... :/

(The content is not visible until the download is in progress)

Share this post


Link to post
Share on other sites
Sometimes torrent's label can't be removed by pressing Enter on this label (marked) in labels' list: the mark is gone but label still exists. Example: http://ifolder.ru/27381237

I believe I found the reason of this issue. It happens when there is the ampersand ('&') inside the label. So I hope you guys will fix it quickly. Now we have only 2 ways to get around this issue - to use either BEncode Editor or v2.

Share this post


Link to post
Share on other sites
Sometimes torrent's label can't be removed

Not sure if you meant this, but for me - there are two issues with labels:

1. I did not find a way to completely remove a label from the list

2. I could not add a label using the RSS downloader "add-new-favorite" dialog, and just writing a new label in there. It used to add it to the labels-list, and now, it is only visible in the RSS dialog :(

Share this post


Link to post
Share on other sites

I get the following on each program start (note I added the [%AppData%] myself to shorten the lines):

[2012-03-10 10:27:41] File not found during integrity check: [%AppData%]\uTorrent\resume.dat

[2012-03-10 10:27:41] File not found during integrity check: [%AppData%]\uTorrent\resume.dat.new

[2012-03-10 10:27:41] File not found during integrity check: [%AppData%]\uTorrent\resume.dat.old

This happens even though resume.enable_resume_dir = *true, and more importantly resume.dir_only = *true.

Share this post


Link to post
Share on other sites

To be precise, if a label contains the ampersand it won't be checked in the label list after marking a torrent with it (by adding a label). A marked torrent has the label, but it stays unchecked - so we can't remove the label in any way.

Share this post


Link to post
Share on other sites
I did not find a way to completely remove a label from the list

A label is gone from the list if no torrents have it checked' date=' isn't it?[/quote']

Hmmm, I guess so... :/ (except for what you've just noted...) Not sure if this is how I would prefer it to be. For me it better to have it stay on the list unless you intentionally delete it.

Anyways, that leaves problem # 2... :)

Share this post


Link to post
Share on other sites

why it doesn't install, 'stop responding' need to kill process then only install. when launch, it won't launch and found 2 processes running, need to kill one then only the app will start.??

Share this post


Link to post
Share on other sites

I can't understand what counting T(total?) counters in status bar.

I download about 70GiB (2 BD) from start of uT, but it shows only 20,4 GiB. Why?

Share this post


Link to post
Share on other sites

Well 3.1.3 screwed me royally. Most of my uploads read - "An operation on a socket could not be performed because the system lacked sufficient buffer space or because a ..." and I lost several downloads (~50gb) because of "Error: The file or directory is corrupted and unreadable."

Additionally, ONCE AGAIN, it does not shut down properly, nor can the process be killed - a re-boot is required.

Sorry, but I will maintain that the 3.1x path is broken, and will remain broken. I will stick with 3.1 (Build 26616) as that is the last one that gave me no problems.

Each release seems to *cause* more problems than it fixes.

Screwing the pooch on this one guys (girls).

Share this post


Link to post
Share on other sites
Still getting duplicated torrents.

http://forum.utorrent.com/viewtopic.php?pid=639722#p639722

Anyone know what it could be?

Maybe a bug? ... :) Probably counting both the resume dir AND resume.dat file.

I have tried turning off resume.dir_only and resume.enable_resume_dir.

Also tried removed the resume_dir folder.

I think I even tried move my resume.dat-file as well.

It works in µTorrent 3.1.2 (build 26746) but no builds after that. =/

I guess this is what caused it: "-- 2012-02-15: Version 3.1.2 stable (build 26749)

- Fix: fixed bug where adding a torrent from cmd line could overwrite the same torrent from resume.dat"

Or it's something else that got changed in that build.

Share this post


Link to post
Share on other sites

I'm having some problems with this last version of ut 3.1.3 ......when down&uploading 10MBdown&10MBuploading the speed isn't distributed correctly......for ex if you uploading at 11MB you will down at 3-4MB even if you have a very good peering(proof below)

-second problem if you down&upload at high speed(10MB) even if you down on one hdd and upload on another and try to watch a mkv 1080p the upload drops down almost to zero. I didn't have this issue with utorrent 3.1.2 please fix this cache problem

796307179317387.jpg

449ce3179317396.jpg

c27cb3179317402.jpg

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.