Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 3.1.3 stable (27327)

Recommended Posts

No. Possibly in the upcoming 3.3 (now in alpha), where they've revised the cache/disk-IO engine.

Share this post


Link to post
Share on other sites

Yes.

3.2 fixes the problem with Magnetic Links.

3.3 fixes Disk Error.

I only use Private Trackers always so no Magnetic Links issue, and never had any problem with µtorrent what so ever, with Disk Error. Been Lucky I think.

Still waiting for the stable version of the above 2 version.

Major upgrade coming in the coming months. :)

Share this post


Link to post
Share on other sites
I dont understand the way you publish code , guys. Version 3.1.3 is still full of problems, and you are delivering a 3.2 Beta and a 3.3 Alpha. All this does not make sense..

OR may be you dont dare to write "3.1 is deely crippled so we ask you to live with it for a few months ? weeks? while we are rewriting Disk-IO etc.."

I still live happilly with my 2.2.1 ;-) Thanks.

It's actually quite simple:

3.1.x is the current release version. As bugs and other issues are fixed, the third number in the version number is increased.

3.2 is the current beta version. This will become the new release version when the developers feel that it is stable enough to go into wide release.

3.3 is the current alpha version. These builds are not expected to be fully stable and are used to test features that may become part of the software later.

When 3.2 becomes the release version, 3.3 will move into beta, and 3.4 will become the next alpha (if I'm remembering how these guys handle that properly).

2.x.x is an unsupported version that may have unresolved bugs and security holes that no one will be able to help you with.

Share this post


Link to post
Share on other sites

This means you have a corrupted settings.dat. Open %AppData%\uTorrent, delete settings.dat and settings.dat.old with uT closed.

Share this post


Link to post
Share on other sites
Our problem:
I don't know. When windows start icon doest appear in systray. Restart uTorrent solve the problem. All like in 2.2. 2.0.4 and 2.2.1 works correctly.

More info about it:

Honestly' date=' it works for me 100% of the time on Windows 7. I need a little more info about your settings and OS.[/quote']

Well, I'm on Windows XP SP3 32-bit. I have all options under System Tray Enabled, but "Show Balloon Notifications". And also have enabled "Start uTorrent when Windows Starts" and "Start Minimized".

For the time being I have made a little batch file to delay uTorrent when Windows starts, for the moment it has worked; but is not the ideal solution.

Something like:

ping -n 40 localhost > nul

start "uTorrent" "<Directory>\uTorrent.exe" /MINIMIZED

Another description for the problem could be that it's like it is on Boss Mode, but I don't even use that option -_-.

Here is my settings.dat: http://www.anonstorage.net/PStorage/602.settings.dat

I re-uploaded my settings.dat: http://www.mirrorcreator.com/files/XT757JVZ/settings.dat_links so it can be checked to see if there is a problem. I tried it again with 3.1.3 build 27220 btw.

Share this post


Link to post
Share on other sites

i find it funny how its called stable, and its nothing but unstable...

just updated to the newest 3.1.3 build and it keeps freezing every other minute... and forgetting what i just did before the freeze...

Share this post


Link to post
Share on other sites
Guest

I am not experiencing any freezes whatsoever.

My only concern is the unwanted and unneeded crap. Yes I mean the excellent free stuff.

Firon or anyone else from the dev team, do you consider paid version with extremely basic functionality? I know this sounds ridiculous (it IS), but with nowadays' trends in software, I would be willing to pay for version without sh*t. Just like what the client ORIGINALLY was. Hell I'd value it at at least $20, possibly even $50. Not because the bloatware actually does anything, but because it simply IS there. I don't want it :P

Share this post


Link to post
Share on other sites
i find it funny how its called stable, and its nothing but unstable...

just updated to the newest 3.1.3 build and it keeps freezing every other minute... and forgetting what i just did before the freeze...

I'd just try 3.2 if I were you. It's been rock solid for me.

Share this post


Link to post
Share on other sites

Seriously UTorrent devs' date=' if you dont fix this bullshit 5 min updating that forces the internet con to drop im removing UTorrent and will use another client! Excuse my language, but having your internet drop for 5 mins every 5 mins during these updates is fucking bullshit!!!

Again, im a full time torrenter of 5 years and never had this problem until i updated to 3.1.3[/quote']

The problem isn't the client. It's your router.

i can ensure you that my top of the line router isn't the problem, nor is any of my top of the line equipment.

This problem has only started happening since i updated the 2 latest builds over the last 30 days, it completely uses up 100% of the upload speed during the 'Updates', but the new build does an update every 20 mins. Its ridiculous!

Still waiting on a update to fix this....

Share this post


Link to post
Share on other sites

It's only you that's having this problem. If you're not prepared to figure out what's going wrong & where then change to another client or drop back to which ever version prevents the problem from occurring, it's really not that difficult.

Share this post


Link to post
Share on other sites
It hangs on occasion with lots of magnet links. This is fixed in 3.2.

I can verify that the 'stable' release hangs always.

Reproduce:

1. Downloads active and downloading at full speed to make the hard drive work / disk io thread.

2. Now add several magnet links at once. Around 5 should do it.

It will hang after a few seconds to a few minutes.

Boom all data that have been downloaded is lost including added magnet links (and probably torrents too) when you force exit the program.

Losing a gig of data is just unacceptable. It should flush more often for data integrity reason. That is what common sense and accepted guide-lines say.

Are you following the guide-lines in 3.2 ?

Workaround:

Use good ol' torrent files. Or use a magnet link to torrent file converter.

Share this post


Link to post
Share on other sites

BTW:

What compression is used on the exe file ? A modified upx ? Where can i download it ?

I can't unpack it anymore with standard upx. I have to use a manually written script now :(

I'm wondering out loud here:

Are you doing something illegal that you need to hide ?

Should i analyze the exe file for evil ?

What is your thinking behind this change ?

(Honest answers only, no PR bullshit)

Note: I unpack utorrent because of false positives, to let anti-virus scan it more clearly and exe compressors cause bugs, instability and is a plain waste of time (and money).

All i care about is that it is portable. It doesn't need to be compressed for that.

Share this post


Link to post
Share on other sites

It's still just normal upx (with --brute --lzma). but maybe the decompressor freaks out on the additional resources at the end.

Anti-virus apps already know how to unpack the executable, so you aren't really getting anything by doing that, and upx has no known bugs or instability problems.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.