Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 3.2 stable (27568)

Recommended Posts

Maybe someone can post a best "settings.dat" file for people to try?

You are welcome to mine... (in my sig/guide...)

Rafi, your settings fit your connection with your ISP, your GUI preferences, your..... I don't think that it fits other users. I have a 1970 car (not really) that is "best" for me. You are welcome to buy a car like mine.

Share this post


Link to post
Share on other sites
Rafi, your settings fit your connection with your ISP,

Thus, there are 3 setting files, for different connection upload rates. Sure, you have to tune it per your bandwidth (not ISP!)/router (# of connections, port# , paths etc.) the basic stuff... But, whatever....

Share this post


Link to post
Share on other sites

So if you have to tune it per ISP/router why not start it from scratch instead of using yours? No user has the same preferences like you.

Share this post


Link to post
Share on other sites

Not per ISP, per connection speed. And yes, you can use your own. In my experience, my advanced settings are good, better then the defaults for some, so I just post them for other people if they want to.

Share this post


Link to post
Share on other sites

While the bug of new build (27020) is fixed, could you put the link to download the previous build (26986)?.

Thanks. ;)

Share this post


Link to post
Share on other sites

Every 3.xx version upload very slow for me. Upload is around 100-150 Kb/s when my max is 900-1000 kb/s. I don't know what going on but on the same setting 5 min later 2.2.1 verion upload 700-900 kb/s

Share this post


Link to post
Share on other sites

I found these another bugs in latest release (27020):

1. Since I execute uTorrent, take a few minutes, several, to appears the program window. :/

2. When I open a torrent file, this torrent not load it in uTorrent immediately, as must be, run another uTorrent process in background, and takes a few minutes to load that file in the program. :o

Share this post


Link to post
Share on other sites

can anyone help me? I'm getting autoupdate error every time.. it doesnt say what error happened, just say it couldnt update!

Share this post


Link to post
Share on other sites
Not per ISP, per connection speed. And yes, you can use your own. In my experience, my advanced settings are good, better then the defaults for some, so I just post them for other people if they want to.

Do whatever you want. I think that you just confuse users to think that your settings are better than theirs, while they don't really fit them.

Share this post


Link to post
Share on other sites

If you're going to keep Folder and "File/Folder" split in the Add dialog then you need to have it retain the \ at the end of the folder side or it always goes one folder higher ever time. Also, it shows the same folder multiple times in the pulldown, instead of just moving the old instance up in the list. I've got the same folders like 40 times.

Share this post


Link to post
Share on other sites
If you're going to keep Folder and "File/Folder" split in the Add dialog then you need to have it retain the \ at the end of the folder side or it always goes one folder higher ever time. Also, it shows the same folder multiple times in the pulldown, instead of just moving the old instance up in the list. I've got the same folders like 40 times.

Agreed. I posted a topic as a bug report on this issue, now I don't know if I should have posted it here or there.

http://forum.utorrent.com/viewtopic.php?id=117126

I believe there's something wrong with the behavior of the new "Save In" and "Name" fields at the AT dialog, presented on the latest 3.2 beta builds.

When I add a torrent, the AT dialog show me two fields:

Save in: which is the directory in which I want to save the files.

Name: Which is the name of the subfolder that will be created inside the "Save in" directory and contain the downloaded files.

When I add a second torrent, the Save In dropdown list should be filled with the path to the directory that I pointed on that same field for previous torrents, but instead it is showing the path that I pointed + the name of the previous torrents downloaded.

For example:

I want to add a torrent named Torrent1.

At the Save In field, I point to X:\Downloads\Music

At the Name field, there is the name of the torrent, Torrent1

So the files will be saved to X:\Downloads\Music\Torrent1

Perfect, so far.

When I add a second torrent, I click the Save In dropdown expecting to select the same previous folder X:\Downloads\Music, so that I can add Torrent2 to it, and then the files would be downloaded to X:\Downloads\Music\Torrent2

But instead, utorrent shows me X:\Downloads\Music\Torrent1 as a Save in option, so I have to either select this option and delete the Torrent1 part of the path (to avoid my files being saved to X:\Downloads\Music\Torrent1\Torrent2), or I have to manually select the X:\Downloads\Music path again.

I believe this totally disrupts the two separate fields function, and because of that I understand that this is a bug.

I think the "Save In" dropdown should show only the exact paths that I selected for that field, so I can easily select different destinations depending on the type of torrent that I'm adding, like:

X:\Downloads\Music

X:\Downloads\Movies

X:\Downloads\Games

Or didn't I understand the function of this new "feature"?

Share this post


Link to post
Share on other sites
Build 27020 and my settings.dat still grows. 3MB now.

Same here :( Reverting back to b26934

Share this post


Link to post
Share on other sites
Nope. Revert to the previous beta

That means i will have to delete my setting.dat file and lose all my stats.

i got half of the dat file opened in word pad. seems like my download path location is places in it million times in a loop.

Or just use the .old-file?

what i did was.. wait 3 hours for 3.2 beta to open then screenshot my stats, after crash it. then uninstall beta and installed 3.1.3. lastly i used btencode to reenter all my stats in the newly created settings.dat.

Share this post


Link to post
Share on other sites

2Firon: Can you describe structure of settings.dat and what kind of its data rapidly growed? May be we can write own script to fix them? (build 27020 load them, but take on reading few minutes + eat ~600MB of memory => it simply contains not required data and it should be possibly to clear it)

thank you.

Share this post


Link to post
Share on other sites
2Firon: Can you describe structure of settings.dat and what kind of its data rapidly growed? May be we can write own script to fix them? (build 27020 load them, but take on reading few minutes + eat ~600MB of memory => it simply contains not required data and it should be possibly to clear it)

thank you.

I checked mine and it was mostly RSS feeds and recent added torrents, I believe.

Line after line repeating, like:

Feed 1

Feed 2

Feed 3

Feed 1

Feed 2

Feed 3

Tried to remove all with a hex editor but it became corrupted when trying to load it.

My settings.dat was about 150 MB before and 20 kB after edit.

BEncoder might've worked to remove all dupes, but waited for about 10 minutes for it to load the original file.

I took an older backed up settings.dat I had and changed my stats with BEncoder instead.

As someone said, the current settings.dat may be hosed forever.

Share this post


Link to post
Share on other sites

I can only suggest to backup your settings.dat *before*/if you use the current beta (that is, if this is still an option...). I can only recommend to wait for a proper fix before you upgrade your release to the last two betas. The last good beta (not having this issue) is build 26394.

Share this post


Link to post
Share on other sites
nothing is broken...

It's broken, or blocked, or whatever you call it, I attach a screenshot so you can see for yourself. The page show a error message that says: "File Blocked for Violation."

screenynf.png

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.