Jump to content

uTorrent speed limiting broken?


Recommended Posts

After the last update I've gotten a really weird problem, the speed limiter stopped working and uTorrent actually "breaks" my internet connection by flooding it, my settings have worked without any issues with many versions before and started just after latest update.

I got a 15/3mbit connection but I've seen uploading numbers over 3MB/sec (even a teoretical impossibility) on uTorrent after this problem started occuring, when uTorrent starts sharing faster than my connection can handle first MSN disconnects, then it becomes impossible to surf and anything else that's online loses connection, so first uTorrent ignores my limit then when it gets past about 350kb/sec (about where my connection maxes out) the connection actually more or less commit suicide until I shut down uTorrent.

Sometimes I know the limiter can "miss" but I've tried removing and reseting it, it looks as if it works for about 1-2sec (speed starts to drop) until getting ignored again also tried reinstalling, anyway I can reset uTorrent (preferably without loosing all the torrents in my list, such a hassle to put them in again).




removed settings file and that seems to have corrected the problem :)

anyone else having similar trouble remove

Computer >> C: >> User >> "your user name" >> AppData >> Roaming >> uTorrent >> settings.dat

(AppData is a hidden folder, you need to edit settings in Windows to see hidden)

Link to comment
Share on other sites

It accepts speed limiter if i tick on the "apply rate limit to uTP connections" option at the "bandwidth" "preferences". Yet it seems the whole thing becomes slower. I guess i have to accept it. This certain torrent doesn't have a great ratio of Seeders/Leechers anyway...

Link to comment
Share on other sites

Have you seen my settings then?...

Anyway, limiter works if i tick the option i wrote about, before. Otherwise it doesn't. I don't know if it has always been on before today, when the problem came. I've been using μTorrent since 2007. Maybe it's the SSD that i recently installed... Who knows...

Link to comment
Share on other sites

Your connections are set insanely high. That is your problem. Limiting will not work with 2000 connections on every torrent. Especially not to 50kbyte/s.

There's no bug here. You just have stupid settings.

The connections worked before, also removing the settings.dat before launch makes the upload limiter work (for one restart), however for some reason also limits the DL speed to 1MB/s so no the amount of connections isn't the problem, I've tried with lower as well and the problem persists.


Will try unticking the uTP setting and see what happens.


seems removing the uTP check lets me restart uTorrent without removing the settings.dat and still having a working limiter, thanks =)


worked twice then limiter crashed again, trying to get an earlier version of uTorrent, giving up on this one

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...