Jump to content

uTorrent interfering with NetBIOS name resolution


Recommended Posts


After installing uTorrent my NetBIOS Remote Cache Name Table wont purge correctly resulting in the loss of connectivity between my other networked computers.


I have uTorrent 3.1.3 (build 26837) installed on Win-XP SP3 Home. I am having trouble with my XP machine on my home network. The network uses only NetBIOS over TCP/IP (No WINS, No LMHOSTS, etc). I have DHCP enabled on my D-link router. I narrowed the problem down to the NetBIOS Remote Cache Name Table on the XP machine. It seems that NetBIOS is holding onto the name and associated IP address of the other computer/(s) even after they have logged off the network and signed back on with a different IP address. Even at a command prompt 'Nbtstat -R' (or -RR) will not purge the name table. This only happens after I have installed uTorrent.


After uninstalling any Optional Networking Components, then uninstalling all the network Clients, Services and Protocols -- including TCP/IP -- I was able to reset my winsock layer by completely rebuilding it. I deleted my winsock registry keys and then reinstalled TCP/IP (this is normally not uninstallable in XP, but there is a way to do it as a search on google revealed). Once I reinstalled TCP/IP, Client for Microsoft Networks, Qos Packet Scheduler, File and Print Sharing, my Winsock was rebuilt and good as new. And guess what? My NetBIOS name problem was fixed. (Note: I have no LSPs installed and MSInfo32 - Network - Protocols shows a clean winsock)

However, as soon as I installed uTorrent the problem returned. In order to verify that uTorrent was the cause I attempted to duplicate the problem. So I uninstaled/reinstalled all networking items and as before me NetBIOS works flawlessly once the winsock is rebuilt. Then I uninstalled/reinstalled uTorrent. As soon as the installer is finished, my NetBIOS problem returns.


The primary symptom of the NetBIOS problem is that the XP-Home computer with uTorrent will stop being able to browse the other Shares across the network when either of the other computer leaves and then rejoins the network and is assigned a new IP. Notice in the picture below that when I try and Purge the remote name table, it says the purge is successful, but if I follow by immediately typing 'nbtstat -c' it shows that the name table is still lingering.


After leaving and then rejoining the network the other two computers, are assigned new IPs by DHCP. But the old IP Addresses are held onto and not resolved to the new addresses. I've tried 'arp -d *', 'ipconfig /flushdns' (and /renew), tried 'Repair' on the wireless adapter. But no matter what I do, the names are resolved to the old NetBIOS IP Addresses! This means I can't share across my network, I can't browse folders, 'My Network Places' keeps saying: "The network path was not found." Here is the result of the two other computers leaving and then rejoining the network and then 'nbtstat -c'. Notice the <20> addresses (Server service) are still there from before and have the wrong IP!


If I rebuild winsock this will no longer happen, but once I install uTorrent this problem will occur. Thus, it seems uTorrent is interfering with how NetBIOS resolves and releases names within the Remote Cache Name Table.

Thanks in advance for any assistance you might provide.

~ Nexus9er

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...