Jump to content

Terrible upload speed rates.


Recommended Posts

I recently upgraded my PC from XP to Windows 7- Home edition via a complete reformat / fresh install, and after mucking around for the past week trying the steps listed in the FAQ and in the numerous stickies around the site, have been unable to get any sort of decent upload rate, both while downloading and while seeding. My Download rate is just fine at 5MB/s, but uploading/seeding rarely takes me into double kB digits, and occasionally I'll spot an error of "no incoming connections" but it'll flip away after a few seconds.

I have tried the following:

Various combinations of enabling / disabling UPnP, NAT-PMP, randomized ports, the uTP algorithm, DHT, also tried enabling / forcing encryption

DMZing my PC,

setting extremely conservative speeds and connection settings that are ~60% of my reported max.

Under the advanced settings, I've tried setting net.max_halfopen to 4 and 2, same for bt.connect_speed to 4 or lower

I've also tried a prior version (2.2.1) as well as Azureus, with the same issues. It's affecting both my private and public trackers, and to confirm I've tried seeding the latest revisions of Ubuntu (both AMD and Intel) as well as grabbing a fresh file from my private tracker, but to no avail.

As of writing this, I've done a fresh install of the latest version, and ran the setup guide, which set my connection to 17.8 Mbits equivalent, and checked that my port is open (60218), so I'm all green there.

My connection and system specs as of posting are as follows:

Verizon FiOS 40Mb up/down max, (only happens during off-hours, usually sits around 20-25ish) last result 1873256268.png

The router/modem they assigned me is an Actiontec MI424WR,

My system specs, as of a dxdiag:

Processor: AMD Athlon II X4 620 (Phenom, 4 CPUs @ ~2.6GHz)

MoBo Manufacturer: ASUS

Memory: 3072 MB

OS: Windows 7 Home Premium 64-bit SP1

Video(Not that it matters): ATI Radeon HD 5700 (~2295 MB)

I can provide a HjT on request, as well as more detailed info, but I won't be able to get back to this for about 6 hours.

Any insight would be appreciated, I've tried just about everything I can think of, even pushing the little reset button on the back of my router. :P

Link to comment
Share on other sites

I originally had the Actiontec on an ont connection as my main for fios but ever since i found out about the small nat table and constant disconnects I switched over to ethernet and added my own router in front of the Actiontec....

No problems since!

Link to comment
Share on other sites

...I switched over to ethernet and added my own router in front of the Actiontec....

No problems since!

I'm connected to my Actiontec via ethernet right now, and if I remember right, it's Revision F (I can check when I get home tonight), so having a table size of 30,000 isSee Edit 2 only 7.5k, which is small but shouldn't be preventing me from seeding / uploading to at least one person (at a rate higher than ~5kBps, given my bandwidth). Also, I never had a problem with it and torrents when I was running XP. Just switching from XP to 7 SHOULDN'T be the culprit, especially on a fresh install.

DSLreports.com page on the Actiontec NAT table

Edit 1: dslreports link

Edit 2: My router's actually Revision D, which means it's NAT table is a lot smaller than what I thought, being only 7.5k instead of 30k, but again,

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...