Jump to content

Dynamic IP? See here!


Recommended Posts

  • Replies 84
  • Created
  • Last Reply
  • 2 weeks later...

Hi all,

I've set up the web interface download as described in the readme. Accessed it and logged on locally using the http://localhost:port/gui/ address. Set up a no-ip thingy and tried to access when away from home but no luck?

Let me clarify that i'm a bit of a novice - so getting utorrent to work in the first place was good going for me.

Hy home pc links to my livebox router wirelessly. I guess that as the livebox holds the internet connection even when my pc is off, the no-ip address is for my livebox... So i'm guessing that when I try and access utorrent when away from home, i'm linking to my router but not my pc.

I've read some emails about port forwarding... had to get my head around that when I set up utorrent in the first place but that was a while ago. Is that what the issue is here, or am I missing something else?

Any help appreciated

Cunfuzed of UK.

Link to comment
Share on other sites

First does the port test in the speed guide of µtorrent itself say your port is open? (No means Port Forward problem)

Second your computer and µtorrent should be running to access the webui remotely (Saying just in case :P)

Make sure you the 'Alternative listening port' option of the Advanced -=> Web UI preferences is disabled.

What DO you get when you try to access from the internet?

Link to comment
Share on other sites

Ahhh... I assumed that if utorrent was u/loading and d/loading torrents ok (which it is), then port forwardng was fine. Done the test and it appears that I have a port forwarding problem! Looking into that and will come back if still stuck.


Yep - still stuck...

Port forwarded fine now - utorrent test says a-ok.

Trying to reach ******.no-ip.biz:*****/gui , but times out.

Pinged ******.no-ip.biz , but times out?

Home computer is on and utorrent is running ;)

Any help gratefully received.



Link to comment
Share on other sites

I've been trying to get this to work for a week or so. It's slow going because I have to set up some things at home, then try others when I'm not, and I'm at work 14-16 hours a day (which is why I want to use the WebUI in the first place).

Anyway, I'm unclear on the port forwarding - which ports need to be forwarded? I know how to do it, but not sure which need to be done.

uTorrent port - obviously

WebUI listening port? or can that be the same as the uTorrent port without anything being added?

a port to be used by No-IP?

anything else I haven't thought of?

Also, I guess the No_IP host needs to be set up from home so that no_IP can find the IP address there, not the machine I'm trying to connect remotely from, right?


Link to comment
Share on other sites

  • 4 weeks later...

I've followed the instructions on the first post to the extent I downloaded mozilla firefox which I dont like very much. But the last part I just can't get to work. It tries to connect and it and time's out. I've got NIV but that says its made the rules for the DUC and Mozilla. Any help would be deeply appreciated. Thanks.

Sorry to sound like an idiot but whats a webui?

Can't anyone help?

Well thanks a bunch what a great forum this is [/sarcasm]

Link to comment
Share on other sites

  • 4 weeks later...

"Dynamic IP". Is it here that I've should start if I have a simple cable modem to the internet? I've heard that my IP isn't fixed and can change from time to time....should I try this if I want to be able to access the webUI from outside of my home network ?

Update: Can't believe me eyes!!! I've just tested using my IP address of which I took note last night and just worked (unbelievable that I can access remotely as I just posted in another thread that I'm unable to access from my home network). Anyway, "Dynamic IP" means that the address is going to change from time to time and I should try this approach to continue having access ?

Link to comment
Share on other sites

Ok, just a tip for those with the router DLink DI-524 or similar and a NO-IP account. There is an "internal DUC" in the router setup, so you don't need it - and it's better because it makes your whole conection with a hostname. Here's how:

1. Type as your URL

2. It'll ask for username and password. The default values are admin and nothing for the password (and you should change that!).

3. Go to "Advanced" tab above and make sure "DDNS" is the one selected in the right.

4. Configure as follow:

DDNS: Enabled

Provider: No-Ip.com (in my router there options for DynDNS, TZO and DHS as well)

Hostname: YOURLOGIN.no-ip.org (or whatever is your hostname there)

Username/Email: yourlogin@yourlogin (the whole email, the same you use to login in noip site)

Password/Key: ****** (the same one you use to login in noip site)

And you're set!

Here it worked *ONLY* this way - no duc, no firewall, no turning on ports on router, no nothing... just this way.

Hope it helps! :)

Link to comment
Share on other sites

  • 1 month later...

I followed all the instructions on the first page.

I signed up at NO-IP.com

made a new redirection on my acc.

Installed NO-IP DUC an so far everything is by plan.

But i cannot make my own URL....


My email is stoiandd666@gmail.com and "my_url" is arucad.no-ip.org

This is what i wrote in my FireFox:


And it tells me:


And after I click YES it shows blank....

What have I got wrong???

Link to comment
Share on other sites

  • 1 month later...

Okay, so I decided to revisit this forum as I finally get to use the WebUI again. I have set it up and it works okay via local host and I even get the login box and it starts to load then sits endlessly, for hours even (I got busy at work so forgot to stop the page, while I was working.). Any suggestions?

Link to comment
Share on other sites

  • 6 months later...

Can anybody help me pls. I am trying this webui thing, but it doesn't work out!!

I tried all the stuff as u said but the page doesn't load :(

I have setup no-ip account and eneter the url:


where username was the same as in utorrent,

your_url = as made on no-ip site

port, was the open port in utorrent (works correctly, i.e, is open, checked )

alternate listening port is disabled

webui enabled

opened the address in firefox 3

gave the error:


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...