Jump to content

uTorrent causes 700 000 k memoryleak.


Recommended Posts

Started having problems today. uTorrent was installed but they trayicon was unresponsive and nothing happened when i clicked it. I tried to manually shut down the process which worked, but ever since i have not been able to get uTorrent running.

I tried uninstalling it but after clicking uninstall in my control panel programs section it went unresponsive and opened another 700mb memoryleak.

After which i manually deleted uTorrent from my system files and registry.

After this i tried to install it again by downloading the stable version and the beta version. Both just take 700mb of ram yet do not install anything and no UI for installation pops up.

Any suggestions? I'd really hate having to change to a less superior torrent client.

Windows 7 x64

Heres a pic of the ram usage:


Sincere thanks!

Link to comment
Share on other sites

Okay now the problem is back. After i reinstalled it after deleting the files you guided me to it worked fine for 1 torrent. It is now downloading the torrent i wanted and using 35 megs of ram.

Now the problem occurs when i try to add another torrent to uTorrent.

It just keeps opening uTorrent.exe's that take 700 000 k memory and open no UI even though it should open it on the UI i have open already.

Help is once again very much appreciated : )

Link to comment
Share on other sites

I have the same problem going on and it's been in the latest beta for about 3 updates. I rarely can access the program, and I keep getting the 700K+ memory leaks with no functionality whatsoever. I never had a problem with utorrent and I hope this doesn't get chronic like Firefox did.

For more details, feel free to ask.

Link to comment
Share on other sites

Updated to 3.1.3 from 2.2. a few days ago, and i have the same problem.

Upon starting uTorrent it takes a lot of ram and wont start, if i try to start it again it will just start more instances of utorrent.exe with the same memory problems.

I did the settings reset, it was a short lasting fix.

Finally i decided to wait it out and after 10 min u torrent started and takes 60mb of ram.

Think i'll go back to good old 2.2 or some reliable client.

Link to comment
Share on other sites

  • 1 month later...

Just so you don't think he's the only one seeing this.

I thought I would chime in, seeing the same issue.. utorrent grow's until it consumes all available ram

I've been downloading torrents by killing the utorrent process restarting it. mem locks killing the process and restarting it.

currently running 3.1.3 build 27207 32bit.

the link to the torrent was a magnetlink.

currently utorrent is at over 400k in ram consumption and growing.

No I have not tried any of the suggestions as a fix .. because I knew in advance they would not work.

What seems to be aggravating this.

I'm downloading a torrent. that has no seed's but has seed 0(0) peers 1(10)

Link to comment
Share on other sites

  • 3 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...