Jump to content

DHT: waiting to log in - for weeks! And all setup tests are failing


Recommended Posts

I'm running uTorrent 3.1.3 on Windows 7 32-bit. I'm running uTorrent in administrator mode and can confirm that uTorrent is permitted through Windows Firewall. I have not set any specific port as unfirewalled (and, indeed don't know how to), and therefore have uTorrent set to use a random port.

For the past few weeks I've been completely unable to use uTorrent - the bar at the bottom always says DHT: Waiting to log in, and when I run the Bandwidth and Network tests, I get all X's.

The Network test reads that neither NAT-PMP nor UPnP is enabled, despite the fact that my preferences list both as being enabled.

The Bandwidth test is set to Sydney Australia (I live in Taiwan) and states that there's a lookup error: the requested name is valid, but no data of the requested type was found (11004).

I have no idea how to fix this and am getting really, really frustrated. Can anyone help? I hope I've supplied all the necessary information, but if not please, please let me know and I'll supply it as quickly as I can.

Many thanks!

Link to comment
Share on other sites

Well, they're not really speed issues as such, since I can't make any connections at all, but:

I have tried toggling the UPnP and NAT-PMP options, and the DHT options. I have tried randomizing the port as well.

According to the Setup Guide, I'm looking at a bandwidth config like this: upload limit. 4 upload slots. 50 connections per torrent. 200 global connections. 5 max active torrents. 5 max active downloads. I'm set to port 48530 and have automatic port mapping enabled.

I've got a yellow sign at the bottom of uTorrent indicating that no connections are being made.

net.max_halfopen is set to 100. I have changed no advanced settings.

After running third party tests, I can verify that: my ISP is Chunghwa Telecom (I live in Taiwan, recall), ping is 29ms, DL speed is 3.51 Mbps and UL speed is 0.45 Mbps.

I am running Windows 7 32 bit, have Windows firewall, and AVG Anti-Virus Free 2012.

Like I said, it's not that the connection is slow as much as it is non-existent. Recall, DHT just won't log in. This happened all of a sudden after no deliberate changes to any firewall, uTorrent, or internet settings. I'll admit that I can't remember whether the start of the issues is concurrent with my beginning to use AVG; if it is an issue with that, I don't know how to fix that either :[

Thank you!

Link to comment
Share on other sites

OK. I *still* have absolutely NO connectivity. I am registering no seeds and no peers on torrents that listed seeds and peers in the hundreds on the tracker. The bottom bar of uTorrent says: DHT: Disabled. D: 0.0 kB/s T: 89.7 kB U: 0.0 kB/s T: 14.2 kB/s.

I have acquired a new router (the old one was dead anyway) and set it up with set IP addresses, which seems to have taken care of the bandwidth and network port issues. All connection and bandwidth settings are in line with the setup guide tests' suggestions. Specifically:

Bandwidth: USA, WA, Seattle. UL speed: 471.9 kbps. DL speed 1.4 Mbps. Upload limit: 46.0 kB/s. Upload slots: 4. Connections (per torrent) 80. Connections (global): 230. Max active torrents: 3. Max active downloads: 2.

The results of the Network test are inconsistent, but at the moment read that my port is open and all is happy in configuration land. I'm working with port 46661.

I've tried disabling DHT and enabling access across all domains in Internet Security settings - as suggested here http://forum.utorrent.com/viewtopic.php?id=68286. Whenever I turn DHT back on, it still waits interminably.

I've tried turning Windows Firewall on and off, disabling and enabling the utorrent-related rules in the firewall, and removing my AVG anti-virus. At the moment, AVG is back, and Windows Firewall is up with all rules in place.

I have also:

lowered net.max_halfopen to 4 or lower

lowered bt.connect_speed to 4 or lower

disabled uTP

peer.resolve_country is disabled

UPnP and NAT-PMP are enabled

Right now I'm using a TOTOLINK N300RA router but I don't know about the modem.

Link to comment
Share on other sites

The suggestion at the thread I linked to included disabling DHT, which is why I did it, but I've already turned it back on. And yes, AVG was completely uninstalled while I was testing pretty much everything. I only just reinstalled it, as a matter of fact.

A bit more info, in case it's helpful: in Preferences -> BitTorrent, I've got every box checked and have tried 3 values in the "IP/Hostname to report to tracker" field: nothing; the IP my ISP provided; the IP that a Google query says is mine. No response to any.

What am I missing?? :(

Link to comment
Share on other sites

I passed the tests again - the Network test on the second try. And the torrent from OpenOffice is downloading!!!! All my other torrents I found using isohunt. What's the deal? I can't imagine that every single torrent I've tried in the past month is secretly abandoned, regardless of the seed and peer counts listed on isohunt.... I am so confused :(

Link to comment
Share on other sites

You might have used private trackers. Google it if you don't know what it means. Reset settings and advanced settings that you have changed and remember that you can check your bittorrent traffic with openoffice. And use other sites besides isohunt.

Link to comment
Share on other sites

So I signed into demonoid and started a torrent from there, and it works. I *still* don't get why apparently *no* torrents indexed on isohunt are at all accessible to me - it's not like every single tracker they list is private, right?..... right? - but, um, problem solved? I kind of feel like a schmuck.

At any rate, thank you very very much!

Link to comment
Share on other sites

  • 3 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...