Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 3.3 beta

Recommended Posts

I'll give it a shot. Previously that was the option that made the disk cache go kaboom... Never noticed any problems with the upload though. :P

Share this post


Link to post
Share on other sites

Still makes it kaboom, but the disk cache is actually able to catch up in this version where it would just get stuck before, so... half way fixed?

http://i.imgur.com/vFIG2.jpg

You can see the gap in the graph before the disk writes start occurring. In that time the cache had exceeded its bounds (32mb) for a total of 140mb or so. It only does this with that overhead option enabled, as I've been saying since... oh.. 3.0. ;)

So far I haven't seen the upload exceed my global limit (90). I'll continue to test though.

Share this post


Link to post
Share on other sites

I guess you've never tried my example settings-file... You should really up your cache to 128M+ . There is definitely an old bug with breaking the cache limit, it will just occur less frequent with a higher sized cache.

Share this post


Link to post
Share on other sites

The bug only occurs when apply limit to transport overhead is checked. Anyway, after some more testing it appears that option also breaks the upload limit. Just had it spike randomly up to 241kb/s when 90kb/s is my limit.

Share this post


Link to post
Share on other sites

Some issues with 3.3 beta (build 28763):

Changelog:

--2012-12-16: Version 3.3 beta (build 28763)

- Fix: Maintain upload rate limit when download limit is turned off

More:

- Fix: Limiters do not take into account correctly network overhead when set to do so if the overhead amount exceed the limit (TCP & uTP)

Upload limiter breaks also for data after the overhead exceeds the set limit

Not yet fixed:

- The upload limit seems to be off by about 10-30KB/s *only when* there is no download limit set

- File IO: write operations do not coalesce data to the set value, causing speed degradation due to possibly inefficient write cache operation

- File IO: Download will not finish (endlessly flushing) at the end of download with some analigned torrents

- Seeding: Unbalanced seeding speed distribution to seeding jobs (speed cut to 0), when there is an active downloading job *plus* there is an upload limit set (seems to behave well balanced when there is *no* upload limit )

- Add-Torrent – sub-folder control is still gone AWOL…

Share this post


Link to post
Share on other sites

Guys, I updated to latest 3.3, and it's only one thing I'd like a little help about...

My connection can download with 2.0MB/s. Currently I'm downloading with 1.2-1.4MB/s, but still it affects my browsing speed. If I apply "rate limit to transport overhead", the speed goes down to 200-300KB/s.

Any advice to keep ~1.5MB/s without affecting my browsing speed? Shouldn't a margin of 0.5MB/s be enough?

At least, the "Skip files" has been fixed, it was a major pain having to download everything included in a torrent.

Share this post


Link to post
Share on other sites
Any advice to keep ~1.5MB/s without affecting my browsing speed?

Look at my tips/sig. The upload limit (which you didn't way what is your connection's max) is the key issue. Set it to ~80% of your max, or use my sample settings and modify it.

Share this post


Link to post
Share on other sites

Downloading more than one torrent makes my hard drive constantly writing and slow as hell, upload speeds are a lot slower than in 3.2, please fix these bugs. It's still an alpha not beta! Thanks. (I won't make a clean install.)

Share this post


Link to post
Share on other sites
(I won't make a clean install.)

With what max connection speed? How about try using my example-settings (backup yours, and modify mine) ? vv

Share this post


Link to post
Share on other sites
Just wanted to express my immense gratitude for implementing torrent filter. Greatly helpful.

Yea... such a simple feature, yet so long delayed.

Usually happens for large projects, they drown in their own bureaucracy, and nobody can get simple shit like this done. :)

Share this post


Link to post
Share on other sites

28763

bug: I set "change UL speed when not downloading" to 0, and then when not downloading the UL cap keeps switching between 0 and x kb/s, where x is the UL limit when downloading.

Share this post


Link to post
Share on other sites
With what max connection speed? How about try using my example-settings (backup yours, and modify mine) ? vv

30M/5Mbit, nothing was changed in the settings, while v3.2 downloads with 3,5-6 mbyte/s and uploads with 625 kbyte/s simultaneously, then v3.3 downloads with max speed, but burns down the hard drive (It's writing constantly and flushing at the end is really slow with multiple downloads), and the upload speeds are like 2-300k max. and this is with NO download.

Share this post


Link to post
Share on other sites
nd the upload speeds are like 2-300k max.

Are you running the latest 3.3 BETA (not alpha) ? and did you try my settings?

Share this post


Link to post
Share on other sites
lol? what is this new right-click option in the peer's list: "Whole peer list"??

I tried out, and trackers appeared with all their connections (with my client ), dht server also...

Share this post


Link to post
Share on other sites
sorry for the spam, but why did the overhead increase so much out of nothing?

dht begins with no incoming and outgoing traffic ; it is a turbo-diesel feature !

Share this post


Link to post
Share on other sites
28763

bug: I set "change UL speed when not downloading" to 0, and then when not downloading the UL cap keeps switching between 0 and x kb/s, where x is the UL limit when downloading.

not downloading does not mean all dl finished, but all dl rates below the threshold ( 1 KBps at default settings ) ; just one torrent downloads suddenly more than 1 KBps, you switch automatically to "downloading" mode ; this torrent decreases to 0.9 KBps, "not downloading" mode reappears...

Share this post


Link to post
Share on other sites

hmm going back to 3.2.2 from 3.3 beta all my current download says "error: access denied (write to disk)" or something like that.... but now i went back all my current downloads are up and running

Share this post


Link to post
Share on other sites
Are you running the latest 3.3 BETA (not alpha) ? and did you try my settings?

I was running the latest beta from 3.3. But as I understand your settings/tweaks are both good for 3.2 and 3.3 when changing from 2.x, so when I didn't change anything at all in my settings why does behave v3.3 not as v3.2? It should adapt any changes made to disk I/O settings if those are not valid any more from v3.2.

I can only try your settings when I'll run out of seeding torrents.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.