Jump to content

"Error: Hash: The supplied user buffer is not valid...."


Recommended Posts

I've recently been using the relocate feature of µTorrent, and ever since I started using it, I've been getting the below error:

"Error: Hash: The supplied user buffer is not valid for the requested operation."

I never had any issues before I started relocated parts of the torrent. I get this error both on checking files as well as downloading, where parts are missing.

I tried resetting µTorrent back to its default settings and I still get this error. Then went as far as to completely uninstall µTorrent, download the latest stable release, and try again. After copying over my resume.dat file I still get this same error. I tried setting the disc cache size to the maximum allowed value in hopes that this would fix it; however, it appears to have to difference.

I also tried the "solution" posted here; however, deleting the .torrent file and re-adding it makes no difference.

Please help.

Link to comment
Share on other sites

I think I may have fixed my own problem :)

I'm using flexRAID's storage pool feature, which apparently has an I/O Buffer Size of a default 1MB. I increased it to 100MB and I was able to finally get that one torrent to finish downloading. My guess is that because I have so many torrents seeding from that virtual disk that there was not a large enough pipe for all of the data to go through.

I'll post back if I have any more issues. Hopefully this will help any other users who may be experiencing similar difficulties.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...