Jump to content

Download speeds dropping to under 10 kbp/s


Recommended Posts

Hello all, so I've been having these problems with Utorrent, where previously I had none. At seemingly random times my download speed drops from an average of 1,2 mbp/s to less than 10 kbp/s. All these torrents are well-seeded and such problems never used to occur. Sometimes a week goes by where I don't have this problem, and then I have a day like today where I have to restart Utorrent every 2 minutes so I can get a minute of 1,2mbp/s after which it always drops down to below 10kbp/s, this goes for all files I'm downloading.

I've worked my way through the guides step by step and tried everything from using different ports, to the firewall stuff, adding/re-adding and even disabling the firewall alltogether, I tried the Glasnost test which told me there shouldn't be a problem. In the client itself it shows the green button with a V in it, signaling that I should be optimally connected.I tried the protocol encryption stuff, I even tried all those advanced settings but to no avail. I tried files with 10.000+ seeders to see if it was a seeder thing but no, same thing happens.

What's weird is that I didn't used to have these problems and now all of a sudden it seems to happen with increasing frequency. I'd figure that before I switch to some other client there might be something I'm overlooking?

I'm currently using Utorrent 3.2 on windows vista home premium. My hardware specs include:

Intel core 2 duo CPU P8400 @ 2.26GHz and 2.27GHz

4gig RAM

32 bit

If anyone could shed some light it would be greatly appreciated.



For now downgrading seems to have fixed the problem. I'm running 1.8.5 now and it's holding steady around 850 kbp/s cumulatively. Yay.

Mayhaps an idea for the good people at Utorrent to make a lite version which is basically an old version with a shiny shiny interface. At least I can get back to my anime. wooh.

Link to comment
Share on other sites

I just found the fairly daunting list of required info with many terms I'm unfamiliar with, so I'm going to pass on the crash course in IT and run old-as-dirt-but-functional 1.8.5

I just needed a quick fix for tonight, maybe I'll update to 2.5 or something tomorrow.

Thanks anyway.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...