Jump to content

Starting Download


Tutida

Recommended Posts

utorrent 1.7.6b (27691) downloads not started after "save as"

INTRO

Thanks to those who make this great app available and the community who sustain it. It seems to work well. After letting it update itself from the current non-beta, I did have a problem with it refusing to quit much of the time but that seems to have been solved recently by replacing the app with a freshly downloaded one a week ago. However, not wanting the hassle of restoring settings, I didn't trash any of its system files, and since then I have noticed another problem that seems to be similar to this one that Tutida has noticed. However, in my case restarting uTorrent does nothing to fix it.

ABSTRACT

The problem is this: I click "OK" to save a torrent and expect it to start downloading but sometimes it doesn't do that. Moreover, sometimes the torrent file is not saved.

TEST CASE

Over a few days, I tested this out on a large sample of torrents from TPB. For each torrent, I clicked on a magnet link. Every time, uTorrent switched to the foreground and gave me a "save as" dialogue box. I clicked "OK" on each one. Download speed was consistently between 300 and 600 kB/s. I then stopped and waited over 12 hours. Then I checked my "torrents" folder to see what torrents had been saved, my "completed" folder where I had stored an extra note of each torrent I had tried to download and my uTorrent window where I could see the files that were downloading. I compared them.

RESULTS

Total number of different torrent files on which I clicked "OK" in "saved as" boxes: 184.

Total number of downloads not started and torrents not saved: 92 = 50% (!!)

Total number of downloads not started but torrents saved: 12 = 6%.

Total number of downloads started but torrents not saved: 6 = 3%.

MY SETUP

Mac OS 10.7.4, 2.5 GHz Intel Core 2 Duo, 6 GB RAM, with torrent files, downloads in progress and completed downloads each in a different subfolder of a child folder in my Downloads folder on my startup disc.

DISCUSSION

The rate of downloads not starting is so high that I should really check for each one in the uTorrent window after trying to save it. This will work around the problem to some extent for the site I used in this test, since most of the torrents have the same names as their downloads. Some don't though, so sometimes there will be confusion. Moreover, on another site I know, the torrent files most of the time have different names from the downloads. It's also really strange that sometimes downloads are started but the torrent files for them are not saved, but that is a minor issue.

CONCLUSION

This is happening so much to me that I have been wondering if there is something wierd about my setup or if others have this too. It may be the same as Tutida's problem.

Link to comment
Share on other sites

I should mention that I have picked a handful of the torrent files that do not appear in my uTorrent window and double-clicked them to get a "save as" box again. I don't get any error messages or anything. I can click "OK" and seem to have been able to start them downloading successfully this second time.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...