Archived

This topic is now archived and is closed to further replies.

dobbyisfree

"Error: Write to Disk: Access Denied" shows now when I'm dwnloading

Recommended Posts

With no disk in my laptop, this message comes up around the time the torrent has been 0.09% downloaded. I'm not trying to put anything onto a disk, and I downloaded many torrents before and had no issues. I did nothing different, but no all of a sudden it's giving me this issue and it's frustrating. I've become addicted to Game of Thrones and really wanna download a torrent for an episode I was on. Please HELP! N:(

Share this post


Link to post
Share on other sites

It would not be referring to an optical drive unless you picked, or somehow the target drive setting was changed. Mine asks me for every download, I do not have a set path.

Anti-Virus software, when scanning a file, LOCKS the file, thus any other program wanting access at that point in time, is denied access. McAfee is known for this. I use Comodo, and never have these issues. Anti-Virus scans a file on Creation, Reads, and Writes. For troubleshooting purposes, turn off, disable, or exit any Anti-Virus software you have, see if that stops it.

Check your PATH for where files are being saved.

A going bad or faulty hard disk can cause these issues too.

Share this post


Link to post
Share on other sites

Got the same error intermittently. Torrent would start OK, then after a while it would stop with Access Denied error. Moved torrent to a new disc, same problem. Shut it down, and started using "Run as Administrator" and working fine. Strange as I am running from an Administrator account, but works for me! Have just moved from XP to Windows 7 so assume something to do with Windows 7 permissions. There is an option to "Elevated" in some utilities which is higher than normal Administrator. Looks like "Run as Administrator" does the same.

Share this post


Link to post
Share on other sites

@IrishHare, what you describe will happen in Windows 7 if you have uTorrent installed in Program Files and also have settings.dat in the same folder because applications are not allowed to write to Program Files as they were in Windows XP in order to provide some protection against malware. Running uTorrent as Administrator grants the necessary permission for it to write to protected folders (and the registry), which it will not otherwise have regardless of being run from an Administrator account. A permanent solution is to grant Full Control to Users (or add Everyone and grant Full Control) for the folder in which you have uTorrent installed. Right click on the folder and select Security to do this.

Share this post


Link to post
Share on other sites
Security properties on the folder.AGAIN.Why don't people read and search?

Because many people expect to be able to use computers as if they were appliances. And it seems many want to use uTorrent as if it were just a download manager.

Share this post


Link to post
Share on other sites

@jsillup Thanks for the informative and useful answer. Windows 7 is a learning curve - one sort of expects that what worked in Xp wil work in Windows 7!

Share this post


Link to post
Share on other sites

I had this error too! but then i noticed that before i click ok (the dialog box where you check/uncheck the files) i saw at the upper part that my save point (save in) was different (C:/users) so i changed it and then! its working now! :) hope this helps.. :D

Share this post


Link to post
Share on other sites

ok guys i found a solution for me it might work for you too

1. right click on the torrent displaying the message error: write disk...

2. go to "advanced"

3. go to "set download location"

4a. simply click the "downloads" option under favorites (if you have windows 7 like me)

4b. if you don't have windows 7, simply choose the folder where your downloads usually go (don't know if it will work but i'm really sure it will work)

5. then right click the torrent again

6. choose the "start" option and it should start downloading after a few seconds

let me know if it worked for you guys

Share this post


Link to post
Share on other sites
ok guys i found a solution for me it might work for you too

1. right click on the torrent displaying the message error: write disk...

2. go to "advanced"

3. go to "set download location"

4a. simply click the "downloads" option under favorites (if you have windows 7 like me)

4b. if you don't have windows 7, simply choose the folder where your downloads usually go (don't know if it will work but i'm really sure it will work)

5. then right click the torrent again

6. choose the "start" option and it should start downloading after a few seconds

let me know if it worked for you guys

THNX!!!!!! :D

Share this post


Link to post
Share on other sites
ok guys i found a solution for me it might work for you too

1. right click on the torrent displaying the message error: write disk...

2. go to "advanced"

3. go to "set download location"

4a. simply click the "downloads" option under favorites (if you have windows 7 like me)

4b. if you don't have windows 7' date=' simply choose the folder where your downloads usually go (don't know if it will work but i'm really sure it will work)

5. then right click the torrent again

6. choose the "start" option and it should start downloading after a few seconds

let me know if it worked for you guys[/quote']

THNX!!!!!! :D

WORKS GREAT THANKS

Share this post


Link to post
Share on other sites

None of the methods recommended or suggested have worked. I have to continually hit 'start' to get the torrent to move along at a snail's pace.

I've set full control to Users on both the download location folder and uTorrent's installed folder. I've renamed files with the same name as the file downloading. Doesn't work at all. This is very frustrating. This torrent would've been done an hour ago and now I"ll be here until another hour from now baby sitting it.

Share this post


Link to post
Share on other sites

A fix that should work for everyone is to take the ownership of the download folder and it's containing files.

 

This issue is due to security policy on windows 7-8.1 and most often occure after moving the folder from it's original location to another harddisk or machine.

 

This a reg file who add to the right menu this option:

 

Windows Registry Editor Version 5.00

 

the file is joint but you can copy and paste this into a texte file that you will change the extension for to .reg and double click it... or download the file and execute it.

 

/START COPY UNDER THIS TEXT

[HKEY_CLASSES_ROOT\*\shell\runas]
@="Take ownership"
"HasLUAShield"=""
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\*\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant everyone:f"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant everyone:f"

[HKEY_CLASSES_ROOT\exefile\shell\runas2]
@="Take ownership"
"HasLUAShield"=""
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\exefile\shell\runas2\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant everyone:f"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant everyone:f"

[HKEY_CLASSES_ROOT\Directory\shell\runas]
@="Take ownership"
"HasLUAShield"=""
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\Directory\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant everyone:f /t"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant everyone:f /t"
 

 

Share this post


Link to post
Share on other sites

I had this problem for some reason, just out of the blue, and saw that there were several threads about this on the forum. But this seemed to be the most pertinent.

 

My problem was solved by re-selecting the download location, tried both in the settings (preferences --> directories), and also when i click on a torrent link then the save location there to the same as the settings tab. (most of us still use C:/users/(user name)/downloads).

 

When i checked the permissions, both my user and the administrator permissions were set to "full control" (and the "allow" boxes were all checked, except "special permissions").

 

Hope this helps.

Share this post


Link to post
Share on other sites

Any update on this? I've changed folders 3 times, uninstalled and reinstalled utorrent twice, set permissions to the downloading folder, torrent holding folder, utorrent parent folders (all of them) to ALL full persmission, utorrent itself, the downloaded torrent, the files, turned off and uninstalled my firewall and my anti-virus.

 

This has only started happening since Monday. 1 torrent is giving me the problem. Why?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.