Jump to content

Connection issue with Windows 8


mosaicdj

Recommended Posts

Hi,

I'm running the latest non-beta build of uTorrent on Windows 8 Pro. I did a clean install of both the OS and uTorrent and I'm using the same settings I was using in Windows 7, where uTorrent worked fine.

I use port 43830 in uTorrent and manually forward it. When I was using uTorrent on Windows 7, I disabled "Enable UPnP port mapping" and "Enable NAT-PMP port mapping" and everything worked great.

On Windows 8, sometimes it works, other times it doesn't as it says that the port is closed. If I enable the two options mentioned above, it works, except then the port changes to 43831, even though I've set it as 43830. I use 43831 for another program where it's also manually forwarded so I would rather uTorrent not change the port.

How come uTorrent changes the port from 43830 to 43831 when I enable those 2 options? Also, any reason why it would sometimes show the port as closed in Windows 8 when it worked fine in Windows 7?

Thanks for any help you can give!

Link to comment
Share on other sites

How come uTorrent changes the port from 43830 to 43831 when I enable those 2 options?
Your router "told" uTorrent that the port was already in use so it incremented it automatically.

But why would it do this now when it never did it when I was using Windows 7? I've been using the same router for ages and the router settings haven't changed.

And why would the port already be in use? If 43830 was in use (i.e. open) then uTorrent wouldn't be having any issues connecting. 43831 is in use by another application, yet uTorrent still switched to that port.

Link to comment
Share on other sites

But the router doesn't report WHAT application might be using it, just the fact that it is already forwarded, and the router also does not say "Oh and by the way port 43831 is also in use so don't bother trying that one either"

Either use ports that are seperated by more than one number, after all there are 64,511 to choose from , or turn off NAT_PMP and UPnP then set and forward the ports manually.

Link to comment
Share on other sites

or turn off NAT_PMP and UPnP then set and forward the ports manually.

But that's what I was doing. It's why I started this thread :D - it doesn't work now that I'm using Windows 8.

I have port 43830 manually forwarded. I have those 2 settings disabled. A lot of the time when I'm using uTorrent, I get the yellow icon in the bottom-right and when I click on it and do a network test, it says the port is closed. This never happened in Windows 7, but it's happening a lot in Windows 8.

Thanks for your help so far.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...