Jump to content

DHT: Waiting to Log in OR DHT: 0 Nodes


silentrake

Recommended Posts

I know this is a frequent question, as I have read through at least a dozen threads from others trying to figure this out. I am going to attempt to give the information I see all of those other users fail to include in their post. It always seems there are lots of recommendations, but there are never any follow ups with what actually worked.

I have been struggling with this for months, and it seems that Utorrent doesn't work FAR MORE that it actually does work. I am getting a few hours a week of function and the rest of the time I get the same things "DHT: waiting to log in" or "DHT: 0 Nodes (login)". I have done what basic things I can do (my knowledge is limited), but I have reset modem, router, PC. I have port forwarding on my Netgear WNDR3800 router working, I have attempted a glasnot test but it fails to "measure my link", I have tried changing ports and then adjusting the port forwarding, I have tried uninstalling and reinstalling utorrent more times than I can count, I have tried adjusting peer connection settings as were recommended in one post...and have now reset the .dat and old.dat folders by deleting them to get it back to factory.

Here are the specs on my setup;

Windows 7 Enterprise (service pack 1) 64-bit

Utorrent 3.2.3 (build 28705) [32 bit]

Windows Firewall shows utorrent exception is enabled

No other antivirus is on this machine

The craziest thing is, I wouldn't be the least bit surprised if it just started working again for a day. I don't change anything, and it will eventually start working, but its so infrequent that I need to figure out what is happening so I can either fix it for good, or at least know how to fix it when it fails. It's just so incredible unpredictable.

Bring on the questions, and I will do my best to get the information needed for some of you experts to help me diagnosis this. If you want some technical log info, please offer some instruction on how to obtain it so this thread doesn't get clogged with me asking a million off topic questions.

Thank you so much. Hopefully this thread can help others in the future too. If we can positively identify what is going on, I will make sure the thread obtains the final fix, and not leave everyone hanging.

Link to comment
Share on other sites

I am not certain how to tell if the torrents are allowing anything. The only guess I can take, is that it isn't the particular torrents that are the problem because I have had the same one trying to download for the last month, it's 51% of the way downloaded. When uTorrent works, which is incredibly rarely lately, the torrent slowly makes progress, but then it it stops working with this DHT log in problem. So, based on the fact that it has worked in the past, I would say the torrent is fine.

I did delete uTorrent again today, so lost my 51% progress, but I kept the torrent file, so it's the same one. I tried uninstalling and reinstalling again because it seems to be the most popular fix, but it's insane to have to do this all the time. There is something else going on.

I did notice that I had to try several different ports with the random port button before my router would accept one of them.

My router allows me to give a range of ports to open. I am going one above and one below to make room for that one port listed in my preferences section of uTorrent.

I have run the connection test, and it pasted within uTorrent, so the ports are working.

Link to comment
Share on other sites

DWK,

Thank you for the link, but I must not have clarified that I am not very savy at this stuff. The list of things to try may as well be written in greek.

1. UDP Traffic needs to be allowed in firewalls for DHT to function.

Ok....how do I check this within WIN Firewall? Would this allow for uTorrent to work one day, but not the next?

2. PeerGuardian needs a smarter blocklist selected. Several of the blocklists generated by Bluetack block the DHT bootstrap node used by UTorrent.

What in the world is this about? I don't know what Bluetack is....I don't think I use PeerGuardian, and I have no idea how to check either if I do use this stuff.

3. IF DHT has worked in the past, try torrents from OpenOffice or Depthstrike Entertainment's Open Source and Freeway tracker.

Guidance? I typically download torrents from Kickasstorrents.com. I went to Depthstrike Entertainments site, and I don't konw what the heck I am looking at, and I don't see any torrents I would download. What is all that stuff?

4. Shut down uTorrent, remove teh dht.dat and dh1.dat.old files from %appdata%/utorrent and restart UT, then retry.

Been there done that, at least 20 times in the past year. It has never fixed the problem, but in the name of following what is recommended, I just did it again. No help.

Link to comment
Share on other sites

I'm going to push my luck here a little. If you aren't willing to walk a newb through some of this stuff, then I can hang out and wait for someone who is.

1> Is there a way to check, or should I flip a coin?

2> Apparently not, although I thought had a bead on things. I am not aware of BlueTrack or PeerGuardian on my machine, and a quick search appears to verify I don't have those programs.

3> I went to the links in the text, which is why I posted that I didn't see anything there that made sense to me. Is there perhaps a certain torrent you would recommend as a test? It appeared there were many pages of torrents, none of which looked like something I wanted to blindly click on.

Thanks (hopefully) for any further guidance.

Link to comment
Share on other sites

Thank you for the help.

I removed the firewall exceptions, and then attempted to add it back in. I am not sure if I added it correctly. In the past I have always let uTorrent create the firewall exceptions. I did not see uTorrent on the program list of .exe files when I attempted to add it. So I did it by selecting "all" and then named it uTorrent. I think I might uninstall / reinstall again to make sure that is working.

As for the two links. I am a creature of habit, and the only sites I have ever used for torrents are ones that have the magnet link. I have not one clue how to use OpenOffice. I found a magnet and clicked it...not sure what the heck it was actually for and I got a uTorrent error. Unable to load"OOo_2.1.0_Intel_install_en-US.exe"unsable to parse magnet URI!

Not sure what that means.

Link to comment
Share on other sites

Ok....development.

I selected to download a torrent that was advertised under "Featured Content" within uTorrent plus. It was some 4 hour chef special....not sure what it is. I clicked it and its downloading just fine!!!

I still see DHT: Waiting to log in. Nothing else will download but that one from this link in uTorrent works fine.

Link to comment
Share on other sites

  • 2 months later...

Hi Silentrake,

I also am struggling with this issue for a couple of years already. My main access point in behond a router, and I have done all the configuring without success. Sometimes I access through 3G and not from behond a router, and then it works 100%. When I then disconnect the other connection and go back to the default behind the router, DHT remains logged in, Some torrents download, sometimes the speed is not too bad. But when my machine shutdowns, I have to do the same procedure, first connect to the internet from another access point on the same PC, and then disconnecting this connection, going back to the router. But lately even this now gives me a very slo D/L rate, and only a few torrents that work.

Maybe we could share ideas here, ultimately there must be a solution that works,

Igmar

Link to comment
Share on other sites

  • 5 months later...

i may have solved it!

i have win 7 with utorrent and a VPN, std router settings, home network with 10 machines connected, tonite my DHT couldnt connect, but had been in the past, i eventually disconnected my VPN (for no reason other than i was closing down for the night), i noticed when back on my "real" UK ISP (virginmedia) i had a DHT of 1 and it was looking for more, ok why? so i changed my VPN to a UK address and reconnected, BINGO!!!!!

For some reason if i go to the USA for the VPN, no DHT, if i stay in the uk on the VPN i have 171 nodes (now 202 and still rising).

this may not fix everyones but perhaps a clue is here to non-VPN users too, maybe proxy or something? VPN users can try a UK connection, or failing that, their own country?

i hope this helps some ppl :) i know "supposed fixes" keep arriving and never work (i just spent 2 hours googling and trying cr*p), but this genuinely works for me and is not a coincidence :)

now someone tell my why my android media player has network issues when i transfer files between machines!

EDIT: now 308 nodes which i think is about usual for me

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...