Jump to content

v3.2.3 ignoring individual torrent Download Speed & Download Location


Recommended Posts

Hi - need some help with a bizarre problem that started after I upgraded utorrent.

I run utorrent 3.2.3 32bit on Windows 8, 64 bit.

I have noticed 2 instances of utorrent blatantly ignoring my settings:

1) I set an individual download maximum speed for a specific torrent. It is being ignored! I put 21 as the max speed, and verify that the setting is there. but the torrent is blasting down at full speed.

2) I tell utorrent to ASK me where to put new files. But it ignores that this setting and simply puts everything in the Windows Downloads folder.

I've been using the functionality I mention for many years in utorrent and there was never any problem before.

What is going on?

Link to comment
Share on other sites

If you read the forums you will find that there is a known 'bug' that is triggered by a set of circumstance/conditions.

2) I tell utorrent to ASK me where to put new files. But it ignores that this option is ticked and simply puts everything in the Windows Downloads folder.
Screen shot of Preferences -> Directories please.
Link to comment
Share on other sites

Thanks for responding.

Sorry if either of these are known problem. I spent quite a while googling this, before coming to the forum. Apologies if I missed something.

Would you be able to tell me what phrase to google for, or post a link so that I can find out about the known issues?

In the meantime, here are some screenshots:

Preferences > Directories > Location of Downloaded files:

Option for where to store torrents is empty, as it's been before. I always want utorrent to ask me where to put the files: Utorrent does not seem to realise that this option is unticked though..


Instead, utorrent puts all downloads in the Windows "Downloads" folder without asking first. I have to stop the torrent, manually move the download location and delete anything that utorrent has already started downloading into the Downloads folder.


EXAMPLE of speed issue: Individual upload speed for the torrent named "The Gates" is 10 kB/s. However, it's uploading at at 65 kB/s which is still much higher. This happens both with individual torrent upload and download. It happened for a torrent on a private tracker which I needed to download slowly for ration reasons.It seems utorrent is disregarding the setting.


My conclusion is that either two new bugs were introduced, or my utorrent installation is corrupt. I uninstalled, downgraded to v 3.2.2, but the problem remained.

I am reluctant to do a complete cleanout and re-install because I am seeding plenty of magnet links and torrents that are labelled and with passkeys and specific locations.

I'd be very grateful for some feedback if anyone knows what the problem is.

Link to comment
Share on other sites

A bit of reading will get ALL the information you need

Any known timeframe for a release when this will be fixed?



--2012-11-21: Version 3.3 alpha (build 28582)

- Fix UT Plus LREC height mis-sizing

- Remove: obsolete graphic images

- Fix: Crash in LAdWindow

- Fix: Restore global upload rate limiting

- Fix: rare crash in udp tracker code

- Fix: coalesce writes from cache to disk

Link to comment
Share on other sites

UPDATE and SUMMARY for the benefit of anyone finding this and needing quick and clear answers:

The problem is present with BOTH individual torrent upload and download speed.

There is another issue with not being able to select location for individual downloads.

The problem is NOT solved in version 3.3 Alpha which I tested.

I tested versions 3.2.3, 3.2.2 and 3.2.1. The problem was present in all versions.

I found that the problems were NOT present in version 3.1.3 .

Skimming the threads referenced by ciaobaby above, I could not find any conclusive response to whether the specific problems I am having are definitely being worked on, and when a fix is due. Trying to read between the lines of ciaobaby's comments and the material he referenced, I conclude that both issues are *more or less* known regressions and will be addressed in the not-so-distant future. (If they are not, I'll have to choose another client).

In the meantime I have reverted to 3.1.3 as the quickest and least painful way to address the problem.

Another possibility might be to try out another client for a while, if you've been with utorrent for a long time. There seem to be quite a few problems with the utorrent 3.2 code.Regressions on basic functionality is never a good sign... For me I'll give it a couple of months, just staying on 3.1.3. After that I'll try the next upgrade and if that's shaky too, I'll take it as a sign it's time to move on.

Link to comment
Share on other sites

I'll be damned if the Download problem isn't present in 3.1.3 as well!

I wish I could remember what version I was running before I upgraded to the fatal 3.2.3.

It must have been a lower version than I was aware, or my settings are messed up in the registry or similar.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...