Jump to content

trouble using uTorrent Beta for galaxy s3


Recommended Posts

Using my phone, galaxy s3, I downloaded utorrent. I've been trying to download torrents from americansoccerarchives.com but it looks like the program doesn't want to start downloading it. I tried several videos with utorrent and I even tried using another client, tTorrent, but again nothing happens...It just sits there. Im a beginner when it comes to torrents so maybe I'm making some stupid mistake. Anyone able to give some advice? Here's what I'm seeing. It just stays like this no matter how long i wait:

How they look on uTorrent


How they look on tTorrent


the utorrent app has like a 'trending' section and I tried one of those which downloaded fine. But i tried a torrent from another site and it didn't go through...it was the same result as the american soccer archives site. So it can't be just that that site isn't working...on the other hand its not just my phone because the one from uTorrent went through just fine.

I appreciate the help everyone

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...