Jump to content

Running uTorrent as a service with the remote app for Android


sanderxpander

Recommended Posts

Hi all,

I just upgraded to uTorrent plus [EDIT: to avoid any unclarity, before this I was running the regular uTorrent 2, the feature I'm asking about is not unique to the plus version of uTorrent]. I'm trying to get the remote app to work. Previously, I had uTorrent run as a service on my Windows Home Server (using AnyServiceInstaller) and used the webUI to access it remotely. I also used stunnel to make it SSL. This is something of a hassle to setup, though it worked well once I had it going. I used Torrent-Fu on my Android to search/add/delete torrents etc.

With the new uTorrent secure remote option, I figured that'd be safer and I wouldn't have to mess around with stunnel (it was a long time ago I set it up that way and after my reinstall, I'm not sure I remember how to go about it).

However, now it seems the remote app (and the remote web option through remote.utorrent.com) don't work if I run uTorrent as a service? I have to actually run the program, which requires me to login via remote desktop at least once each time I reboot the server. Even when I tell uTorrent to start when Windows starts (because it only starts when a user actually logs in).

Is there any innate difference between running uTorrent as a service versus running the program? Is there any way to make this work? Should I have posted in the troubleshooting forum? :)

It doesn't seem a bug exactly.

Suggestions very welcome!

Link to comment
Share on other sites

I'm pretty sure I did. I mean, I set up the remote client, connected with it through both my browser and the android app, and it worked. Then I RDd into the server, quit the application, and started the service. Then I tried logging in again, but no cigar. It seems that there is some difference between running as a service and running the application, which I don't get.

EDIT: I just tried again to verify. When I have the application started through remote desktop, it connects fine through the remote app and through the browser. If I quit and start the service instead, nothing. It won't find my computer at all.

Link to comment
Share on other sites

For who is interested, I "solved" this issue.

First I got an extremely unhelpful email back from the support department saying simply that they offer no support for running utorrent as a service atm.

I ended up not running as a service but using task scheduler to start the program - you can specify whether it will start when the computer starts OR only if someone logs on. uTorrent's own preferences setting "start when Windows starts" only works on logon. The task scheduler version actually starts when the computer starts, so if you're running a server and don't want to RD in every time you reboot, this is the way to go. Remember to disable uTorrent's "start when Windows starts" option in preferences or you'll be running two instances.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...