Jump to content

'Shutdown When Downloads Complete' - not working with scheduler


Sillychuckie

Recommended Posts

I like to schedule my downloads to run between 1am and 8am.

I like to 'auto shutdown when downloads complete'.

I used to always do this:

- At 10pm, before bed, I would queue up my downloads with the scheduler enabled. They would not start due to the scheduler restriction (1am-8am).

- I would also specify 'Auto shutdown when downloads complete'.

The downloads would start at 1am, and then shutdown when complete, or, if they don't complete, would be stopped by the scheduler at 8am.

I am now using version 3.2.3 (build 28705) [32 bit], and this no longer works.

I find that when I select 'Auto shutdown when downloads complete' (after scheduling my downloads), uTorrent tries to shutdown the system immediately. I don't think it used to behave this way.

How can I schedule downloads for a time in the future, yet also use the auto-shutdown feature?

Thanks.

SC.

Link to comment
Share on other sites

Sorry, I don't understand your reply, or perhaps, you haven't understood my question.

I know how to enable and disable the scheduler. I have it set up so that the scheduler is green from 00:00 to 08:00, and all the other squares are white. I'm not a new user and have used uTorrent (with scheduling) for years now.

I want to set up auto-shutdown, before the scheduler starts, but have it shutdown when my download completes (which may be before the scheduler ends).

I think this is a bug. It seems nuts that it pops up a dialog to shutdown the system the moment I set 'auto-shutdown when download completes'.

Please re-read, or try yourself. Thanks. SC.

To be clear: I have the scheduler enabled, and I am in a period when nothing is downloading (a white square). I have downloads queued.

I click 'auto-shutdown when downloads complete'.

uTorrent immediately pops up a message box stating:

"Automatic shutdown will initiate in 25 seconds. Press cancel to abort".

Link to comment
Share on other sites

OK - I get what you are saying, but we are still clashing somewhat :)

Perhaps I should change angle, and instead post this as a 'feature request' (forgetting the fact that it used to work).

You are saying that:

- If you schedule 'auto-shutdown when downloads complete', it will shutdown at any moment there are no active, incomplete downloads.

- Because my scheduler is enabled (preventing downloading) at the time, there are no active, incomplete downloads (only inactive ones). So it tries to shut down immediately.

- Were I to set the 'auto-shutdown' rule after 00:00am (once my downloads have started), it won't auto shutdown.

However - this is annoying and doesn't allow me to go to sleep at 10am.

The way I think it should work, is that the software should raise an event each time a download reaches 100%. If at the time a download reaches 100% there are no other downloads still yet to complete, it should auto-shutdown (assuming shutdown is enabled).

I don't think it should immediately auto-shutdown, if someone enables this mode at a time when there is nothing downloading.

Please suggest any other way you think I could achieve what I want, else, I'll move this to a feature request. I think something has changed in the code which has altered this behaviour.

I get unlimited internet downloads between midnight & 8am. The rest of the time, I get charged for my usage. I want to go to bed at 10pm. I'm happy for my computer to remain on between 10pm and midnight (doing nothing), and I'm also happy for it to stay on after midnight (provided it is downloading). However, once my downloads are complete (this could happen any time), I want it to shutdown. If by 8am it hasn't finished downloading, then the scheduler stops them (so I'm not charged for my usage). I accept that uTorrent wouldn't shut my system down in this scenario.

Let me know what you suggest, or whether I should create a new post in another section of the forum (feature requests perhaps).

Thanks. I do appreciate your replies.

SC

Link to comment
Share on other sites

I don't think it should immediately auto-shutdown, if someone enables this mode at a time when there is nothing downloading.
Yeah I understand what you mean but "stopped" is "stopped" no matter how what created the stopped state.
I get charged for my usage.
I'll assume that charges only apply over a set limit, otherwise it makes it a pretty useless connection if you can't even read webmail without being charged extra for the privilege.

I'd suggest leave your full download times as they are but set all other times to "Seeding only" (Pink), and have 08:00 - 08:59 set to stop (white).

Link to comment
Share on other sites

I get a monthly allowance of 15Gb, except for overnight when it is unlimited.

I prefer not to use it on downloads, so scheduled them up during the unlimited hours.

(so I'm not charged for checking emails/web, but wanted to simplify my post).

I guess the solution then is to use the 'Limited' option in the scheduler. Did you know about that one - I just noticed it.

I can set my connection to be 'limited' between 10pm and 12pm (lighter shade of pale green), thus starting my download early but limiting it to 0kb upload and download.

At midnight, I have the darker green (unlimited) kick in.

I can then simply set auto-shutdown, with it downloading in 'limited' mode - but actually, since my limit is 0kb, it is effectively 'queued'.

This is a work around - but I'd still suggest a more intuitive change to the rules of 'auto-shutdown when 'downloads complete', or renaming it to 'auto-shutdown if no active downloads' (which is actually what it does).

Thanks.

SC

Link to comment
Share on other sites

Did you know about that one
Yes I had made the assumption that you were wanting NO download at all during the "peak" hours.

Just be aware of the "global limit bug" in 3.2.x that ignores the set limits given certain conditions, although as far as I know, no one has reported whether the scheduler limits are affected or not.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...