Jump to content

WebUI: Invalid Request... I've tried everything


Recommended Posts

I've read the post about all the possible reasons I could get the "Invalid Request" error, and have checked, double checked, and triple checked all of them, and haven't had any luck.

My uTorrent port is 2000, I'm not using an alternative port for the WebUI, I don't have any IP restrictions. I'm remembering the /gui/ and even the trailing / at the end. Port 2000 is forwarded for both TCP and UDP in my router to the IP address of the host machine ( I even tried putting it in the DMZ on my router to no avail.

On my server, I can hit the WebUI from localhost:2000/gui/, homeserver:2000/gui/ (my host name), What's strange is that I get an invalid request if I use I can also hit the WebUI from any local machines on my network by either using the host name or IP address. Although the is bizarre, its not really my issue (though could be related, I guess).

For months now, I've been able to access the WebUI from work, or anywhere else online by typing my domain http://my.domain.com:2000/gui/, and its been great. One day, however, it just stopped working. Wouldn't even give me an invalid request. I've been scouring the forums for help and couldn't really find anything I hadn't already tried.

I changed my port to some other random number, forwarded it, and started getting invalid request errors, which was at least some sign of life, but all of the settings are the same as they were before, except for the port, which, if the port were incorrect, I doubt that I would even see the invalid request.

I reinstalled uTorrent (though I didn't want to remove prior because I didn't want to lose all of my RSS feed settings). I copied in the most recent webui.zip from 12-5-2012.

I'm running uTorrent 3.2.3 on Windows Home Server 2011 (Windows Server 2008).

Any help or insight would be great.

Link to comment
Share on other sites

Set IP to and forwarded all the ports I had forwarded to my old IP. Still no luck. I do think, however, that my router is having trouble forwarding some ports. I have port 2000 forwarded to 1.15 now, as well as port 10001 external to 2000 internal forwarded to 1.15. Port 2000 times out, while 10001 gets an Invalid Request. I realize now that there's at least 1 issue with port forwarding on my router, I think it has to do with uPnP. However, because I'm still getting an Invalid Request, that means that its contacting uTorrent somehow.

Link to comment
Share on other sites

  • 11 months later...


This topic is now archived and is closed to further replies.

  • Create New...