Jump to content

Can anyone help I only get speeds of 30 to 40kbs


Recommended Posts

I used to be getting speeds of over 100kbs when I was downloading from utorrent since upgrading to 3.2.3 I've only been getting speeds of 30 to 40kbs. I've tried deleting setting.dat and settings.old.dat, the port is forwarded correctly and I've tried resetting halfopen to 4. I've also tried disabling avast's shields and commodo firewall with no change in the torrent speeds. The torrents have hundreds of people sharing them so I should be getting faster spedds than this. I'm using 11014 for incoming settings, 4kbs upload rate when downloading, no download limit, 200 global connections, 50 peers per torrent, 4 upload slots, 13 active torrents and downloads. Even if an individual torrent didn't get that much at times between the 13 I did get good speeds and I've tried changing everything else to match the speed guides here.

I'm not the most experienced user so I'm out of ideas and would appreciate any help. If you want me to post/change something please give me clear instructions on how to do that e.g. go to x and change y don't just say switch your so and so.

Link to comment
Share on other sites

Sorry I wasn't clear but I've tried everything under the slow transfer speed section and never saw anything over 40kbs. Slackwear linux was around 30 by itself and dropped to 9 with other torrents enabled. Glasnost displays a lego block with a cross in it none of the other settings seemed to change anything.


I did read the forums, tried the links and in the absence of improvement am asking for help.

Link to comment
Share on other sites

Are you talking about the "information we MIGHT need"? If so . . .

I have tried changing my bandwidth settings. Upload from 9 to 4, download from 0 to 150, deticking rate limit, changing maximum global connections from 200 to 100, maximum peers per torrent from 50 to 25. (Currently as per speed guide see below)

I have tried restarting u-torrent and my computer, I have tried restarting utorrent after disabling both my firewall and anti-virus.

I have checked that I have the green status tick in the bottom right.

I have tested a torrent from slackware linux.

I have tried going from 13 max torrents/13 download torrents to 3 max torrent/3download torrents. (currently 13)

I have tried enabling protocol encryption. (Currently off)

I have tried disabling bt.tcp_rate control (currently on)

I have tried bt.transp_disposition on 31, 26 and 21 (currently 31)

I have confirmed peer.lazy_bitfield is on.

I have tried Glasnost and just got that lego-box with a cross in it so I don't think it tested my connection.

EVERYTHING you've tried so far, including ANYTHING listed above (please be as explicit and specific as you can). Tell us what your changed settings are.

I have the latest version of utorrent.

I checked the bad ISP's on vuze wiki and mine doesn't seem to be there (iinet)

The setup guide (New york 2) said

Upload 314.6 kbit/s (38.3kbs) Download 288.4 kbit/s (35.1kbs)

Port is open and network is properly configured.

I know this say's 35.1 kbs which is what I'm getting but I used to get 100 or so kbs downloads and nothings changed.

Upload limit 22.0kbs, 3 upload slots, 60 connections per torrent, 130 global connections, 2 active torrents, 1 download torrent. (only changed torrents after running to 13/13)

Net.max_halfopen is on 100. Didn't modify TCPIP.sys

Windows 7 professional.


No router/D-Link DSL 2740B modem

Iinet ADSL

If you mean something else please tell me what?

Link to comment
Share on other sites

Okay thanks to the above poster I got onto our service provider since the speed is on their end not mine and they confirmed (and fixed a problem). Now my torrrents are getting 2-3 hundred kbs even better than they used to. So thank you very much Dreadwingknight.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...