Archived

This topic is now archived and is closed to further replies.

cmeisel

µTorrent 3.3 Stable

Recommended Posts

so...ut 3.3b29216 eat more than 4GB RAM in fact??? and isn't detected by system itself...??(it should be memory leak, right?)

That's not a memory leak. That's windows' disk cache being stupid.

A memory leak would be visible in task manager under the process that is leaking. In the case of uTorrent, the INSTANT the process exceeded 2GB of ram, it would crash.

Share this post


Link to post
Share on other sites
I have this a long time. But not always. From some version and up. Downloaded files are not transferred correctly. I use "Force Re-Check" and the errors are found. Then the erroneous parts are downloaded correctly. Many times when the file is in zip format cannot unzip because of transfer errors. Then I use "Force Re-Check" and then I am able to unzip.

Looks like that this problem is more frequent with big files of 4GB+ and block size of 4MB.

The latest stable version has this problem. A few minutes ago two files of about 4GB tested and found with transfer problems.

I'd suggest that you try the latest 3.31 beta

The same problem with 3.3.1. It seems that happens with files that have 4MB pieces. All files checked up to 1.8GB never had a problem. Its very bad. A transfer app with unreliable transfers. Looks like that after 3.3 the problem existed before, is worse.

Share this post


Link to post
Share on other sites
so...ut 3.3b29216 eat more than 4GB RAM in fact??? and isn't detected by system itself...??(it should be memory leak, right?)

That's not a memory leak. That's windows' disk cache being stupid.

A memory leak would be visible in task manager under the process that is leaking. In the case of uTorrent, the INSTANT the process exceeded 2GB of ram, it would crash.

thx for the explaination

is there any solution to the problem...?

I remembered 3.2.x stable didn't cause it, but seems 3.2.x has a very bad DISK I/O for me (when I use 3.2.x, it always takes >15min to shutdown my PC after quit UT...but 3.3 is normal)

Share this post


Link to post
Share on other sites
How to disable yellow block "featured content" permanently ?

Tip #N in my guide below...

Share this post


Link to post
Share on other sites

uTorrent is getting worser and worser every update. What's happening? I can't even seed normally. I only seed to one peer. I can't even select all my torrents and delete, pause or stop. The buttons aren't working (can't press them). I had version 3.3 and went back to 3.2.3. This is ridiculous. :mad:

Share this post


Link to post
Share on other sites
'Featured Content' and 'New Apps!' are still present in uTorrent 3.3.

How about you try and configure/upgrade to get this:

dce7d6242510980.jpg

A hint: Hidden in my sig...

Share this post


Link to post
Share on other sites
I only seed to one peer.

Seems to me that only removing the upload limit - might help :(

Share this post


Link to post
Share on other sites
Seems to me that only removing the upload limit - helps :(

I tried that,but that does not solve the problem.:(

It would be nice that devs solve this problem quick. Because it is a very big problem.

Share this post


Link to post
Share on other sites
Seems to me that only removing the upload limit - helps :(

I tried that' date='but that does not solve the problem.:(

It would be nice that devs solve this problem quick. Because it is a very big problem.[/quote']

Do you care to possibly try one more thing? also set bt.ul_queue_factor = 254 in shift-F2-Advanced & restart ?

Share this post


Link to post
Share on other sites

Thanks rafi and mike20021969.

Problem is still there,only seeding to one peer (out of 100) on torrent :(

I hope that some of the devs will fix this big problem.

Share this post


Link to post
Share on other sites

Why is the main page of the website acting a bit strange? When I try downloading utorrent from the main page, it redirects me to the page where I can choose to download both the free and paid versions, and then when I click on the free version, I'm starting to download the Mac version of the program.

Another weird thing was when accessing the forums - I suddenly started seeing threads and posts that were old.

Share this post


Link to post
Share on other sites
and then when I click on the free version, I'm starting to download the Mac version of the program.

The Free Download button (for me) points to this address/web page:

http://www.utorrent.com/downloads/complete/os/win

I've not seen, or come across, a Mac version EVER when clicking the Free Download button.

I can't even see a Mac version under the Products button.

As for the other thing, I'm not seeing any old posts.

Share this post


Link to post
Share on other sites
and then when I click on the free version' date=' I'm starting to download the Mac version of the program.

[/quote']

The Free Download button (for me) points to this address/web page:

http://www.utorrent.com/downloads/complete/os/win

I've not seen, or come across, a Mac version EVER when clicking the Free Download button.

I can't even see a Mac version under the Products button.

As for the other thing, I'm not seeing any old posts.

This is what the link I receive when I click the Free button: http://staging.utorrent.com/downloads/complete/os/mac

The old posts thing was for a few times, now it seems it's OK.

Share this post


Link to post
Share on other sites
I can't find bt.ul_queue_factor in advanced

Whilst pressing Shift+F2' date=' click on Preferences button:

...

[/quote']

Thanks you :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.