Archived

This topic is now archived and is closed to further replies.

cmeisel

µTorrent 3.3 Stable

Recommended Posts

Any attempt to set an upload limit on a single torrent (even with 1 uploader) stops it from uploading altogether with 3.3 build 29111. That is completely broken. This alone makes 3.3 unusable for me.

CPU usage on a single download is now totally ridiculous. I have a quad core AMD running Windows 8 and approx 20mbit per second download connection (usually 1.4/1.5 megabytes per second on a torrent when things get going). I thought it was really bad before when it regularly chewed up 15-20% or CPU time. Now that's more like 35-45%.

This is the same torrent before:

77u323p

And after:

j3u330p

Overall, upload speeds seem faster/more resilient across multiple torrents. When there is other disc activity across the two drive raid array on which my torrents sit it also seems less prone to slow down like 3.23 did, which are both great positives.

Needless to say I'm firmly back on 3.23 though until the CPU and upload limiting issues are resolved.

Share this post


Link to post
Share on other sites
Doesn't happen on Win7 with 3.3.1. Make sure your uT taskbar-icon is customized as "show icon and notifications"

Yeah, I have always set the show all icons and notifications. :|

Share this post


Link to post
Share on other sites
Preferences -> UI Settings -> System Tray panel.

is "[ ] Always show tray icon" checked?

In this way it works but I want that the icon is displayed only when minimized. :)

Share this post


Link to post
Share on other sites
Any attempt to set an upload limit on a single torrent (even with 1 uploader) stops it from uploading altogether with 3.3 build 29111. That is completely broken. This alone makes 3.3 unusable for me.

Yeah, it seems to slow down the upload (to almost 0... ). Try waiting a minute or so, I see it picks up speed again...

Definitely shouldn't behave that way...

Share this post


Link to post
Share on other sites
Any attempt to set an upload limit on a single torrent (even with 1 uploader) stops it from uploading altogether with 3.3 build 29111. That is completely broken. This alone makes 3.3 unusable for me.

Yeah' date=' tt seems to slow down the upload (to almost 0... ). Try waiting a minute or so, I see it picks up speed again...

Definitely shouldn't behave that way...[/quote']

Thanks for that tip, I didn't leave it running long enough to notice that.

If only the CPU consumption would drop after a short while as well during downloading. That doesn't happen though.

Awaiting the next version.

Share this post


Link to post
Share on other sites
If only the CPU consumption would drop after a short while as well during downloading. That doesn't happen though.

Set net.low_cpu to true. I was sure I had it set to true, but it seems to have been reset to default - false - with all those updates...

Share this post


Link to post
Share on other sites

Still getting disk overload with the "improved" version in the same amount of time. Can't see any difference from the post ludde releases. Small changes to the interface and part of the crap-ware has been removed. Maybe after a few more downgrades we will get a decent version.

Is there a light installer without asking me about all the crapware? If I needany of that stuff I would download it separately.

I forgot to uncheck the toolbar which is checked by default last time and it took 15 minute to uninstall all the crapware/spyware. As much as I love another toolbar hanging around all my browsers I think I'll pass.

Share this post


Link to post
Share on other sites
Is there a light installer without asking me about all the crapware?

Yes. You just don't know how to use it right and make it "light"...

Share this post


Link to post
Share on other sites

The delete dialog box has not been fixed. Cancel is still the default and you have to press right on the keyboard (instead of left) to get to OK. Who writes the changelog?

Share this post


Link to post
Share on other sites
The delete dialog box has not been fixed. Cancel is still the default and you have to press right on the keyboard (instead of left) to get to OK. Who writes the changelog?

That change log entry was meant for the next version of 3.3.1. Youll see it in the release after 3.3.1.29105.

Share this post


Link to post
Share on other sites

That change log entry was meant for the next version of 3.3.1. Youll see it in the release after 3.3.1.29105.

Seems like you can save some effort. Part of it is already there... No need to fix things twice... ;)

--2013-02-15: Version 3.3 stable (build 29126)

- Fix: fix flushing of completed pieces immediately

- Fix: fix disk flushing not being triggered every time it should be

--2013-02-11: Version 3.3.1 (build 29105)

- Fix: fix flushing of completed pieces immediately

- Fix: fix disk flushing not being triggered every time it should be

I'm sure there is something new in 3.3 29126 as well. Why not just replace the text with the correct changelog for it?...

Share this post


Link to post
Share on other sites
If only the CPU consumption would drop after a short while as well during downloading. That doesn't happen though.

Set net.low_cpu to true. I was sure I had it set to true' date=' but it seems to have been reset to default - false - with all those updates...[/quote']

Sure enough it's back to hovering between 15-20% of CPU when downloading, which is definitely bearable because I don't download so much at full pace for very long. It quickly drops under 10% when less loaded. Thanks for pointing that out! One silly setting.

It's also the first version that runs happily when Ad-Muncher is running under Windows 8 x64 and more than 2200 (I now have 3500) torrents! Even the old 2.x versions behaved badly.

So I'm now reaaaallly happy - I can go back to an ad-less internet AND keep utorrent :D

Share this post


Link to post
Share on other sites

After starting uTorrent, the menu access (alt key) does not work.

The uTorrent windows has focus, but is seems the "subfocus" is on some strange part of it.

If I click anywhere inside the window and the press alt-F, then it works.

This is the last release (why isn't the build number in the about dialog copyable?).

I'll copy from the first post: 29126

It was similar, but quite the same with 29082.

Share this post


Link to post
Share on other sites
3.3 and 3.4 install into %appdata%/uTorrent/ to bypass the UAC (User Access Control) and allow "silent updates" to the client.

Oh, really? Then why do I get a UAC prompt (you read my other posts today)?

Share this post


Link to post
Share on other sites

Unfortunately, we need to throw the UAC dialog to add the windows firewall rule.

I just changed the port in uTorrent, then did the test in the Setup Guide and it was successful.

I also get green icon in the status bar and incoming connections on my torrents (flag I).

I tested this on Windows 8 Pro 64 bit.

An "enable firewall exception" dialog did appear (I only noticed this after the test, because it appeared under the uTorrent window), but I never clicked it during my test. After I canceled it.

Share this post


Link to post
Share on other sites
3.3 and 3.4 install into %appdata%/uTorrent/ to bypass the UAC (User Access Control) and allow "silent updates" to the client.

Oh' date=' really? Then why do I get a UAC prompt (you read my other posts today)?[/quote']

Maybe you should read the replies, and having several threads for ONE issue makes it bloody difficult to figure out what is going off.

Unless you are THE Administrator applications that "run at startup" NEED elevated permissions to start up.

Share this post


Link to post
Share on other sites

No they don't. Otherwise half of programs would not work.

Current when I log in there are two programs started and put an icon into systray.

Inexperienced users have dozens of them.

They never require AUC, as it would make the login process a nightmare.

Again, how about checking your "facts" before posting them?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.