Archived

This topic is now archived and is closed to further replies.

TylerW

µTorrent 3.3.1 RC

Recommended Posts

New 3.3.1 beta 29594 released:

No torrent info is shown in the files, info, peers, trackers, etc. tabs!!!

Same here (even with just 1 torrent).

(Going back to 29579 shows all the info instantly).

Share this post


Link to post
Share on other sites
New 3.3.1 beta 29594 released:

No torrent info is shown in the files' date=' info, peers, trackers, etc. tabs!!![/quote']

Same here (even with just 1 torrent).

(Going back to 29579 shows all the info instantly).

+1

Share this post


Link to post
Share on other sites

While the problem is solved, where I can download the previous build (29579)?.

path is %appdata%\utorrent\updates

that's all folks !

Share this post


Link to post
Share on other sites

thanks for fixing the create torrent dialogue

another problem I noticed although I not test latest was when you right click and say remove torrent and the data when it deletes and highlights the next torrent it dont show the correct stats peers etc in the panel and

have to click to another torrent and back again before it shows

Share this post


Link to post
Share on other sites
thanks for fixing the create torrent dialogue

Cancel/close button is still missing... :P

another problem I noticed although I not test latest was when you right click and say remove torrent and the data when it deletes and highlights the next torrent it dont show the correct stats peers etc in the panel and

have to click to another torrent and back again before it shows

I think this one was fixed in the latest beta...

Share this post


Link to post
Share on other sites
thanks for fixing the create torrent dialogue

another problem I noticed although I not test latest was when you right click and say remove torrent and the data when it deletes and highlights the next torrent it dont show the correct stats peers etc in the panel and

have to click to another torrent and back again before it shows

In deeds, it is a more general bug : when a torrent is highlighted, you click on the left to select another view, and infos are shown about another torrent ; if you are dumb enough to delete it, it is not the torrent highlighted which is destroyed, but this with infos shown ; I never reported this bug, just because devs MUST have noticed it by themselves. ( bug present since 2.0.0, not present on 1.8.5, if I remember correctly )

Share this post


Link to post
Share on other sites
never reported this bug, just because devs MUST have noticed it by themselves.

Funny one indeed!...;)

Share this post


Link to post
Share on other sites
if you are dumb enough to delete it

But... but... uTorrent users are not dumb... ;)

Share this post


Link to post
Share on other sites

not sure if its a bug but the play and stop buttons seem to have some lag on them

for 2013-04-24: Version 3.3.1 (build 29594)

perhaps I need to reboot laptop after upgrading

Share this post


Link to post
Share on other sites
not sure if its a bug but the play and stop buttons seem to have some lag on them

for 2013-04-24: Version 3.3.1 (build 29594)

perhaps I need to reboot laptop after upgrading

If you ask me, it's the same bug (root cause) as the lag in detailed/info-tabs not showing ASAP when selecting a torrent.

Most likely just someone (new?) is counting all the torrents now with each select (to solve some bugs), so to save himself the trouble of bookkeeping/hashing lists intended for the sake of speedup... How should he know that there is this old problem? No one has told him... :P

Share this post


Link to post
Share on other sites

Download rate limit bug? (sometimes when DHT automatically updates (not manually updates)) - http://img541.imageshack.us/img541/8687/315d46b22db1.png

My settings:

Set globally down. rate limit to 200 kB/s

bt.transp_disposition=31

Apply rate limit to transport overhead - checked

Limit local peer bandwidth - not checked

peer_policy - not used

dht - used

Share this post


Link to post
Share on other sites
On 29594 I cannot see any info on selected torrents

It is broke (and has already been reported).

Go back to 29579 in the meantime (hopefully, you'll find it in your updates folder).

Read from post #323 onwards.

Share this post


Link to post
Share on other sites
New 3.3.1 beta 29594 released:

No torrent info is shown in the files' date=' info, peers, trackers, etc. tabs!!![/quote']

+1

+1

No detailed info, or, the wrong info shown, the latter being few and far between.

Share this post


Link to post
Share on other sites

The latest or second-latest version of 3.3.1 beta introduced a new bug: when streaming a video, sometimes a piece gets "stuck".

I generally stream movies that are about 3mbps while downloading at around a rate of 10mbps (1.3MB/s and more). Sometimes the movie gets stuck. When I check utorrent, the "pieces" tab, I notice that there is a piece that is being downloaded, but for some reason blocks are not marked with dark green, they are not prioritized for streaming. All the other pieces with consecutively increasing id # are being prioritized for streaming, but the exact next one in the movie, the one with the next lowest id #, is not. The piece availability is >3, with those being the peers I am having that high download speed.

You can imagine that this completely blows streaming where you need every piece. Sometimes the player can jump over it and display some garbage blocks, but if each piece is large (4-16MB in size) it presents problems.

Current build is 29594, but it's possible that the problem was introduced by an earlier build.

I've noticed this problem both on my desktop and on my laptop with both smaller movies and larger ones. Both higher bitrates and smaller bitrates.

The torrents are healthy with plenty of seeds. And the speeds I am downloading at is 2-3 times higher than the movie bitrate (video+audio), and that speed is mostly from seeds. So I can safely exclude availability issues.

Share this post


Link to post
Share on other sites
when streaming a video, sometimes a piece gets "stuck".

Eventually, was the movie (including this piece) fully downloaded?

Share this post


Link to post
Share on other sites

I guess not. There is something wich triggers off writing from cache to disk at high speeds. When you pause a torrent with scheduler or manually, resume get downloading, but not seeding : this means all finished torrents stop seeding. So there is this case where downloading is also impacted with the bug. Looks as if a threshold was reached in disk activity ; when downloading at highspeed, dl is not so high that my connection allows (32Mbps), only 1 500 KB/sec. Suddenly dl rate climbs to 2.9-3.1MB/Sec, and taking a look into pieces tab, plenty of full downloaded pieces are storing, appearing in light green ; task manager show utorrent.exe growing at the rythm of memory cache ; when utorrent.exe is 1 200 000k big, a "tung" yield out of the speakers, then utorrent.exe grows for ever fast to 1.6-1.7GB, and exits out of memory!!! (no crashdump generated...)

When I say : dl not as high as it should be, downloading a torrent from 3 seedboxes, one of them topping at 60MB/Sec.

Share this post


Link to post
Share on other sites

Did uTorrent 3.3.1 stopped being "portable"?

I use to simply copy the "*.dat" files into the same directory as uTorrent and it worked fine. eg on a USB drive or portable HDD. The FAQ that tells how it is done is still present, but the behavior has changed.

But now, the *.dat files are copied all over the place and I also get that dreaded "Old Version of uTorrent Running" WARNING when I test different versions of uTorrent and Bittorrent v3.3.1/7.8....

Can someone point me to the new FAQ or instructions of how to make uTorrent "portable" again, without letting it copy its data files all over the place?

Thanks...

Share this post


Link to post
Share on other sites

Message "older version running" indicates that a version of utorrent has been launched, which is different from this you want to run ; try to locate it with task manager, and rename it, or delete it .

Share this post


Link to post
Share on other sites
New 3.3.1 beta 29594 released:

No torrent info is shown in the files' date=' info, peers, trackers, etc. tabs!!![/quote']

Same here (even with just 1 torrent).

(Going back to 29579 shows all the info instantly).

Same here.

I've had it with uTorrent. I was running the stable 3-point-something version a while ago, then suddenly some update broke everything and randomly torrents were doomed to remain at 0.0%, stuck in checking-limbo or whatnot. Restarting uTorrent sometimes fixed it, sometimes it didn't. So I read up on the forums whether there was a fix, and all I could find was the recommendation to try the beta.

So I installed the beta and everything worked fine. Then another update came out and uTorrent broke down again with the above bug. No torrent info, no peers, no trackers, nothing. It seems like for every bug that gets fixed three others pop up.

I don't know what's going on, but it feels like whoever is working on this is dropping the ball continuously. All I really want from my torrent software is stability and reliability. I feel like the time and energy that I'd waste in getting this to work would be better spend in finding an alternative, especially if I'm going to have to refix shit every time there's a new update that breaks some other part.

So, after about 5 years of having used uTorrent, I've uninstalled it and am retiring it from my software package. Thanks for having provided me with a free and good torrent engine for all those years. Perhaps I'll re-install it in half a year or so; perhaps things'll have improved by then.

Share this post


Link to post
Share on other sites

No torrent info is shown in the files' date=' info, peers, trackers, etc. tabs!!![/quote']

Same here (even with just 1 torrent).

(Going back to 29579 shows all the info instantly).

Same here.

I've had it with uTorrent. I was running the stable 3-point-something version a while ago, then suddenly some update broke everything and randomly torrents were doomed to remain at 0.0%, stuck in checking-limbo or whatnot. Restarting uTorrent sometimes fixed it, sometimes it didn't. So I read up on the forums whether there was a fix, and all I could find was the recommendation to try the beta.

So I installed the beta and everything worked fine. Then another update came out and uTorrent broke down again with the above bug. No torrent info, no peers, no trackers, nothing. It seems like for every bug that gets fixed three others pop up.

I don't know what's going on, but it feels like whoever is working on this is dropping the ball continuously. All I really want from my torrent software is stability and reliability. I feel like the time and energy that I'd waste in getting this to work would be better spend in finding an alternative, especially if I'm going to have to refix shit every time there's a new update that breaks some other part.

So, after about 5 years of having used uTorrent, I've uninstalled it and am retiring it from my software package. Thanks for having provided me with a free and good torrent engine for all those years. Perhaps I'll re-install it in half a year or so; perhaps things'll have improved by then.

I use to have similar problems, and I swore that it was the developers fault. What you should be looking at is what else do you have installed on your system? That could be causing allot of problems, I'm just trouble shooting. You also might want to try, before updating utorrent, make sure you back up your resume.dat files, then completely uninstall uTorrent including the settings, then delete the %AppData%/uTorrent directory. Then do a clean install, then before doing anything, go to Setup Guide and let it run the tests, then save the settings, then, set up your preferences with the minimal changes. You should change the Directories, Queueing, Remote, UI Extra, and Web UI settings only. If you still have the same problems, then it COULD be something on your system. I know this sounds like allot of work, but if you want to keep things running good, you have to do some maintenance. Personally, I usually, back up my personal files, then I wipe the boot drive and do a CLEAN install of Windows. That usually clears up any problems I've been having. It's totally up to you what you want to do. This is just my advice.

After I did all that, and IF I was still having the same problem, then I ALWAYS went back to the Stable Build. If you set up uTorrent with your own specific colors, icons ect., before I would do anything, make/copy/move the current.btskin to your backup drive, but don't keep your old settings.dat file. I've had similar problems, and I tried other P2P clients, and uTorrent is allot better, and has allot of features I like. :cool:

Share this post


Link to post
Share on other sites

Detail Info and peers etc work fine for me on the 29594 build

however if i click stop torrent.. normally in 2,2.1 and older builds I could

then click start torrent again but it looses focus

then I search for the torrent and click on it and the

tool bar wont light up for play and stop etc

so I have to right click and say start

some weird lag or bug there.

how come things that worked no longer work

its very odd.. surely each build is not rewritting

the whole tool bars and columns all the time?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.