Jump to content

No New Torrent Dialog. Can't Add New Torrents

Recommended Posts

I'm using uTorrent 3.3 (Build 29462) [32-bit] on Windows 7. Here's my problem...

When I click the "Add Torrent" button, I get the window that pops up and allows me to search for the torrent file I want to add. But, as soon as I click open, nothing happens. If I look quickly, I can faintly see the new torrent dialog pop up for a fraction of a second, and then it disappears.

It just started doing it this morning. I haven't updated anything. I don't think I've made any changes to my PC that would affect uTorrent in any way.

I've tried shutting down uTorrent and starting it back up, restarting the computer. Nothing works. I'm completely unable to add new torrents at this point.

Any help would be greatly appreciated.

Link to comment
Share on other sites

  • 2 weeks later...

For anyone that comes across this thread at the height of their frustration, there is a solution!

Uninstall uTorrent and select the option to uninstall SETTINGS.

Then reinstall and you should be good to go. It appears that this is a settings incompatibility issue, at least in my case. Annoying that I had to re-add a dozen torrents I was sharing with people, but great that I figured out how to get it working again after a week without the time to look into a solution...

Link to comment
Share on other sites

Just had this issue start today. I updated awhile ago. I still had some torrents seeding but couldn't add any new ones. Magnet links open utorrent but do not bring up the normal dialog box. Adding through the file menu or double-clicking a torrent file does not bring it up, either. If I add a torrent from a torrent file, then click on the magnet link for that torrent, it DOES bring up the box that says I already have the torrent in the list, do I want to merge the tracker lists. But there is no torrent in the list and nothing is downloading. Just to reiterate, this is not due to an update, as I update utorrent weeks ago. I don't want to blow away my config and reinstall because I have too many rss feeds. I tried reinstalling over top and that didn't correct the issue.

Also I just noticed that none of my rss feeds are displaying their items in the right pane.

Link to comment
Share on other sites

Found a solution although it's not the best...

Close utorrent completely.

Go to your uTorrent install directory (mine is c:\Users\username\AppData\Roaming\utorrent)

and delete:





Then reopen utorrent. You will have to re-enter all your settings, but if you don't delete the rss.dat you'll keep your feeds, at least... :|

Link to comment
Share on other sites

  • 3 months later...

I just wanted to check back in with some additional info. This problem had gone away but has returned. I've discovered that if I uncheck the "Show options to change the name and location of the torrent data," torrents will start downloading automatically. But, as soon as I try to re-enable that dialog, it goes right back to not working. It's almost like there's something preventing the new torrent dialog from popping up.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...