Jump to content

Fixed Connecting to peers


Recommended Posts

I was just about to post the big message below when I fixed my problem but I saw so many here with a similar issue I decided to post what worked for me in the hope it might help someone else.

Though I had reboot the server before I just rebooted it again and now it works. The only difference I can think of is that the first time I had not uninstalled/reinstalled µTorrent yet. The other thing is that UDP port bind error was always present when I was having the problem and this time it’s gone. I’m fairly certain that this is an indicator of the fault. It seems that although µTorrent was removed there was some residual process locking up that port.

Anyway I hope this helps someone.

Original post:


Box: SBS 2008 with loads of cores and RAM.


Status of new torrents “Connecting to peers”

Trackers all have the status of “Connection Timed Out”

Network OK in status bar.

DHT is often “Waiting to log in”

At startup I get this error” “UDP port bind failed (10048) Only one usage of each socket address (protocol/network address/port) is normally permitted.”

Things I’ve tried:

Reboot the server

Reboot uVerse box (modem)

Reboot router

Router FW off

Turned firewall off.

Ran setup guide. Worked perfect with no problems found.

Deleted .old files

Tried reinstall.

Tried 3.3.1 and 3.4 but installers crash on both.

Installed µTorrent on another machine and it worked fine.

Removed server FW rules and manually added a new one for utorrent.

Forgive me in advance as I know many have posted here with this same problem but none of them has yielded a solution and I’ve been reading and trying for 4 hours.

All weekend my RSS Downloader was picking up torrents and downloading them quickly. Today I realized that there should have been a couple from Monday that didn’t show up. I found them both there “Connecting to peers” and trackers “Connection timed out” and they had been there for hours, maybe even a day. Despite all the things I tried above nothing fixed the problem. But when I installed on µTorrent another machine it worked great there proving nothing was wrong with the router or Internet connection. Interestingly the downloads I tried on the other machine started working on my server. I guess it’s the local peer feature. But once connected it shows that they can download just fine. But even then I saw no upload traffic. The UDP port binding error looks suspicious but I couldn’t find much on that online. Does anyone have any what could be causing that and how I can fix it?

Link to comment
Share on other sites

  • 1 month later...


This topic is now archived and is closed to further replies.

  • Create New...