Jump to content

Help Please - Permissions ???


Recommended Posts

I have finally created a second account to use on my machine for general purposes. My usual account is an Administrator Account. I have come to understand that it is better to use a regular user account for daily and general usage, mostly for security purposes. So, I created a second Regular User Account. I have changed the uTorrent File Properties to Shared.

Now, when I am logged on as Administrator, I can get on the internet, go to mt favorite Torrent Site, click on the "Download Torrent" link, and the correct information is loaded into uTorrent and everything works like it always has.

When I am logged in as a Regular User, I get on the internet, go to my favorite Torrent Site, click on the "Download Torrent" link, and nothing happens. If I simply find the uTorrent file, I can open it like that. I don't know how to load all the correct torrent information manually. Nor do I really want to. I would like to make it so that uTorrent works when I am logged in as a Regular User like it does when I am logged in as Administrator.

Can anyone please tell me how I can do that?

Thanks In Advance

Link to comment
Share on other sites

Hi ciaobaby.

I appreciate you taking the time to respond to my inquiry. Really. This response has a twofold purpose: to continue the inquiry because the problem is not solved and to provide some constructive feedback.

Your note,

"This ˅˅˅˅˅˅˅˅˅˅˅˅˅˅˅˅˅˅˅˅ is a signature not a reply.

Smarter than the av-er-age bear! Boo-Boo. ... AND if you see something labeled "Help" ..... try clicking it because it probably will!"

made very little sense to me or the others here with me. We're talking everyone here has a graduate degree. So, while we may not be smart, we aren't stupid either.

I did browse the Help section for about 45 minutes with no hint of success before I gave up and tried this post, thinking that some kind soul who actually knew how to solve my problem would help, if that's what you are referring to in your message.

Then I got creative with my inferences to your message and tried the link above the message entitled "Run As Administrator". That seemed a bit more promising. Now my expertise is in Synthetic Organic Chemistry and not Computer Science, but I can follow the discussion to some small extent. After carefully reading the article, I guessed that maybe "Option 5" would be most appropriate, judging from the "Note", which says "This will show you how to always have the program run as administrator when you open it". That was based on my guess that the problem is occurring because uTorrent needs to be running by the Administrator for this, although I wonder how that could be happening if the Web Page that has the Torrent Link on it does not seem to even be activating uTorrent, so it isn't even running for it to decide whether it is going to run or not based on whether a Regular User or Administrator is trying to run it.

I carefully followed those instructions and then logged out as Administrator and then logged back in as a Regular User. The behavior, or rather lack of it is the same as before.

The problem seems to be that while logged in as administrator, uTorrent can be activated, by clicking on the Link on the Webpage that supplies the information that makes the torrent work. And when logged in as a Regular User, clicking on the link that is supposed to supply the information that supposedly makes the torrent work does not activate uTorrent, or open it and automatically put in the information into uTorrent to make it work.

I really am not trying to be stupid or ungrateful. I certainly am not trying to be a Forum Troll. But, I have to say that the response that was left for me seemed to have the intent of making me feel stupid. I am sure/hoping that wasn't your intent. It is good to have some levity is something as dry as this topic. I just figured that just in case folks aren't aware of it, their responses to those of us who are not experts in this topic can give us an unintended (hopefully) impression of what is meant with a response.

Before I give up on this idea, if someone would tell me if this is even possible, that would be nice. If someone could tell me why it is not working for me, that would be even better. If someone could give clear instruction on how to make it work, or exactly where I can find directions to make it work, that would be even better yet.

Maybe I need to understand how uTorrent is "activated" when the Link on the Webpage that supposedly loads the appropriate torrent information is clicked. If someone were to tell me where I can find that information, that would be pretty cool.

Link to comment
Share on other sites

Are you trying to open Magnet links or .torrent-files?

Also which Internet browser do you use?

Fix for magnets in Google Chrome:

1. Navigate to %LOCALAPPDATA%\Google\Chrome\User Data

2. Open the file Local State with e.g. Notepad.

3. Change following to false: "magnet": true, > "magnet": false,

If it doesn't exist, create it under "excluded_schemes": {

Link to comment
Share on other sites

Your note,

"This ˅˅˅˅˅˅˅˅˅˅˅˅˅˅˅˅˅˅˅˅ is a signature not a reply.

Smarter than the av-er-age bear! Boo-Boo. ... AND if you see something labeled "Help" ..... try clicking it because it probably will!"

That 'note' is there because my signature is NOT PART OF THE REPLY to the question!!!!!!!

And did you actually read the document I linked to that tells you HOW to run a program in 'The Administrator' context while you are logged in as a standard user??????????????

Link to comment
Share on other sites

Hi Andreasvb,

i use Comodo Dragon, which is a more secure Chrome based browser.

I always click on the magnet link.

It works fine as long as I am logged in as administrator.

Also, I have recently noticed that while I have loaded stuff into uTorrent an administrator, and then later shut down all programs and then the computer, I can later turn on my machine and log on as administrator and then open uTorrent and all the torrents I set up earlier start downloading again. But, if I turn on the computer and log on as Regular User and then find and open uTorrent, it is empty. That is, there are no entries (torrents listed to download).

I am not sure I need to do the fix you suggest since it works with an administrator logon.

I guess there are two things I am not understanding.

1) How is uTorrent "activated" when I click on a magnet link on an internet site? Is that something that can be managed?


2) How is the version of uTorrent I am running completely shared with a Regular User so that it can be opened and continue up and down loading while a Regular User is logged in.. I am thinking that is somehow managed through permissions and sharing.

Thanks for your time.

Link to comment
Share on other sites

This will be a very detailed explanation, sorry. :D

Comodo Dragon is based on Google Chrome, so it may use the same mechanism as for the Magnet linking. See if you can find it in the same file.

// Question 1 //

To make Magnets work (not how do magnets work ;) ) you need to understand the basics of a URI scheme, what opens http:, ftp: etc.

Magnets are the same, it's magnet: and your browser need to know what to do with it.

More info:



In Google Chrome's case it's in that Local State-file that tells it to ignore a specific URI scheme or not.

Each browser has its own way, and you need to figure it out how yours do it.

If you don't have any programs associated with Magnet links the following will happen, in Google Chrome on Windows 8:

No apps are installed to open this type of link
Look for an app in the Store

Choosing Store should bring it up and find different programs for handling torrent files.

I can handle security myself and have disabled UAC, normal users should leave it on.

Thus, following dialog appear:

ms-windows-store:Assoc?protocoI= magnet
This app can't be activated when UAC is disabled.

Then I open µTorrent and associate it with torrent files in Preferences, that make it create those Windows Registry entries other programs need.

This is mine:

@="Magnet URI"
"URL Protocol"=""
"Content Type"="application/x-magnet"

@="\"D:\\Apps\\PortableApps\\µTorrent\\utorrent.exe\" \"%1\""

I click on the Magnet link again and now I get the following, asking what I want to do:

External Protocol Request

Google Chrome needs to launch an external application to handle magnet:

links. The link requested is magnet:?xt=urn:btih:...

The following application will be launched if you accept this request:

"D:\Apps\PortabIeApps\uTorrent\utorrent.exe "?xt=urn:btih:...

If you did not initiate this request, it may represent an attempted attack on your system.

Unless you took an explicit action to initiate this request, you should press Do Nothing.

* Remember my choice for all links of this type.

Launch Application / Do Nothing

When I choose Launch, it opens µTorrent and from there on it's µTorrent that will handle the rest.

A computer is "dumb", it only do what you tell it to do, it doesn't have a mind ot its own, but maybe sometimes you'd wish it had. :rolleyes:

So, when you click on that link, in your browser, it has nothing to do with µTorrent, it's only the program you're interacting with that can make a call (yes, you could design programs to trigger passively when something changes in another program, like catching a copy of a URL. But then it would check that in the background all the time, draining resources.)

But the point here is that it's the host program that makes the call and fires an action.

When Google Chrome sees that it handles the magnet: URI it will then see what you want to do with it.

What will happen if you set

Remember my choice for all links of this type

and then click on Do Nothing is, you've told it exactly do that:

It will set in Local State that it will exclude that type of request in the future by setting "magnet": true, under exclude, as you've told it to never do anything with it.

And then you think, I'll fix it by reinstall the program (about 10 times already, and it's still the same, strange you think, maybe one more time will fix it?)

Here's another tricky part. Only the program gets reinstalled (usually), not your profile with it.

That would make you a sad panda, if all your bookmarks and whatnot are gone when starting it up again (caring about the user).

And there are programs that will remove everything, but most programs today will let user data be intact.

So you're left with that broken profile of yours, so you need to either figure out how to change, if possible, that setting that handles the option you once told it to do.

You maybe check for an option somewhere, no, not in chrome://settings/ so you might go little deeper, chrome://flags. Not there either.

Doing another user in Google Chrome won't help as it's a more global setting, so you still need to change it manually somehow.

So you're left with edit or remove the file, also knowing where and which file(s) contain the setting.

And this was only for Google Chrome on Windows, mind you. ;)

Although, the principles are the same on other browsers.

// Question 2 //

It does have something to do with permissions, but not in the way you think.

In Windows Vista and later you have UAC that won't let programs store settings in Program Files (write access).

µTorrent is usually installed in your profile (settings and torrents, exe in Program Files), and it won't be shared to anyone, only that specific account.

Doesn't matter if you're admin, you can't write to Program Files unless you allow it, each time, manually.

You can make it portable so it can be shared, that's what I do, even though I only use one account. I find it easier with everything in one place.

Then you place everything outside that Program Files-folder, maybe on another drive or just somewhere in your profile-folder where you have write access.

But if you have it inside the profile-folder only that user will be able to use it, obviously.

I recommend using it on another drive everyone has write access to.

You can disable UAC and do whatever in Program Files, but µTorrent will still save everything in user profile as you haven't told it not to.

The secret is that it need settings.dat where its exe is for making it portable.

To make it fully portable it needs to be on a USB drive, it will even say Portable in the title when you run it, and will warn you about exiting before disconnecting the drive.

Read here more about the different options: http://www.utorrent.com/help/faq/installation [ Installation - FAQ - Help - µTorrent ]

Hope this clears it up a bit. ^ ^,

TL;DR: Your settings are independent between your user accounts (both Comodo Dragon and µTorrent). One where you've told it to open Magnet links and one you've told it to do nothing, and never ask again.

Link to comment
Share on other sites

2) How is the version of uTorrent I am running completely shared with a Regular User so that it can be opened and continue up and down loading while a Regular User is logged in.. I am thinking that is somehow managed through permissions and sharing.

You set it up as "encapsulated" and set it to start with a 'shortcut' in "All Users" startup location, this will also require disabling UAC so the user does not get 'prompted' to allow the application start up.

The download locations also have to be in "publicly accessible" drive locations.

Link to comment
Share on other sites

A..svb, Don't be sorry, I know it took a bit of your time and brain cells to share all of the above. I wish I had professors in school like you! Thank-you very much.

and c..baby, Your last contribution also helps tremendously. Thank-you. I think that for those of us that don't use forums much, your signature can be confusing if there isn't a lot of text before it (compare with Andrea's).

After I have digested all this and applied it, I'll report what happened. Give me a few days.

Have a great day!

Link to comment
Share on other sites

OK, here's my most recent report.

If it seems strange that someone wants to do what I am trying to do, picture this. You are a one computer household. You have kids. It seems reasonable to want to prevent unauthorized/accidental/incorrectly done changes to your machine. Also, there is the whole security thing that it is better to run your computer regularly as a Regular User, than as an Administrator. But you would also like uTorrent to be run while the Regular User is using it and maybe allow the Regular User to add a Torrent if they wish.

I cannot understand why this is so hard to do.

Here are my notes.


Trying to make it so that whatever torrents that were loaded into uTorrent (uT) by the Administrator (Adm) when logged into Windows Vista are also loaded into uT when a Regular User (RU) is logged in (not Adm) and then the RU opens uT. Currently that is not happening. If RU opens uT, it has no torrents loaded into it.

Also and separately, while uT will automatically open and load a torrent that is activated on a website when the link for the magnet is clicked when the Adm is logged in, it does nothing if RU is logged in.

Two fairly long discussions were posted to the uT Forum.

Doing Asvb's suggestion makes the enigma machine from WWII look like a Dick and Jane Book.

Users/Administrator/AppData/Local/Comodo/Dragon/User Data/Local State


"protocol_handler": {

excluded_schemes": {

"magnet": false, (8th down in the list)

She says "It will set in Local State that it will exclude that type of request in the future by setting "magnet": true, under exclude, as you've told it to never do anything with it."

It's already set as "false"

Now trying the same for Regular User. It's already set as "false" there too.

Trying Default. Comodo's not there.

Trying Public. No AppData there.


Open uT

Preferences/Advanced/Web UI

Checked "Enable Web UI, Entering Adm password in the box to effect changes.

Check "Enable Guest Account with User Name" and enter the appropriate RU name.

This is a Guess Action (GA).


Looking into cb's suggestion - Googling "encapsulated" reveals little of use to me. I'll try to decipher this suggestion.

Cannot find %AppData%\uTorrent folder.

Sharing all my AppData/Roaming/uT with RU does nothing. GA

After re-creating a Regular User

A million Comodo permission requests pop up also. Clicked OK for all of them.

Suddenly Windows defender is warning me about antivirus and firewall.

Comodo Application Agent is not running! Run Diagnostics button is clicked and after a few minutes it says the computer may need to be restarted. No change though.

The Diagnostics Utility, run from the Comodo more tab says there is nothing wrong.

Magically went away after shutting it down and letting it sit overnight.

Log in as RU. All looks good. Comodo is OK.

Dragon still doesn't open uT nor does opening uT load what is does when Adm is logged in.

Users/JC/AppData/LocalLow/uT Properties - Sharing. Set to share w/ RU. GA

Still same as above.

Going back and sharing Cache. GA


The ie Folder has a bunch of temp files in it dated from roughly when I set up torrents downloading as Adm. Sharing that also. GA


If all this confusion isn't enough, it get's better...

There are two places where I have found uT.exe. One version is in Program Files and the other is in Adm AppData/Roaming.

Mouse Hover says C/Program Files/uT is v3.2.0.27568

Mouse Hover says C/Users/Admin/AppData/Roaming/uT is v3.3.0.29677

Both bring up current (Adm. loaded torrents are loaded) version when logged in as Adm. ???

Gave RU Full Control in C/Users/Admin/AppData/Roaming/uT/uT.exe because no sharing option is offered. GA


I'll bet I don't fully understand Sharing even though i have read about it.

Another way to say what it is I am trying to figure out is: Where is the data stored that is automatically loading into uT when I am signed in as Adm? And, how can I get that same data to automatically load when I am signed in as RU?

I think maybe I give up.

I have the greatest difficulty believing I am the only person who has ever tried to do this.

If I ever get this figured out. I'll post easy to follow instructions for the other freaks like me.

I do appreciate the time and energy others have spent trying to help me do this.

Link to comment
Share on other sites

Best Solution: Run a TRUE multi-user client such as MLDonkey rather than trying to fudge it with an application that is intended to run in a single user context only.

And, how can I get that same data to automatically load when I am signed in as RU?
Does that mean you didn't read the user manual about running an encapsulated instance of uTorrent.
Link to comment
Share on other sites

Can you try install regular Google Chrome instead and see if it works with that?

What ciaobaby means with encapsulated is portable, just another word.

Read this how to make one: http://www.utorrent.com/help/faq/installation#faq4 [ Installation - FAQ - Help - µTorrent ]

µTorrent will check in %AppData%\uTorrent and use that if it's not installed as portable, regardless where utorrent.exe is located.

Just make sure everyone can write to the folder you place everything in and it should work out fine. :)

Link to comment
Share on other sites

i run u torrent at my nearest net caffe for free downloads everything was ok i have downloaded a lot from there but now the caffe owner has installed a new window , no problem i m with the same trick again, using the boss key to hide from task bar and renaming to hide from task manager, and hided in regisrty also but the simple problem is that whan i m shutting down the window the windows automatically shows a box ending program utorrent.exe .so on next system restart utorrent does not run automatically plzzz tell me how to handle this in wndow xp sp3

Link to comment
Share on other sites

Final Notes

After more experimentation, it was discovered that uT.exe is placed in C/Program Files by the installer, and not in User/AppData/Roaming (where the other uT data is placed and also later created as needed). It is not known how the extra file was placed there. All versions of uT were uninstalled. Anything else uT related was searched for and deleted. Then the most current version was downloaded and installed by Regular User (RU). Then it was found to be activated by a click on the Magnet Link on the Internet Torrent Site. Problem Solved. The extra version of uT.exe in AppData/Roaming may have been interfering with its operation.

A way to share the uT data created by the Administrator was not found. The best working fix to use the data created by Adm is to copy the the entire uT AppData file from Adm to the RU's AppData file. (There were a lot of files that had been loaded into uT already and it was desired to determine if it works.) Afterwards, simplest is to only use RU as the uT operator/user.

So, the "instructions I would give anyone who is trying to do what I have described previously is the following.

1) Get rid of (uninstall and delete) all previously installed uT files on the machine.

2) Log on as the desired Regular User. Download and install the current version of uT.

3) Use the "Setup Guide" and then set up the "Preferences".

4) Only use uT as a RU and not as Adm.

For the problems I was having, Step 1 was key.

Now for "retrospection".

One of the Post contributors was great. While they weren't able to give me simple stepped instructions, that person was very informative and the information shared did help my understanding of torrents and uT greatly. It also inspired me to keep trying for a solution. It was obvious they spent a fair amount of their time trying to help me.

The other person that regularly responded to my new experience with Forums was referred to by several other people I was sharing my learing experience as something I was not familiar with. After googling "Forum Troll", I initially rose to their defense. I mean, I am probably pretty eccentric myself and I do try not to negatively judge other people unless I really need to. Now, being the good scientist I am, and while I mostly like the Physical sciences, I do appreciate the psychological and social sciences. Also, while most of the world avoids it, I like "calling a spade a spade". So I figured I would do some research and share the results. I expanded the sharing of my notes and all the postings on this topic with twelve other easy to get along with and intelligent people, asking them for their opinion of the other contributors to my Topic.

While one of the regular contributors got consistently very favorable and complimentary remarks, the other did not. The word "Troll" was used specifically by ten of the twelve. Eleven of the twelve advised "Ignore". Me? Life is too short to waste on dwelling on this any more than I already have, or by judging it.

I will say that it should be obvious to most normal people that I am not fluent in computerspeak. Also, that the odds are high that I will not know what is meant by some of the terminology, and that I am not going to waste my time searching for and learning all the definitions when what was said could easily have have been said in a less technical and more easily understood way, as was abundantly illustrated by the one respondent who was more user friendly. I will say: I was positively impressed by one person here, I was not "inspired" to feel stupid, and I solved my problem, sortof.

I guess, since I am on a roll, I can't resist.

"And did you actually read the document I linked to that tells you HOW to run a program in 'The Administrator' context while you are logged in as a standard user??????????????"

In the reply this was a response to, a full paragraph was devoted to a discussion of my attempt to glean any useful information from the document in question. Also, it looks like there is some trouble with the repeat function on one of your keys. That can be corrected from the Control Panel/Keyboard.

Here's another one...

"Run a TRUE multi-user client such as MLDonkey rather than trying to fudge it with an application that is intended to run in a single user context only.

Does that mean you didn't read the user manual about running an encapsulated instance of uTorrent."

Any moron should be able to tell instantly uT is a single user context only application. It's totally obvious. Damn, I must be dumber than a box of hammers! There are eleven written guides at the uT site. I figured it would be a common courtesy to read through them to try to find my answer before troubling anyone with a question. There are none entitled "running an encapsulated instance of uTorrent" and I found no reference to such when I did read through them. But at least us hammers know an interrogative is punctuated with a question mark. I'm guessing someone doesn't have a girlfriend.

On a separate note, it appears I have the dubious honor of "Getting my thread hijacked". I am told this is another type of Troll.

I guess since I have sortof solved my problem, I am done here. Thank-you all! Well, almost all.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...