Jump to content

µTorrent not working with proxy

Recommended Posts

I've been attempting to use uTorrent with a SOCKS5 proxy (PrivateInternetAccess.com if that helps diagnose the issue), but I can't seem to get it working consistently. On the other hand, if the proxy is off everything works great.

All of the torrents are stuck on "Connecting". Every 24 hours roughly, the client will take a fit and download 6 torrents before returning to "Connecting" on the rest. None of the torrents seed and the connection says either "Not connectable" or "No incoming connections". I suspect that these torrents have slipped passed the proxy setting somehow and that's the only reason it works.

The message log shows lots of errors, such as:

Disconnect: Disconnect: Proxy connect error: connection closed by peer

Connecting: source: L

Disconnect: Peer error: offline (timed out)

The "source: L" message is interesting as I've read elsewhere that Local Peer Discovery hasn't been added to the Mac version yet.

I took a crack at WireShark for packet sniffing, but all I can see is a back and forth between my computer and the proxy with my login credentials going out and "m" coming back. I tried to decode to HTTP but nothing happened.

I should add that I see ICMP "Destination port unreachable" errors too, but from what I've read, this is to be expected.

For settings, I tried to mimic the proxy setting advice I've seen elsewhere for Windows. Namely, set a port that I had already forwarded on my router and then turned off Random port and NAT-PMP. I've also used the fqdn and a particular IP to see if that made a difference.

Any assistance is appreciated!

Link to comment
Share on other sites

So this kind of performance is to be expected? Strange that I only see Mac people complaining about various proxies with various Mac-based BT clients. Windows folks seem to be ok.

I suppose my alternative is to bottle a VPN in a VM, but I'm not crazy about the overhead required to run that.

I did see SOCKS5 proxy issues resolved in libtorrent 0.16.10, but µTorrent doesn't use libtorrent, does it?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...