Jump to content

Can't set port 80 for Incoming TCP


Recommended Posts

I have a firewall that I can't manage which blocks any port but 80, 443 or other common ports.

When I try to change the port with 80 or 443 on uTorrent for Mac and I press enter to confirm the port I inserted becomes 0 and there's no way to change that port with 80 or 443.

What can I do??

Thank you in advance.

Link to comment
Share on other sites

I don't think you understood my problem.

If that would have been the problem, after hitting enter to confirm my port choice, i should have seen the port I chose in the setting pane. But when I hit enter after typing the port, the textbox for the port changes instantly in "0". It doesn't let me set any port that is lower than 1024. If I had any matter with privileged or already used ports I could have changed the port anyway and after a while the "led" in the status bar should have become red.

Link to comment
Share on other sites

I don't think you understood my problem.
Nope, you don't understand what privileged ports are.

'Privileged' ports are the port numbers between 0 and 1023, and if you are not the root user you cannot bind ANY process to ANY privileged port.



Link to comment
Share on other sites

Do bear in mind that setting ANY application to run as 'root' is ABSOLUTELY NOT recommended, because it has serious security implications for the machine


(replace [Application] with the fully qualified path to the uTorrent binary.)

set uTorrent to be 'owned' by 'root'

chown root [Application]

set permissions to the file with:

chmod 4755 [Application]

The extra '4' is to set permission for any user to run the executable and have it always run as the root user.

Do NOT do this on ANY executable that could be used maliciously.

Link to comment
Share on other sites

  • 1 year later...

Tried for over 2 hours now and think I'm eligible to ask now ;)


I've set ownership succesfully to root

I've set the permissions as you instructed


I see the changes happen in the "Info" screen so they are made.


I've reset the computer, and other 101 things but still cannot for some reason change the port to a privileged one, in my case, 81.


I enter the port number, hit enter but it changes to zero as soon as i hit enter or exit the window.


Assistance appreciated

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...