Archived

This topic is now archived and is closed to further replies.

AdamK

3.4.x Beta

Recommended Posts

Hi Fellow utorrent users,

 

Could someone with the SSE related issue try build 30657, and let us know if this solves the issue for you?

 

Thank you

 

is this change a fix to a bug, or a change to take advantage of previously unused SSE functionality ?

Share this post


Link to post
Share on other sites

While downloading 100mb wasted 10 hashfails.I exited the utorrent and restarted then also it downloading corrupted data.Is there any way to fix it.

Share this post


Link to post
Share on other sites

is this change a fix to a bug, or a change to take advantage of previously unused SSE functionality ?

 

 

Here's what happened: when we switched from compiling uTorrent with Visual Studio 2008 to using VS 2012, the default instruction set emitted changed from SSE to SSE2.

 

However, we didn't notice this until very recently, because relatively few people run windows with those SSE only CPUs. As more people started getting 3.4, we began getting reports that it would not work on older CPUs.

 

So, I would technically classify this as a regression, but on the other hand, we never explicitly set out to support only CPUs with a certain instruction subset :)

Share this post


Link to post
Share on other sites

That is very good to hear. I thought it might be a compiler flag or something like that that someone didn't change or set.

I do have modern computers. But, I run my uTorrent servers on my old PIII computers. They were expensive high end powerhouses at one time. :) And, for a "micro" client like uTorrent that just does Bit Torrent, they still are great to use just to run uTorrent. I suppose I could replace them, but why? I have no CPU bottlenecking or other issues at all on them with uTorrent; they just work, and work great. I suspect a lot of people have older computers they keep around for non CPU intensive kinds of tasks like this.

Imagine that. Someone still uses a PIII for something. ;)
 

At least I'm not trying to run it on an Amiga. :)

Share this post


Link to post
Share on other sites

Here's what happened: when we switched from compiling uTorrent with Visual Studio 2008 to using VS 2012, the default instruction set emitted changed from SSE to SSE2.

 

However, we didn't notice this until very recently, because relatively few people run windows with those SSE only CPUs. As more people started getting 3.4, we began getting reports that it would not work on older CPUs.

 

So, I would technically classify this as a regression, but on the other hand, we never explicitly set out to support only CPUs with a certain instruction subset :)

 

I see.

 

I wonder how many poeple are running processors without at least SSE2, can't be that many proportionatly surely ?

 

We're talking about SSE2 from the days of intel's Pentium4 back in 2001..... 13 years ago o.O

 

I'd love to know what performance benefits a fully SSE2+ (preferably SSE4+ as even that is 8 years old !) optimised version of uTorrent would yield compared to plain SSE, because having a few users on ancient hardware isn't really a good reason to handicap uTorrent to such a low bar. People on older hardware can be left to run older software.

 

Why should the vast majority be denied modern software simply because i tiny minority can't run it ?

Share this post


Link to post
Share on other sites

Why should the vast majority be denied modern software simply because i tiny minority can't run it ?

 

uTorrent runs on my PIII systems and uses virtually no CPU. There is simply no "hit" any modern computer is taking by running uTorrent without SSE2+ features.

 

Why should the entire network be denied every possible client simply because a tiny minority wants to have a client that can only run on late model systems?

 

Anyway, can't the program be compiled in a way so that it can use SSE2 and above features on systems that support it, and still work on systems without it?

Share this post


Link to post
Share on other sites

Probably too much work, in too many places. Easier to generate too versions, but this simple GUI does not really need SSE2...

Share this post


Link to post
Share on other sites

4c Cannot stop a seeding "red" torrent, "connecting", "queued", "checking..." etc...

 

(my problem is if i try to stopped more then 2 torrents, it will still say "queued")

 

any fix? 

Share this post


Link to post
Share on other sites

Build: 3.4.1 30606

Operating System: Windows 7 SP1, 64-bit

Download location & disk/filesystem characteristics: Internal 2.5" 1TB HDD (specs and transfer rates), SATA, NTFS, OS Drive

Internet connection speed D/U: 25/1 Mbit/s

 

Experiencing "Disk Cache Overloaded 100%". The download practically stops and "Disk Cache Overloaded 100%" is shown in status bar. Cache usage 128/128 MB. Corked jobs count rapidly increasing. ~1 Minute later: download resumes and corked jobs count stops increasing.

 

Screenshot does *not* show error message, but does show the dip in transfer speed.

 

xXkGVvhm.png

Share this post


Link to post
Share on other sites

Possibly a hard drive failure/disconnect?

Internal hard drive, I've never had any hardware issues with it.

 

Is this message the same as the infamous "Disk overloaded 100%"? The computer was also idle at the time, so if the disk really was being hammered, it must've been some OS background service.

Share this post


Link to post
Share on other sites

Version 3.4.1 Beta build 30662 is now available for download...

 

SSE Build (>= Pentium III, Athlon XP)

If you have an old CPU please try this 3.4.1 (30662) build and let us know how it goes for you. When replying please make sure to include the build number and what CPU you are running it on.

Changelog:

- Change: (revised) Support SSE processors and up.

- Fix: Better handling for unicode strings in the WebUI

 

3.4.1 (30662)

Share this post


Link to post
Share on other sites

Build 30606: Bug with magnet links and "Enable DHT for new torrents" unchecked. Reproducible.

 

1) Initial settings before loading magnet link. "Enable DHT for new torrents"  is unchecked. Status bar shows "DHT: ### nodes". DHT is working.

MDBHrQnm.png

 

2) Load magnet link. This message shows up. Click yes.

oPtKE4Qm.png

 

3) Now the status bar shows "DHT: Disabled" and the settings show "Enable DHT for new torrents" as checked (I did not check it manually). DHT does not work. Magnet link never loads. Loading a second magnet link doesn't lead to an error message, and also fails to load.

ykpAsq8m.png

 

4) Clicking "OK" in the settings window restores DHT: the two magnet links start working and the status bar shows DHT: ### nodes (login). Clicking "X" or "Cancel" in the settings window does not restore DHT.

 

Retried on 3.4.1 build 30657: crash.

nPQNFvTm.png

Retried on 3.4 build 30660: behavior identical to 3.4.1 build 30606

Share this post


Link to post
Share on other sites

3.4.1 build 30606

3.4.1 build 30657

3.4 build 30660

 

When scraping two tracker URL that resolve to the same IP.

 

[2014-03-14 16:46:11]  udp://tracker.prq.to/announce: scrape response had 6 torrents, request had 1
[2014-03-14 16:46:11]  udp://viv.tv.tracker.prq.to:80/announce: scrape response had 1 torrents, request had 6
 

Share this post


Link to post
Share on other sites

4c Cannot stop a seeding "red" torrent, "connecting", "queued", "checking..." etc...

 

(my problem is if i try to stopped more then 2 torrents, it will still say "queued")

 

any fix? 

Not that I am aware of, the bug happens in 4.3 stable as well. It's also not just when seeding, I can confirm it happens with ANY "red" torrent on both latest stable & beta. An admin in another section basically tried to tell me it wasn't a bug but I certainly don't buy that.

Share this post


Link to post
Share on other sites

Thanks for confirming #4c on my "known issues" list... But, in this case it really doesn't take a rocket scientist-dev to reproduce this, so I guess there are some more important issues for the devs to deal with....

Share this post


Link to post
Share on other sites

Thanks for confirming #4c on my "known issues" list... But, in this case it really doesn't take a rocket scientist-dev to reproduce this, so I guess there are some more important issues for the devs to deal with....

Ya think?  :P  To better judge how efficiently they're dealing with longstanding "known issues" how about providing an alternate ascending chronological list based on longevity & persistence?  I vote #1 is #28 (Mouse hovering display above columns' partial texts is broken) dating back 3+ years, since 3.0 beta.  You have it as low priority but it’s symptomatic of stagnation and inattention to detail.  If that's too much trouble with a low cost / benefit potential, how about highlighting the top 10 (by age) in contrasting color (i.e. green = fixed, red = high seniority).  Depending on priority position everyone can better judge the extent of actual progress made (or not).  Presented in proper context humiliation can act to propel improvement more effectively than perpetual apology.

Share this post


Link to post
Share on other sites

Yeah, me think :P And just for you, I've colored the priority titles... I guess you haven't noticed that the list is categorized by priorities...

Oh, and your vote has been noted...

Share this post


Link to post
Share on other sites

And you all *wonder* why so many of us still stick with v2.2.1?

 

And you *wonder* why we complain about the total lack of dev management?

 

 

When (rafi's) 4a & 4c are confirmed as fixed, I'll give it another go, but not until then.

Share this post


Link to post
Share on other sites

Version 3.4.1 Beta build 30662 is now available for download...

 

SSE Build (>= Pentium III, Athlon XP)

If you have an old CPU please try this 3.4.1 (30662) build and let us know how it goes for you. When replying please make sure to include the build number and what CPU you are running it on.

Changelog:

- Change: (revised) Support SSE processors and up.

- Fix: Better handling for unicode strings in the WebUI

 

3.4.1 (30662)

@beasly 

For normal CPU, what version you recommend?

I'm curious, now on Normal CPU i5  with 3.41.30662

set to max ul 5, max dl 0, port 6881 sometime random

plz tell me there is  wrong in setting Thanks.

Screenshot:

http://gyazo.com/125973ecd543be296bfafdb2436e36ac

Share this post


Link to post
Share on other sites
For normal CPU, what version you recommend?

It doesn't matter. And if you set your upload to 5 - why should we even care, leach?...

Share this post


Link to post
Share on other sites

4a Users are *loosing all their settings when upgrading/installing from an older "standalone"  non-%appdata%\utorrent location.

 

When (rafi's) 4a & 4c are confirmed as fixed, I'll give it another go, but not until then.

"4a Users are *loosing all their settings when upgrading/installing from an older "standalone"  non-%appdata%\utorrent location."

You don't need to worry about that one, just replace your exe manually, or use tip #R of mine...

Share this post


Link to post
Share on other sites