Archived

This topic is now archived and is closed to further replies.

AdamK

3.4.x Beta

Recommended Posts

48 minutes ago, freedomdwarf said:

Where is that option Rafi??

I don't see anything like that on my uT options.

 

Right-click on torrent->context-menu->advanced

Share this post


Link to post
Share on other sites

Right click on torrent - Advanced -  Set Download Location...

It works but I would like to move multiple torrent without select the destination for every torrent

Share this post


Link to post
Share on other sites

So use the global move in the pref->directory settings. This is what they have...

Share this post


Link to post
Share on other sites
28 minutes ago, castlemania said:

@rafi I download it but the video player doesn't play. It's black and doesn't play.... I moved the locations to downloads, desktop, and video. Still isn't playing the movies

Right, for me too... Well, we have to have some bugs, for the sake of the devs' job security... ;)

Share this post


Link to post
Share on other sites
On 6/23/2016 at 4:13 AM, rafi said:

So use the global move in the pref->directory settings. This is what they have...

Can't move the entire thing, it only moves the location uTorrent expects the files to be. so that requires me to move the files first.

I'd also really love to set locations so I could simply -> Move torrent -> custom location 1 or -> Move torrent -> custom location 2 etc.
I don't want to move all torrents when they're completed just some. Qbittorrent has the ability to straight up move a torrent, once they get their UI looking like some thing half modern that feature will probably make me jump ship.

Having a move rule (when finished etc) per label would be pretty awesome and serve the same purpose.

Can't imagine we'll see much effort put into the client, devs seem to have it in maintenance mode, but hey at least they've finally got version numbers and development sorted..

Share this post


Link to post
Share on other sites
4 hours ago, Ryrynz said:

Having a move rule (when finished etc) per label would be pretty awesome and serve the same purpose.

There is something, Labels->mapping but I've never could figure how to make  it work...

 

Share this post


Link to post
Share on other sites
2 hours ago, rafi said:

If this "- Bugfixes" will go on, we can declare release notes as useless :(

Yeah that's lazy AF, especially when it's just a new build. That's the sort of change log I'd expect from an Android app.

Can't you just feel this client starting to fizz out?

I say starting but it's been some years really.

Share this post


Link to post
Share on other sites
20 hours ago, mike20021969 said:

The big question is - are you still using uTorrent?

Yeah it's stable, looks nice and works well enough but at the current pace of development other options will be far more attractive.

It'll go the same way as Winamp, there's only so far a name can take you.

Share this post


Link to post
Share on other sites

Bug: If I've started downloading a file within a torrent and set it to skip mid download uTorrent continues to download it to completion. This happens with 3.4.5 also.

Also I've encountered another bug seen below quite a few times.. really annoying..

File says it's 100% completed. If I stop the torrent, force a recheck and download it says it completes 100% but it hasn't, if I recheck again it comes up exactly as before.

If I delete the part file and recheck again it still doesn't complete. Strangely after doing so uTorrent listed it downloaded partially the other files which were listed as skip. Rechecking it once again and a lot of these downloaded parts went back to 0% save a couple.. why is uTorrent downloading parts of files when it's told not to? Also why is it's estimation of what it's downloaded reported wrong? Hopefully the dev/s can get this fixed for 3.4.8 final, it's been around for a while this one.

HYeR8F8.jpg
OC9I7jc.jpg

I1TidCg.jpg

After deleting both the file and the part, it started again then to tell me my disk is invalid. =/

Did another check and it started fine. Which lead to this.. which is obviously related and have encountered a few times before as well and am glad I've finally caught. Surely some of you guys would've seen this one before as well.

No completion time or date and 105% completed. Still downloading bits of the other files.. if this is just part of the process of downloading via torrent then can the devs just scrap the data rather than saving it?

Also even though it says the file is completed, it's still has .ut appended to the file name until I stop the torrent, I did another recheck and it says 100%. The filename is now correct with a completed date set.

jfSYR1d.png

 

Share this post


Link to post
Share on other sites

I have seen these symptom too (10X%, .ut "management" issues, etc) . I think that the support for multifiles torrent is now buggy (maybe since they've added that network thread). Since not much energy seems to be allocated to fix the issues, what I did is adjust myself... no !ut, no "pre-allocate", minimal changes to internal files (skip) during download. With this, when everything is per-set before you download (or maybe after completion, but not during downloads) - the client  seems to behave well... ;P

 

 

 

 

Share this post


Link to post
Share on other sites
On 7.7.2016 at 4:36 AM, Ryrynz said:

What's been fixed?

Not the typo in the changelogs - this is new ;)

Share this post


Link to post
Share on other sites
On 7/7/2016 at 4:35 PM, rafi said:

Nothing?... ;p

Well there's something, good luck guessing what that is.

Bout time for 3.4.8 to be released now? It's almost been two months.
One would hope there's some significant changes in 3.5 but as I said earlier, I expect this client to be in full on maintenance mode.
Please prove me wrong.

Share this post


Link to post
Share on other sites
25 minutes ago, Ryrynz said:

One would hope there's some significant changes in 3.5 but as I said earlier, I expect this client to be in full on maintenance mode.
Please prove me wrong.

There are plenty place for versions till 3.5 - 3.4.9,  3.4.10, 3.4.11 ... and so on...

 

Share this post


Link to post
Share on other sites

Tech Question:

why does uT create files in its DL directory with the P attrib set?  Is it saving some special meta data in the file's dir?

it does not seems to be a true junction or reparse point, so it can only be for "user data".  There is no utorrent file filter installed.  What's up here?

searching google shows up indications that it's embedded within libtorrent.lib.  But what's it used for?

copying the file to a new dir leaves the P behind.

Could this have something to do with why recent builds get the "Access Error" when other apps (media player) have one of the files open (still present in 3.4.8.42400 BTW).

=========

This is the first/only time I have ever seen a P attrib on a file that was not a true repase (junction) point. 

Share this post


Link to post
Share on other sites

Ah, I was mislead!!!  a P attrib is for a SPARSE file, L attrib is for REPARSE.  Shows you can't always trust what google finds!  MSDN discusses spares files, makes sense.

But, could this be involved in the ACCESS DENIED error in some way?

thanks....

 

Share this post


Link to post
Share on other sites