Archived

This topic is now archived and is closed to further replies.

cmeisel

3.4.x stable

Recommended Posts

-- 2015-02-06: Version 3.4.2 (build 38656) Stable
- add bundle's icon to the searchbox search by bundles
- Fix incorrect data in the Relevance column for a selected torrent
- Fix relevance column in peers tab
- Fix long shutdown times when parsing certain media types
- Fix gap in download list name column
- Tweak default column widths


 

Share this post


Link to post
Share on other sites

No work because the proposal to pass to pro it's not possibly to hidden......

Should be OK. Screenshot? Build #?

Share this post


Link to post
Share on other sites

It is impossible here as well (on version 3.4.2 build 38656) to hide "Upgrade to Pro", "gui.show_plus_upsell_nodes" in Shift+F2+Avanced keeps resetting to true each time I restart µtorrent.  Like I set "gui.show_plus_upsell_nodes" on false and "Upgrade to Pro" disappears but I restart µtorrent and "Upgrade to Pro" re-appears and "gui.show_plus_upsell_nodes" is back on true. :rolleyes:

Share this post


Link to post
Share on other sites

Should be OK. Screenshot? Build #?

 

Ok... but i thinks i can update my build but this is the proposal it's impossible to hide:

QU7xaXt.png

 

The exact "problems" explain from @peeer upper here..........

Share this post


Link to post
Share on other sites

It is a new "feature", that I guess we have to live with, and it is not that terrible... There are a few icons/links in the status line too you know...

If you want to try and block all communications to BT servers as was explained in the forum in the past, it might do the trick, or might not...

Share this post


Link to post
Share on other sites

Hmm... Having release notes only one day after the release is out - definitely an improvement...

Share this post


Link to post
Share on other sites

Looks like somewhere in between stable build 36044 and 36318 the fat LREC/sidebar issue has returned - and it has been so ever since at least build 36318 up to the current stable of 38758

Note the screenshot and how the bottom one [latest] is wider. In both screenshots, the LREC is sized to the narrowest uTorrent allows:

 

I have no faith this will get fixed (again) or even more of a pipe dream: allow us to size it as narrow as we want - even to 1px wide if we so choose - why impose a minimum pixel width programmatically for the LREC if the ad is disabled? I can understand imposing one if ad is enabled - but not if its disabled. It'd take editing one line of code in C++ to allow users to resize it as narrow as they want. 

 

Just to clarify: I am NOT talking about the space between the text items [height] I am talking the width of the LREC sidebar <--> vs <---->

 

I'll try hunting down every single beta version between 36044 and 36318 to pin down exactly which build reintroduced this behavior. 

 

 

1RSdVNO.png

Share this post


Link to post
Share on other sites

Looks like somewhere in between stable build 36044 and 36318 the fat LREC/sidebar issue has returned - and it has been so ever since at least build 36318 up to the current stable of 38758

Note the screenshot and how the bottom one [latest] is wider. In both screenshots, the LREC is sized to the narrowest uTorrent allows:

I think the min width is set to more or less the "downloading (xx)" node-line width.

http://forum.utorrent.com/topic/88339-34x-beta/?p=500889

 

Plus, I think there is still this un-removable  "upgrade to pro" line they now probably want people to see... ;)

Share this post


Link to post
Share on other sites

I think the min width is set to more or less the "downloading (xx)" node-line width.

http://forum.utorrent.com/topic/88339-34x-beta/?p=500889

 

Plus, I think there is still this un-removable  "upgrade to pro" line they now probably want people to see... ;)

Unfortunately Pro has the fat column too :/ Oh well I'll go back to the older build with the thinner one. 

 

s1Gur6M.png

Share this post


Link to post
Share on other sites

I installed build 38656 a few days ago and am glad to report that the UI issues that were plaguing utorrent for months are finally fixed.

Now, when queued torrents are stopped, the UI immediately updates and shows them as stopped.

The left side bar also updates properly now, for example, when a torrent finishes seeding, the number immediately drops.

The only remaining UI issue I can see, is that the active tab header sometimes jumps to "Files", when I close utorrent's main window and then re-open it. It's just the tab header though. The content of the tab doesn't switch to files, so it's a minor issue, although annoying.

I'm yet to try build 38758.

Share this post


Link to post
Share on other sites

Now, when queued torrents are stopped, the UI immediately updates and shows them as stopped.

The only remaining UI issue I can see, is that the active tab header sometimes jumps to "Files", when I close utorrent's main window and then re-open it. It's just the tab header though. The content of the tab doesn't switch to files, so it's a minor issue, although annoying.

I'm yet to try build 38758.

Hm... good to know about stopping that now works as is should.

Did you check also with problematic torrents, like w/o peer "connecting" or w/o trackers "red" status?

Btw, I've not seen the issue with the tab here (39758)

Share this post


Link to post
Share on other sites

Hi guys, I got the pro version in the hope to remove ads and it is fine now. But I really dont want the antivirus neither the playback feature. How can I disable this ? I have also removed the player folder and the antivirus folder but everything time i start utorrent it download them again. I don't want utorrent to download these features. How can I disable them permanently ? I also see .btinstall files but no way to uninstall properly. Any helps ?

Share this post


Link to post
Share on other sites

Did you check also with problematic torrents, like w/o peer "connecting" or w/o trackers "red" status?

I'm not sure I know about those. Can you post some forum links?

 

Btw, I've not seen the issue with the tab here (39758)

I hope by that you don't mean "If I'm not seeing it, then it's not true." :D

 

Here is a screenshot:

 

Y5UQLD1h.png

 

This usually happens after I leave utorrent running in the taskbar and then open its window by clicking on the taskbar icon.

 

As you can see, the tab says "files", yet it shows the speed, because I left it on speed when I closed it.

 

It's been like this for many builds. Haven't tried build 39758 yet.

 

It's a minor issue though and doesn't really bother me that much.

Share this post


Link to post
Share on other sites

Hi guys, I got the pro version in the hope to remove ads and it is fine now. But I really dont want the antivirus neither the playback feature. How can I disable this ? I have also removed the player folder and the antivirus folder but everything time i start utorrent it download them again. I don't want utorrent to download these features. How can I disable them permanently ? I also see .btinstall files but no way to uninstall properly. Any helps ?

 

Not sure if there's actually an option to do that from the Settings, never bothered to look in such poor quality software.

But what you could do is in place of the directories you're trying to delete you can create empty files with their names (no extensions, of course) and make them read only. Same for any other files you don't want to be downloaded/modified. See if it helps.

 

Share this post


Link to post
Share on other sites

In the latest stable 38758 - the new disk cache scheme cause every download job to fill up the cache and "stall" for a couple of minutes before the download continues.

7e8817390171858.jpg

Anybody else sees this?

Share this post


Link to post
Share on other sites

Not sure if there's actually an option to do that from the Settings, never bothered to look in such poor quality software.

But what you could do is in place of the directories you're trying to delete you can create empty files with their names (no extensions, of course) and make them read only. Same for any other files you don't want to be downloaded/modified. See if it helps.

 

It didn't work as expected. with this solution I got an error at every startup saying couldn't download pro files...

Share this post


Link to post
Share on other sites

re: last post, I was wrong;  even 38397 seems to be turning off the R bit on restart; I thought that issue had been fixed, I havn't noticed it in a very long time, now it has returned.  Could something in settings.dat be affecting it, rather than software version?  Hum...

 

nevermind....  ;-)

Share this post


Link to post
Share on other sites