Jump to content

Can't find .torrent files -- but they *are* there


RedPill

Recommended Posts

I upgraded to build 30596 yesterday. After upgrading, however, nearly all of my torrents are now reporting "Error: Can't open .torrent file at ______". I've triple-checked both my settings (.torrent folder still properly set) and the physical folder (.torrent folder still accessible in exact same location/drive/name) and restarted uTorrent multiple times, to no avail.

I opened Process Monitor to see what's happening when uT tries to access the .torrent files --

 

It appears uT is correctly finding the .torrent files in their actual location, however, uT then tries to create/access every one of the torrent's files in C:\Windows\SysWOW64, instead of going to the actual location on disk where the torrent's files are stored (i.e., uT tries to "CreateFile" in "C:\Windows\SysWOW64\[name-of-torrent-file.rar]". This results in "NAME NOT FOUND" result, and then uT tries again with the next file, with the same result.

 

Even more confusing -- with some torrents, uT still checks C:\Windows\SysWOW64\ first (and can't find anything), but then uT checks the actual location on disk where the torrent's files were saved, resulting in a "SUCCESS". I have no idea why it's able to do this with some torrents but not others.

 

In uT, there seems to be a pretty clear correlation between "broken" torrents and torrent-age -- every torrent from the past three months is broken with "Can't open .torrent file...". The earliest torrent in my uT history that isn't broken was added/completed on October 30, 2013 (verified by looking at its .torrent file and downloaded files). The following torrent, however -- added/created/completed on October 31, 2013 -- is "broken", and every single torrent after that up until now.

 

I wonder if this has to do with some uT version incompatibility, like if there was a uT update that happened on October 30/31.

Link to comment
Share on other sites

This is unbelievable. I've been working on this all day, to no avail. There's a new problem and set of headaches every time there's a uTorrent update.

 

No wonder people stick with old versions forever -- every time there's an update, people's history gets wiped, locations get juggled around, torrents get broken, and/or a whole slew of madness with %AppData%.

 

"Stable" releases should get renamed to "Beta", and "Beta" releases should get renamed to "Extra-Beta".

Link to comment
Share on other sites

  • 2 weeks later...

I have a similar error "Can't open .torrent file" and it happened when I moved all my collected .torrent files to a new folder and then updated in the settings.

 

The files show in the folder but the status is in error.

 

copy the original filename.torrent back to the actual error path and its all good.

 

let us know how you go as it's pissing me off.

Link to comment
Share on other sites

Preferences aren't retroactive to already loaded torrents.

 

If you've moved the files back force a re-check on the problem tasks.

Thanks DreadWingKnight for the info,

now as I cannot remember where the folder was where can I start to look at with a HEX Editor to help trace my missing folder location?

Link to comment
Share on other sites

  • 1 month later...

Just wanted to chime in and say im having the same exact issue after updating to newest version.

 

Windows 7 64bit. UT30740. 

 

I have UT set to move .torrent files to a different folder than the default. When this happened I did the force recheck option and it went back to downloading right away. I didnt do anything to make it work other than this.

Link to comment
Share on other sites

I would like to point out that this is not necessarily specific to a version of utorrent or to updating.

 

I am using v 2.2.1 as people tell me that this is still the best version & not to bother upgrading. I have not really had any problems with it.

 

But now, I am also having the previously mentioned problem.

 

The message Error: Can't open .torrent file: C:\Users\location\location\location etc has occurred  on over 100 permanent seeding torrents, & is a huge problem.

 

I have tried rechecking, nothing happens at all, not even an attempted recheck.

 

Downloading the .torrent file to the same location does nothing, the files are already there.

 

Replacing the .torrent file it says it can't find with a new one in the correct location does nothing.

 

Trying to restart the torrent or recheck it after replacing the old .torrent file with a new one in the original location does nothing.

 

This is extremely frustrating & I would really like a solution from the admins if possible, thank you.

Link to comment
Share on other sites

Thanks for the prompt response to the only part of my post not related to the technical error I am trying to fix.

 

As there are many people online reporting having the same problem in different & current versions of utorrent, do you have any technical advice as to how to get utorrent to find the torrents that had previously been working fine for several years?

 

I don't see any reason why the fix for this problem in the latest version should not be applicable for v 2.2.1.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...