Jump to content

Utorrent stuck at Connecting to Peers


Recommended Posts

Utorrent was working a few days ago then all of a sudden it wouldn't get passed connecting to peers. I'm using version 3.3.2, tried 3.4 but still wouldn't work so went back to 3.3.2.



[DHT] - waiting to announce (on the bottom bar, it says DHT: Waiting to log in)

[Local Peer Discovery] - working

[Peer Exchange] - working

all others are connection timed out


The icon in the bottom left corner is yellow and when I double-click it and run the test I get: Connection failed error: A request to send or receive data was disallowed because the socket is not connected and (when sending a datagram socket using a sendto call) no address was (last word won't show, guessing it's supplied). My internet is working since I'm able to go to websites and such just utorrent is not working.


Don't know if it's anything I did. When this first happened, my avast antivirus came up with a Url: Mal and gave me this website for favicon.ico. everytime I tried running any torrents so then I restarted my computer and the same thing would happen but the torrents would still work. I scanned my computer and I found no viruses or rootkits. So once the torrents stopped working. I uninstalled both utorrent and avast and then reinstalled both and utorrent got stuck but avast wouldn't detect anything. Windows firewall is allowing it. I tried a system restore which let it work for a while, next day stopped and hasn't worked since. I'm working on windows 8.1 by the way.


I don't think anything has changed from when it was working to when it got stuck. I don't remember installing anything.


Is anyone else having the same problems?

Please help!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...