Jump to content

I need help with my bad DL speed.


Recommended Posts

My download speed was upto 210 kb/s max but nowadays i'm getting a very slow download speeds, 75 kb/s max.


This is the basic spec. of my laptop:


Asus Asus Laptop

pentium Dual-Core Cpu T4300 @2.10GHz 2.10Ghz

Ram: 2GB

System Type: 32-bit Operating system

Os: Windows 7 Ultimate



i don't know the hijackthis but i got this Process Explorer from www.sysinternals.com,



My speedtest.net result:




My uTorrent download speed:





I've read this thread http://forum.utorrent.com/topic/13691-if-you-have-speed-issues-read-here-first/ and followed the instructions but nothing changed. please tell me what to do. I would really appreciate your help. Thanks!


Link to comment
Share on other sites

  • Try lowering net.max_halfopen to 4 or lower (Can be found in Preferences > Advanced) = 4

  • Try lowering bt.connect_speed to 4 or lower (Can be found in Preferences > Advanced) = 4

Try disabling IP resolving in the Peers tab's context menu = disabled

Try disabling DHT (Can be found in Preferences > BitTorrent) = disabled

Try disabling UPnP and NAT-PMP (Can be found in Preferences > Connection) = disabled

Try disabling peer.resolve_country if it isn't already set to false (Can be found in Preferences > Advanced) = disabled

Try lowering maximum global number of connections to 200? 100? 50? Lower? (Can be found in Preferences > Bandwidth) = 50

Try disabling uTP? (Set Preferences > Advanced > bt.transp_disposition to 5) = disabled

Connect your computer directly to the modem to make sure the problem is not caused by the router = Already tried (nothing changed)

Restart µTorrent, your computer, modem, and/or router after performing any of the suggestions below = Already tried (nothing changed)

Make sure you have a green network status light in the µTorrent status bar and/or the port checker in the Speed Guide (Ctrl+G) shows the port to be open


I don't get this part so i show you screenshot.

  • Try testing a torrent from OpenOffice.orgSlackware Linux, or Ubuntu Linux? (If any of them run quickly, then the problems you're experiencing likely lie only with the swarm) = Haven't tried yet. I don't get this.

  • Try enabling Protocol Encryption? (Can be found in Preferences > BitTorrent) = There's no Protocol Encryption there.

Try disabling bt.tcp_rate_control? (Can be found in Preferences > Advanced) = disabled

Try various uTP settings? (Set Preferences > Advanced > bt.transp_disposition to 31 to enable, 26 to force, 21 to disable) = 31

Make sure peer.lazy_bitfield is enabled? (Can be found in Preferences > Advanced) = enabled

Test your connection with Glasnost to make sure your ISP isn't throttling BitTorrent (and check this thread for a compiled list of ISPs known to throttle) = I don't know how.

For additional information:


I'm using a DSL provided by PLDT in our country Philippines. I turned off my firewall and i'm not using any anti-virus program but i have Malwarebytes anti-malware.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...