Jump to content

Unable to Connect to Peers


Recommended Posts

I am currently having issues with my torrents starting. I currently have three known good torrents (I had someone else download the exact same three to check) all of which are not downloading. All three say in the status collum "Connecting to peers 0.0%" and have no listed peers or seeds. Only some torrents are doing this however as the Slackware torrent losted in the Setup Guide downloaded just fine. I know its not the torrents themselves however because others can download them without issue.

I have restarted uTorrent as well as my computer and my router.



OS - Windows 7

ISP - Comcast

Router - Arris TG862

Version - 3.4 Build 30660

No proxies or other programs known to have issues with uTorrent and I have already tried disabling my Virus Scanner (AVG) and disabling Windows Firewall.


Trackers for the torrents read as -

DHT - waiting for announce...

Local Peer Discovery - working

Peer Exchange - working

udp://tracker.public.com:80 - Connction timed out.


I have tried to use the Built in Setup Guide and about 1 in 5 times it goes perfect and says that there are no issues and that the torrents should work just fine and the rest of the time it gives one or two errors shown in the attacked imgs.


Protocol Encryption is enabled and legacy connections are accepted.

uTorrent has been added to my firewall and I have checked it in Windows.

UPnP and NAT-PMP port mapping are both enabled.



Any help would be greatly appreciated.

Thank you in advance.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...