Archived

This topic is now archived and is closed to further replies.

brang

very slow downloads

Recommended Posts

 

I have no clue if this will help, but I was having similar speed problems and i did the following:

 

Preferences --> Bandwidth --> "Disable the "Apply rate limit to uTP connections" option ( under the Global Rate Limit Options subheading).

 

This fixed my issues (went from ~5-20kb/s to 200-500kb/s +). Hope it helps! 

 

 

Absolutely perfect. I was stuck with 10kb/s downloads for half a month. Now it's gone back up to the usual 1-2Mb/s... just made this account to say thanks a lot!

 

*Edit - it actually doubled to almost 4Mb/s. You, sir, are a genius.

Share this post


Link to post
Share on other sites

You all have some other bad settings. Most likely - the "Apply rate limit to transport overhead" -  enabled and/or a low upload speed limit. Just use my settings ... (@sig).

 

Here, have a look see:

c45867332142161.jpg

Share this post


Link to post
Share on other sites

Disabling apply rate to utp does fix the slow download speed issue but causes another issue. Utorrent now ignores my bandwidth limit settings so hogs all my bandwidth. This means I cannot really use the internet while utorrent is running. Had this issue with the last few updates.

 

Gone back to utorrent 2.2.1. Wow this version reminds me why I liked utorrent in the first place. Everything works as it should. No ads (I know they can be removed in settings), no trying to install crapware during the install process. Very light on system resources. UI was a little ugly back then though.

Share this post


Link to post
Share on other sites

I still say - you have some  bad setting.. uTP can and should be limited, w/o effecting the DL speed. Read my tips, use my settings. We MUST HAVE the latest and greatest GUI possible!!! ;)

Share this post


Link to post
Share on other sites

Me thinks users tend to make adjustments with the basic settings according to their indivdual situations BUT they rarely make the adjustments in the Advanced settings (explainations in help file), which in some cases can be beneficial to some.
 
Advanced Settings Explained

Share this post


Link to post
Share on other sites

I am using the exact same settings with the old version that I used with the new version so something has changed with one of the updates. Why the same settings work differently on different versions baffles me.

 

The old version works great with default settings. I just change download folder and some ui stuff.

 

The fact that these changes don't affect everyone does suggest that the problem is at my end.

 

Will keep trying the new versions when updates are released.

Share this post


Link to post
Share on other sites

Hi,

 

I have 3.0Mbps download and 0.5Mbps upload on speedtest. when i tried to download a torrent it shows that my transfer rate is 11~11.2kBps down and 6~7kBps up it takes forever to download a single torrent.. Im using torrent 3.4.2. 

Share this post


Link to post
Share on other sites

 

I have no clue if this will help, but I was having similar speed problems and i did the following:

 

Preferences --> Bandwidth --> "Disable the "Apply rate limit to uTP connections" option ( under the Global Rate Limit Options subheading).

 

This fixed my issues (went from ~5-20kb/s to 200-500kb/s +). Hope it helps! 

 

 

 

didnt work on this settings, still the same on transfer rate.

Share this post


Link to post
Share on other sites

My download speed has been dragging around 120kb and it shows my limit as 4 mb. I used the 

 

Preferences --> Bandwidth --> "Disable the "Apply rate limit to uTP connections" option ( under the Global Rate Limit Options subheading).

 

and it jumped nack up to 3 mb but for only one download and now its dragging again i checked to make sure the setting was still checked off and it was but now I dont know what to do next. Any ideas?

Share this post


Link to post
Share on other sites

My download speed has been dragging around 120kb and it shows my limit as 4 mb. I used the 

 

Preferences --> Bandwidth --> "Disable the "Apply rate limit to uTP connections" option ( under the Global Rate Limit Options subheading).

 

and it jumped nack up to 3 mb

Meaning - your limit is set to a wrong value :P

Share this post


Link to post
Share on other sites

 

I have no clue if this will help, but I was having similar speed problems and i did the following:

 

Preferences --> Bandwidth --> "Disable the "Apply rate limit to uTP connections" option ( under the Global Rate Limit Options subheading).

 

This fixed my issues (went from ~5-20kb/s to 200-500kb/s +). Hope it helps! 

 

Thanks man, this really works for me too.

Share this post


Link to post
Share on other sites

 

I have no clue if this will help, but I was having similar speed problems and i did the following:

 

Preferences --> Bandwidth --> "Disable the "Apply rate limit to uTP connections" option ( under the Global Rate Limit Options subheading).

 

This fixed my issues (went from ~5-20kb/s to 200-500kb/s +). Hope it helps! 

 

WOW, I made an account just to comment on this. This is THE ONLY thing that worked. I went from 2-56kbs to 2-7.4MBs. I don't know why the heck this box is ticked whenever you install uTorrent, but they need to quit it. lol. Thank you SO MUCH for letting us know what worked for you.

Share this post


Link to post
Share on other sites

WOW, I made an account just to comment on this. This is THE ONLY thing that worked. I went from 2-56kbs to 2-7.4MBs. I don't know why the heck this box is ticked whenever you install uTorrent, but they need to quit it. lol. Thank you SO MUCH for letting us know what worked for you.

And what was your *rate limit* set to?

Share this post


Link to post
Share on other sites

 

I have no clue if this will help, but I was having similar speed problems and i did the following:

 

Preferences --> Bandwidth --> "Disable the "Apply rate limit to uTP connections" option ( under the Global Rate Limit Options subheading).

 

This fixed my issues (went from ~5-20kb/s to 200-500kb/s +). Hope it helps! 

 

Holy Primordial Being! You have stumbled upon Gold!

Bro Thank You! My speed just went from a couple of bps to couple of hundreds! Just like it was earlier! Thank you!

Share this post


Link to post
Share on other sites

And what was your *rate limit* set to?

Just curious, are you guys booting your PC from *SLEEP*? Happened to me once after I've turned if off to "sleep" when uT was running...

Share this post


Link to post
Share on other sites

Hello there? I have the same problem as most of you. Before I edit my settings of mu utorrent, it is working fine enough from 100kbs/s-300kb/s. Which is way better than now, i only have 27kb/s maximum. I tried all the tips and settings given on the topic but still nothing works. I also tried re installing.( I have now 3.4.2 the latest ver.) and still nothing happened. I also tried using vuse. but the same result, so i switched back to utorrent. It sucks that i need to wait for 13hrs to finish a 800mb movie. Is there my be a problem on the setting of my computer? is there any connection there? please help. and by the way, my net speed is only 1mbps in the morning and it goes up atleast to 2.5 in the evening. Please help guys, I'm out of options here :mellow:  

Share this post


Link to post
Share on other sites

 

I have no clue if this will help, but I was having similar speed problems and i did the following:

 

Preferences --> Bandwidth --> "Disable the "Apply rate limit to uTP connections" option ( under the Global Rate Limit Options subheading).

 

This fixed my issues (went from ~5-20kb/s to 200-500kb/s +). Hope it helps! 

 

Thanks a lot

Share this post


Link to post
Share on other sites

I made an account to thank all those who gave valuable information in this thread. Good work guys!

 

With that said, none of it worked for me permanently. At best I had my speeds back to normal for a few minutes. Glasnost says my ISP does not throttle, and I'm inclined to believe them because another torrent program is working just fine.

 

The vast minority of users of almost any program will visit that program's forums to troubleshoot. If they have trouble and they can't fix it they will move on. I have been a dedicated user of uTorrent for years, but the headache of figuring this out is not worth the loyalty to me. I bring this up just to make this point: Just because fixes do exist out there doesn't mean the average user should be expected to find them. While the short term fixes found in this thread are great, I hope the fact that newer versions of uTorrent are causing issues is not being overlooked!

 

Thanks again for the hard work everyone, this wasn't meant to insult or threaten in any way I just wanted to say that relatively few users will even go looking for these fixes before they uninstall and move on so I hope work is being done at the root of the issue and I can use uTorrent again one day as easily as I have in the past.

Share this post


Link to post
Share on other sites

 

I have no clue if this will help, but I was having similar speed problems and i did the following:

 

Preferences --> Bandwidth --> "Disable the "Apply rate limit to uTP connections" option ( under the Global Rate Limit Options subheading).

 

This fixed my issues (went from ~5-20kb/s to 200-500kb/s +). Hope it helps! 

 

Thanks man! Created an account just to say thank you. 

Share this post


Link to post
Share on other sites

 

I have no clue if this will help, but I was having similar speed problems and i did the following:

 

Preferences --> Bandwidth --> "Disable the "Apply rate limit to uTP connections" option ( under the Global Rate Limit Options subheading).

 

This fixed my issues (went from ~5-20kb/s to 200-500kb/s +). Hope it helps! 

 

Thank you very much, sir~!! You are my hero for today~!!

Share this post


Link to post
Share on other sites

I bet your enabled "apply limit to overhead " is the root cause, and not this limit....

Share this post


Link to post
Share on other sites

Hey guys..... First of all I just wanted to tell you that my download spped is averge 70-40 kb..... and.......................... i had this problem and it was to complecated and stuff so i downloaded vuze so i just wanted to chek if it was ok........ and i am not best at english so........... 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.