Jump to content

uTorrent 3.4.x (stable and beta) crash


Recommended Posts



I've just upgraded to 3.4.1, and the app keeps crashing after 1-2 mins. It's crashing with an invalid memory access at ntdll.dll (I know, not very helpful).


I can always replicate this when I open uTorrent, and then add a new torrent. The app will always crash after 1-2 mins.

I've tried downloading 2 torrents, and then adding 2 new torrents. When the app crashes and I reopen it, the newly added torrents are removed, and only the two original torrents remain.


I got no problem whatsoever with version 3.3.2.


I went to check the troubleshooting FAQ topic, but all the "Helpful links" are broken


My system specs are:

* Intel i7, 12GB RAM, Windows 7 Pro English 64-bit SP1

* I'm using ESET Smart Security as my antivirus software

* My ISP is OTENet (Greece)


I've tried the following versions:

* 3.4.1 Build 30888  -----> crash

* 3.4.1 Build 30946 (Beta)  -----> crash

* 3.4 Build 30635  -----> crash

* 3.3.2 Build 30586  -----> works fine


I've tried toggling the following preferences, but the app still crashes:

* Advanced -> Disk cache -> Increase automatic cache size when cache thrashing (disabled -> enabled)

* Advanced -> disabled all btapps settings (auto_update_btapps, auto_update_btinstalls, enable_activex)

* Advanced -> diskio.coalesce_writes (enabled -> disabled)

* Advanced -> peer.disconnect_inactive (enabled -> disabled)

Advanced -> bt.use_similar_torrent_data (enabled -> disabled)

Advanced -> choker.slots_auto (enabled -> disabled)


Link to comment
Share on other sites

Thanks for your quick response :)


In Advanced, I got the following cache-related options:

diskio.cache_reduce_minutes -----> 9

diskio.cache_stripe -----> 128

diskio.coalesce_write_size -----> 2097152

diskio.max_write_queue -----> 32


Also, in Advanced->Disk cache I get 128MB in the automatic cache size. I checked on another PC, and I noticed that this is automatically set to 32MB. Not sure how that's calculated, should I try and manually set it to 32MB and see what happens?


(Edit: Note that I'm currently using version 3.3.2 build 30586, not sure if that makes any difference for these numbers)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...