Jump to content

Torrents will not download, connection test shows "Neither NAT-PMP or UPnP is enabled. Please check your preferences."


Recommended Posts

As the title above states, I'm unable to download any torrents. When I try to open one it remains stuck at "Connecting to peers." 


I tried doing a connection test, and speed testing checks out, but port forwarding does not. A large red X comes up, and under it, "Neither NAT-PMP or UPnP is enabled." 


Now before you ask if I allowed exceptions through my firewall, yes, I did. I also checked my router and made sure UPnP was enabled. 


The thing is, I've downloaded torrents just fine on the same connection before, with the same router, modem, and everything. This only started happening after I got a new computer. I've checked through dozens of


other topics with the same problem, and it seems like no one has ever been able to fix this. I have gone through my windows connection settings, and I made sure "access data sources across domains" was


enabled. I've done everything, and to no avail, I continue to receive the same error. 



Can anyone please help? At least acknowledge if this is fixable or not? 


Edit: This also happened with the Vuze torrent client, it would not download anything at all.

Link to comment
Share on other sites

  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...