Jump to content

Error: the system cannot find the file specified (WriteToDisk)


Recommended Posts


I'm having this problem since I have reinstalled my OS to Windows 8.1 Pro. Whenever I try to download anything, it keeps saying "Error: the system cannot find the file specified (WriteToDisk)" just after 5 seconds of downloading. I have already tried doing many things:

- uTorrent ran as Administrator, separate partition created with all objects removed in "Permissions" and added "Everyone" with all permissions. Tried with actual hard drive and RAMDisk.

- Modifying permissions in my existing "Downloads" folder.

- Trying to download the file on every single partition I had, even tried downloading on my pendrive and my mobile phone

- Reassuring myself that path lenght limit hasn't been reached - it wasn't

- Turning off drive buffer

- Completely reinstalling uTorrent (removing all uTorrent files, clearing the registry, rebooting)

- Installing older versions - 3.2 and 3.3

I also tried every single solution found on these forums and on Troubleshooting page. None of those have helped. Do you have any ideas what would cause the problem? uTorrent is the only program that's having issues with downloading files, I can use any other browser or download manager to download files successfully. But not uTorrent :(

Link to comment
Share on other sites

I only had this problem when I was using my WIndows 7 SP1 Ult 32-bit machine. My WIndows 8.1 Pro Toshiba Laptop, I have no issues with uTorrent. Could be the disk is failing. Try running chkdsk on your torrent drive. It could help. Just a suggestion.

Link to comment
Share on other sites

  • 2 months later...
  • 3 months later...

I have been having this very issue for months, maybe a year.   When this occurred I had no clue what to do.  So, when in doubt, reboot and restart utorrent.  One word of caution.  Whatever torrent or file you were attempting to get when you got the error must be removed.  I highly suggest, based on my ability to live with this problem, is that you use the following to delete:  Remove And Delete .torrent + Data.  I ran into some issues trying to use utorrent, so the next time prior to rebooting the PC I "Remove And Delete .torrent + Data and utorrent runs perfectly.


It might last for a a day or a few days or maybe a month without doing it again.  But I have never found a way to fix the issue other than the method I described.  Note:  I am not presuming that no one having this issue thought to reboot their PC, or totally deleted the torrent + Data prior to rebooting.  But I can attest to the fact that it works.


My source HDD is connected to the PC via USB.

Using Win7 and running utorrent on 32bit.

Using current version of utorrent


Hope this helps and I hope some genius will find and fix this issue for good.

Link to comment
Share on other sites

  • 3 weeks later...

I experienced this problem after I re-installed Windows, and I removed one of hard disk drives, the one which the last torrent was downloaded on it;

I guess the error occurs cause uTorrent tried to save torrent file in the former path which didn't exist; so resetting uTorrent settings or doing a clean install of uTorrent might fix the issue.

- - - - -  - - -

** solution:

method 1:  Manually set & verify torrent download path):

  right-click on Torrent in uTorrent>Advanced>Set Download Location..., (select Folder)      >this needs to be done for each torrent facing this error

- - -

method 2:  (set global download folder for all torrents, i didn't use this way, but it seems to work as well):

    in uTorrent; Options>Preferences;  in Directories tab:  [x] Put new downloads in (select the directory)

I just created this account to share this solution.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...