Archived

This topic is now archived and is closed to further replies.

N4TE_B

uTorrent Mac 1.8.6 Beta

12 posts in this topic

2014-09-11: Version 1.8.6 Beta

Download this version here


Fixes:

  • Added option to purchase the Ad-Free version of the uTorrent client

 

  • Ad-Free activations automatically occur when client is reinstalled

 

  • Ad-Free licenses work for both uTorrent and Bittorrent clients

 

  • Fix for application crashes while seeding if window is not in-focus

 

  • Fix for uTorrent client not starting without an internet connection

 

 

Release Notes for current and past releases can be found at the Mac Release Notes Page

Share this post


Link to post
Share on other sites

Just signed up to this forum to report that my customized toolbar vanishes with each restart/update with this beta build. It's nothing major, since it doesn't affect the performance of the application, but it's a little frustrating to modify it each time i restart uTorrent.

Share this post


Link to post
Share on other sites

I am getting a "utorrent cannot be opened because of a problem".  It is my third try re installing the app.  Going back to 1.8.4 and this time un-checking autoupdate!

Share this post


Link to post
Share on other sites

Well, now i could not even go back to utorrent 1.8.4, I think it has something to do with the installer! Correct me if i am wrong but utorrent did not use an installer before, you would just click the dmg and then the icon would appear and you would drag it over to app fplder. Now they are using an installer, even with the older versions and they are not working on my mac! Luckily i am running both Snow Leopard and Mountain Lion with a partition between both. I had to drag the utorrent from ML to SL to have utorrent on SL again. If anyone knows what is going wrong, please let me know! I would like to upgrade to latest version in the future! 

Share this post


Link to post
Share on other sites

What are minimum system requirements?

 

OS Version:      Mac OS X 10.6.8 (10K549)

 

 

Dyld Error Message:
  Library not loaded: /usr/lib/libc++.1.dylib
  Referenced from: /Applications/uTorrent.app/Contents/MacOS/uTorrent
  Reason: no suitable image found.  Did find:
/usr/lib/libc++.1.dylib: mach-o, but wrong architecture
/usr/lib/libc++.1.dylib: mach-o, but wrong architecture
 
 
file /usr/lib/libc++.1.dylib
/usr/lib/libc++.1.dylib: Mach-O 64-bit dynamically linked shared library x86_64

Share this post


Link to post
Share on other sites

Here's my reply to "Think I've accidentally deleted something important" in Troubleshooting (Mac). That topic has other replies all relating to 1.8.6 release failing on 10.6.8 which is what all entries in current topic actually relate to:

Posted 31 October 2014 - 05:44 PM

For several days I've been trying to fix the problem that the current Mac release, 1.8.6, CAN NOT RUN ON OS X 10.6.8, at least on Mac Book Pros. (I have always declined the installation of other software so have nothing to say re any problems caused by the spigot-extensions). The library libc++.1.dylib is not part of the standard 10.6.8 install. Unfortunately the MacPorts current release of libcxx installs a version of libc++.1.dylib which results in slightly different error messages:(selected portions)
Process:         uTorrent [22693]
Path:            /Applications/uTorrent.app/Contents/MacOS/uTorrent
Identifier:      com.bittorrent.uTorrent
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  launchd [118]
.....
Date/Time:       2014-10-30 14:28:55.061 -0700
OS Version:      Mac OS X 10.6.8 (10K549)
Report Version:  6
....
Dyld Error Message:
 Library not loaded: /usr/lib/libc++.1.dylib
 Referenced from: /Applications/uTorrent.app/Contents/MacOS/uTorrent
 Reason: no suitable image found.  Did find:
    /usr/lib/libc++.1.dylib: mach-o, but wrong architecture
    /usr/lib/libc++.1.dylib: mach-o, but wrong architecture

I am trying to find out what architecture is needed for the I.8.6 version of uTorrent for Mac. Then I will attempt to determine if there is away to get the MacPorts libcxx package to include versions of the libraries for this architecture.

I have occasionally over the past few months tried to update to the 1.8.6 release of uTorrent for Mac. All of these have resulted in a failure to start and an error report which began like my excerpt above. Because of the 4th line "Version: ??? (???)", prior to yesterday, I assumed some low level undiagnosable problem was occurring and never read down to see the dyld error message. Since I had and earlier version, 1.8.2(29019) installed under the app name uTorrent_1_8_2(29019) I never lost access to some working version.

-----------------------

Here's an addition which I added in a reply to "Utorrent wont work on my mac 10.6.8" recently posted to Troubleshoot(Mac):

 

Since that time I've determined that all builds of 1.8.6 (at least when installed on Mac Book Pros under 10.6.8) are built for i386 rather than u86_64.  Also while MacPorts libcxx claims to support both i386 and u86_64, requesting an install of a universal version of libc++.1.dylib results in a long preparation of universal versions of many prerequisite apps and then a failure when it comes to building the universal version of libc++.1.dylib. So I've not yet been able to suggest a solution. The work around of installing an earlier version, <=1.8.4 all seem to have worked on 10.6.8, seems to be best at present.  Personally before I install a new version I always manually rename /Applications/uTorrent.app to /Applications/uTorrent_#_##_###(build no), where version no of uTorrent is #.##.###.

------------------------------------------------

If you have any Time Machine or other backup of an earlier running version of uTorrent you might be able to restore that version of /Applications/uTorrent.app.

 

Share this post


Link to post
Share on other sites

Same problem as others. I'm running 10.6.8 (snow leopard) and the update won't open. Crashes on open. Luckily I hadn't deleted my trash, so I pulled the old version back out of the trash.

 

Also, this instllation of Yahoo as a home page is annoying.

Share this post


Link to post
Share on other sites

I am getting this message and torrents will not download: Failure uTorrentMac 1.8.6B build 2900 is no longer allowed or not yet approved"

Share this post


Link to post
Share on other sites