Jump to content

Can not download torrents, stuck on "connecting to peers"


Recommended Posts

Hey there,


So im pretty new to this forum and im sure this has been a problem that occurs often, but for some reason i cant download at all on utorrent atm. I get to "connecting to peers" and it doesnt get further.


I have tried a few things including,


1. Ticking Enable UPnP port mapping


2. Changing protocol encryption to enabled and forced 


3. Disabling and re-enabling DHT


Im not sure what info will be needed, but i can say the torrent im trying to get currently has many seeders (800+)


DHT says "waiting for announce"


Local peer discovery, and peer exchange say "waiting"


The rest says connection timed out.


So yeah thats all i can offer so far, so if anyone knows what to do help would be appreciated! Thank you in advance for the help guys! :D

Link to comment
Share on other sites

I use avast free version. And no after testing slackware and also movies i do not have the same problem. So the only thing that isnt working for me now is games. Every game i have tried in the last 24 hours hasnt worked.


On the slackware download i can see that DHT still says waiting for announce.


It seems that the connection to the games trackers is what doesnt work.. but that shouldnt be a stable problem between multible downloads and diffrent games right?


thanks alot for helping btw!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...