Jump to content

Utorrent wont work on my mac 10.6.8

Razzzle 4

Recommended Posts

Can anyone help, I down loaded utorrent from the net and Yahoo took over my web broswer I sorted that.

I then went to open utorrent and it said Utorrent cannot open because of a problem.


Check with developer to make sure utorrent works with this version of mac OSX you may need to reinstall the aplication. Be sure to install any available updates for the application and Mac OSX. 

I have updated my version osx 10..6.8 and downloaded utorrent a cople of times now and the same problem happen!!1 It use to work fine for the last year or so, Im at my witts end can any one help out there!!

Link to comment
Share on other sites

I had the same issue but I uninstalled the utorrent from the applications and then installed the version that says 

"µTorrent Stable (Old) With PPC Support (1.6.5 build 27624)" from the link http://www.utorrent.com/downloads/mac?us


When it asks if you want to download the last update I clicked "Remind me later" so it won't install any update. 


The option "skip this version" is probably equally good.


Hope it works for everyone else!



Link to comment
Share on other sites

Hi all, new to the forums today but been a UTorrent user for many years.


Had exact same trouble yesterday-downloaded an update on my Mac, accidentally clicked 'Accept Offer' instead of 'Decline Offer' which defaulted my browser to Yahoo instead of Google (cheers), changed it back after much messing, realised I'd lost all my Bookmarks, opened UTorrent which then failed with the same message as Razzzle 4, tried again which failed, deleted it and re-installed it which failed again, googled a solution which bought little answers, started crying, stopped crying, left it till today, re-installed but same failure, contemplated leaping off a cliff, thought better for it, googled again and found this forum post, followed same procedure as Japa19 (cheers buddy) and all is well again.


Haven't had the request to update the version yet but will decline it as recommended. Shame really. I searched further and found a message from UTorrent twice saying they will NOT support older versions of UTorrent, which is fine if they want people on the latest version, but only if the latest version doesn't fail.


I'll be happy to update once the bugs are ironed out...

Link to comment
Share on other sites

Here's my reply to "Think I've accidentally deleted something important" in Troubleshooting (Mac). That topic has other replies all relating to 1.8.6 release failing on 10.6.8:

Posted 31 October 2014 - 05:44 PM

For several days I've been trying to fix the problem that the current Mac release, 1.8.6, CAN NOT RUN ON OS X 10.6.8, at least on Mac Book Pros. (I have always declined the installation of other software so have nothing to say re any problems caused by the spigot-extensions). The library libc++.1.dylib is not part of the standard 10.6.8 install. Unfortunately the MacPorts current release of libcxx installs a version of libc++.1.dylib which results in slightly different error messages:(selected portions)
Process:         uTorrent [22693]
Path:            /Applications/uTorrent.app/Contents/MacOS/uTorrent
Identifier:      com.bittorrent.uTorrent
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  launchd [118]
Date/Time:       2014-10-30 14:28:55.061 -0700
OS Version:      Mac OS X 10.6.8 (10K549)
Report Version:  6
Dyld Error Message:
 Library not loaded: /usr/lib/libc++.1.dylib
 Referenced from: /Applications/uTorrent.app/Contents/MacOS/uTorrent
 Reason: no suitable image found.  Did find:
    /usr/lib/libc++.1.dylib: mach-o, but wrong architecture
    /usr/lib/libc++.1.dylib: mach-o, but wrong architecture

I am trying to find out what architecture is needed for the I.8.6 version of uTorrent for Mac. Then I will attempt to determine if there is away to get the MacPorts libcxx package to include versions of the libraries for this architecture.

I have occasionally over the past few months tried to update to the 1.8.6 release of uTorrent for Mac. All of these have resulted in a failure to start and an error report which began like my excerpt above. Because of the 4th line "Version: ??? (???)", prior to yesterday, I assumed some low level undiagnosable problem was occurring and never read down to see the dyld error message. Since I had and earlier version, 1.8.2(29019) installed under the app name uTorrent_1_8_2(29019) I never lost access to some working version.


Since that time I've determined that all builds of 1.8.6 (at least when installed on Mac Book Pros under 10.6.8) are built for i386 rather than u86_64.  Also while MacPorts libcxx claims to support both i386 and u86_64, requesting an install of a universal version of libc++.1.dylib results in a long preparation of universal versions of many prerequisite apps and then a failure when it comes to building the universal version of libc++.1.dylib. So I've not yet been able to suggest a solution. The work around of installing an earlier version, <=1.8.4 all seem to have worked on 10.6.8, seems to be best at present.  Personally before I install a new version I always manually rename /Applications/uTorrent.app to /Applications/uTorrent_#_##_###(build no), where version no of uTorrent is #.##.###. 

Link to comment
Share on other sites

Same story here.  I have OSX 10.6.  uTorrent was working just fine until this morning when I was prompted to update the software.  When I did so I was dead in the water.  The program wont even start up now. I get an error stating that program cannot start because of a "problem".  I found this very helpful.  Uninstalling and re-installing a fresh copy does no good.  


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...