Jump to content

No Solution for "connecting to peers" problem


Recommended Posts

Hello uTorrent Community,


I was wondering if there is a guaranteed solution that anyone has located for the "connecting to peers" problem that occurs. It seems to a pretty popular problem but no sufficient solution seems to be offered. There is no perfect fix. I've tried many proposed solutions and still cannot download any content. Has anyone experienced this and solved the problem??? Please Help 



This is my previous post:



Link to comment
Share on other sites

I've been having the same issue off and on for the last few weeks, and now it seems to be stuck at Connecting to Peers with various Connection Timed Out messages. I have tried the tip above, as well as a few other suggestions, with nothing working.


What I have:

Windows 8.1

utorrent 3.4.2 (build 35702) 32-bit

ISP is CenturyLink


I have been using TorGuard Proxy service for some time with no problems.


Recently I upgraded my MalwareBytes to Premium, and I initially suspected that MalwareBytes was blocking uTorrent activity, so I added the utorrent (app/roaming) process and torguard into the Process Exceptions on MB. Sometimes my torrents would work like normal, and other times they would sit for a day or two trying to connect. Now they're stuck all the time. Help please!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...