Jump to content

uTorret does not open


Recommended Posts



For the past couple of days, my uTorrent client does not open.


More precisely, I can see its process running in Process Explorer (in purple) but the actual window does not open. The process's memory is stuck at a certain amount and it doesn't consume CPU cycles.


I'm using Windows Firewall and Windows Security Essentials on a Windows 7 machine.


Any ideas?

Link to comment
Share on other sites

Thank you again,


Ending the process was something I had tried to do previously and it indeed closed the process, but it made no difference since uTorrent would run into the same problem the next time it was launched.


Right now, the problem seems to have fixed itself. I didn't do anything else, it just worked after a reboot. And, to be absolutely clear, I had already rebooted several times in an effort to troubleshoot but it hadn't worked. This time, the problem is gone without explanation.


I couldn't help notice that cosenza987 had reported almost the same issue in uTorrent not opening. His client was also failing to open but it was showing the message: "uTorrent has stopped working". Just like me, "it started working after some restarts, I don't know what had happened." Maybe it's something the developers would want to look into.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...