Jump to content

Windows ran out of memory - crash dump has been saved


Recommended Posts

Ok, I'm running Windows 8.1, and this problem seems to have started occuring just after the latest update. I'm not sure if it's relevant.


I now get the following messages constantly:


Windows ran out of memory. Unable to allocate 1078804802 bytes, followed by uTorrent has crashed. A crash dump has been saved as:


I started by upgrading utorrent to build 38429, then tried reinstalling. I reset the settings, and I also uninstalled and ran CCleaner before reinstalling.


How do I upload the crash dump file (it is slightly bigger than the 500k limit), and is there anything else I should do?


Thank you.

Link to comment
Share on other sites

Cache disque (in French)


Définir manuellement is unchecked

Everything else is checked, except for the last one, Augmenter automatiquement la taille du cache si celui-ci devient insuffisant.


There should be no NVidia software on the computer.


On a side note, I've got Adblock Plus for IE, CCleaner and standard Windows Defender.

Link to comment
Share on other sites

I started having this problem fairly constantly after going to build 38429 and the beta (build 38437) too. I'm on Windows 7 x64. Unfortunately, going back to build 38397, 37951 and 37754 haven't helped so far. Neither has deleting the settings.dat and working off of a new one. Although it seems like the problem takes longer to manifest after clearing the settings.dat, although that is possibly a coincidence. My cache settings are currently the default uTorrent 3.4.2 settings. I'm not using any nvidia software on this computer.


I selected to allow the crash dump to upload, for what its worth. Any other suggestions worth a try?

Link to comment
Share on other sites

I would also like to toss my hat into this "Windows ran out of memory" arena..  It has started out of the blue. No changes in dowloading nor antything out of the ordinary.


uTorrent Version: 3.4.2 Beta (build 38463) installed AFTER the errors started hapening this past weekend.



Custome Built

Windows 7 x64

Intel Core2Quad 2.40 GHz

8 GB Memory

3 HDD (various sizes, none over 50% usage)

AMD HD6450



What else is needed to help figure out this annoying bug. It's wreaking havok on my torrent ratios.


Thanks for any help.

Link to comment
Share on other sites

I am having the same problem, which I noticed for the first time on Jan. 30.  Suddenly a window will pop up that says something like, "Utorrent failed to allocate XXXXXXXX bytes."  After a few of those in rapid succession, utorrent crashes.  I have been using utorrent 3.4.2 build 38429 running on Windows 8.1 without incident for a while, so I suspect that the problem may be with a recent Windows update or with one of the trackers.


Here is one peculiar thing that I started to notice at the same time the crashes began: the total download speed displayed at the bottom of the utorrent window will sometimes be far greater than the sum of the individual file download speeds.  For example, right now the total download speed is consistently showing to be 1.1-1.2 MB/s, whereas the total of all individual file download speeds varies from 250 kB/s - 300 kB/s.  I wouldn't think that the DHT and tracker communication would transfer data so quickly, but maybe they are.  When I examine the ethernet activity in Task Manager, the receive data rate matches the total download rate displayed in utorrent fairly well (the rate shown in Task Manager is actually about 10% higher than the rate shown in utorrent).  This indicates that the total download rate displayed in utorrent is not in error.  For some reason, utorrent is downloading much more than just the active files.  Whatever this is, I believe this is what is causing the crash.  Before a crash, the total download rate displayed will suddenly spike to 2.5-3.5 MB/s.


For anyone who is having this type of crash, please check to see if you have download speed anomalies similar to what I'm having.


I also suspected malware but Zone Alarm scans have come up negative, and there is no other unusual system behavior on that machine.


Thanks to everyone who already posted on this issue and to anyone who replies.

Link to comment
Share on other sites

I have also had this problem. This just suddenly started happening to me around January 28-30 roughly. I run 7 x64 PRO, Intel i5 Haswell-E, 16GB RAM, tons of HD space, etc. My rig is a very clean install as I use it for work. I am running onboard video and no NVIDIA software has ever been installed on this system. I do use a VPN service but this has never been a problem over the years and the encryption is set to a low 128 bit.


I was running build uTorrent 3.4.2 37248 with no problems. I suddenly got a 'Windows ran out of Memory' error and it has kept happening ever since. I Googled the problem and tried some of the fixes to no avail. I tried completely resetting everything to defaults, uninstalling/reinstalling, I even disabled the VPN, etc. For the record, my install is only slightly tweaked, but 99% near defaults anyway. I even tried updating uTorrent and have the latest stable build.




The only things I can think of that might be at issue and the ONLY things that changed for me recently are -


1 - I did do the most recent Windows updates so possibly that new .Net  update is causing this?


2 - I read that this happens when downloading large files. I found a large 55GB torrent of various Linux ISOs that I was going to check out. The error did not start until AFTER I attempted this. I did delete it then tried the fixes mentioned above and the problem keeps happening to me even if I just try to download a single small <500MB torrent.

Link to comment
Share on other sites

Yeah, I noticed the total download speed is actually considerably larger than the sum of the reported download speed of the individual active files with recent builds too. Its pretty noticeable on 3.4.2 build 38554 (Windows 7 x64). I agree that a recent Windows update could be a factor, since I'm using a system that is patched up to date. That may explain why going several stable releases back doesn't seem to help much with the memory leak-like behavior where uTorrent takes up > 1GB ram and crashes out.

Anyone try a build from several weeks ago? I'll try that but going a month back didn't help with the RAM issue, anyway.

Link to comment
Share on other sites



I stopped nvidia's Network Access Manager from loading at startup, and I have confirmed that it no longer appears in Task Manager's list of active processes.  The problem has reoccurred once since preventing it from running.  FWIW I had nvidia's NAM running for months with no apparent problems.


Here's another interesting observation: Under utorrent Preferences -> Bandwidth, the Global Download Rate Limiting setting has no effect on the "ghost" download rate (this is what I'm calling the download rate that is above and beyond that associated with files).  This setting does still affect the combined download rate for actual files.  As dysonsphere mentioned, I still show a large download rate even with no active files.  Viewing utorrent's process details, it appears that the Working Set (Memory) and Memory (private working set) are increasing at about the same rate as the ghost download rate is.  So, whatever this traffic is, it is being stored in memory until utorrent crashes, which seems to happen when well over 1 GB of memory has been allocated.


I am only speculating now, but this looks like someone attacking utorrent users, flooding them with garbage data that utorrent is storing in memory until it crashes.  I can't think of another logical explanation for what I'm seeing.  Hopefully this crash is not being used as an exploit but I can't rule that out yet.  I don't see any indications of other system problems so far, for whatever that's worth.  All unusual traffic seems to cease when utorrent crashes.


I have had pretty good luck with Zone Alarm for the most part and I especially like the operating system firewall that can control outbound communications.  Configuring ZA properly can be a bit tricky.  There are a huge number of improvements and expansions I wish they would make to it, and some bugs have popped up recently that haven't beed addressed.  But it seems to have done an excellent job of detecting malware, at least as far as I am able to tell.  What security software would you suggest instead?

Link to comment
Share on other sites

I stopped nvidia's Network Access Manager from loading at startup, and I have confirmed that it no longer appears in Task Manager's list of active processes.

This doesn't remove its hooks, and as long as those hooks are in place, they can interfere.

What security software would you suggest instead?

The software integrated with windows. ZoneAlarm has historically been extremely poorly coded, causing entire system freezes when it doesn't outright crash.

It also doesn't listen when you tell it to disable. You MUST uninstall to disable.

Link to comment
Share on other sites

This is also began for me around 1/30 and was having the same issue/symptoms as you until I read your comment. Based on your analysis, it seemed like something in DHT so I disabled DHT and the crashes have stopped so far...  Not sure what's wrong with DHT but now that it's disabled, everything appears to be back to normal.

Link to comment
Share on other sites

OK, I uninstalled nvidia's NAM and rebooted. Should have done that a long time ago, it was crapware anyway. I have ZoneAlarm running on half a dozen desktop machines that are all very stable. Most of them run for weeks without being rebooted. But you are absolutely correct that not all ZA processes terminate when you exit the program. The Windows Firewall seems to work well for blocking incoming traffic, but the problem is that it allows outbound traffic by default -- not very secure. Manually blocking each process that doesn't really need internet access is time consuming.

The problem with utorrent did still reoccur once after uninstalling nvidia NAM and rebooting. However, approximately 16 hours ago, the problem suddenly stopped. I have no explanation why.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...