Jump to content

Developing on the 0.388 WebUI release


Recommended Posts

Hello all, this is my first post here so please bear with me :D


I've recently just started using the WebUI feature of BitTorrent, and I must say that it goes a long way in managing torrents while I am away from my computer.


However, I can't help but notice the seemingly ancient interface:



I understand that developers don't just start working right away because one user doesn't like how the project looks, so I've decided to have a go on making a WebUI fork and working on it myself. I know basic HTML(4) and CSS, and a little bit of JS.


My aim is to make the WebUI conform to Google's Material Design guidelines using the Bootstrap framework, which I've previously used in my site so I'm quite familiar with it.


I started out by making a build script for the project, since I've seen that the webui.zip contains multiple GZip archives that contain the file they were named after, like index.html.gz for index.html. I ended up with this.

I tried building with the script without modifying the project, and it was successful - it gave me this ZIP, which I promptly tried using.


Loading the page with Firefox told me that the WebUI seems to not have been installed, which was weird - I knew I had put it in the right place and that the ZIP had the same hierarchy as the original one.


Where did I go wrong? Could it be that I zipped/gzipped something the wrong way? Help would be appreciated.

Link to comment
Share on other sites

What I can see on the first look is that inside your webui.zip you have a folder .tmp which doesn't exist in Ultima's version (the public one).


... now I feel stupid.

Apparently my script tells zip to put the contents in .tmp inside the ZIP and not in the root folder. It works now!


I'll update this thread when I make more progress.

Link to comment
Share on other sites

Addtitional: it seems you started with the build 0.380 and not the last 0.388 from Ultima, right?

And you have the additional "dialogs.css" inside.

Yes, I must have mixed up my source files.

Anyway, it's working now :D and a hell lot more organized. (See here.)

I'll continue working on this probably in the next few weeks.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...